+ Antworten
Seite 1 von 27 1 2 3 4 5 11 ... LetzteLetzte
Ergebnis 1 bis 10 von 261

Thema: Portierte Version der PonyGallery ML 2.5.1

  1. #1
    War schon öfter hier
    Registriert seit
    20.02.2008
    Beiträge
    185
    Bedankte sich
    10
    Erhielt 106 Danksagungen
    in 55 Beiträgen

    Standard Portierte Version der PonyGallery ML 2.5.1

    Hallo liebe Joomla-Gemeinde,

    zuerst will ich mal ein großes Lob an die Entwickler der PonyGallery ML loswerden.
    Diese Bildergalerie ist meiner Meinung nach wirklich die beste, die es für Joomla gibt.

    Da wir unsere Vereinsseite vor kurzem auf Joomla 1.5 umgestellt haben und trotzdem nicht auf die PonyGallery verzichten wollen, habe ich kurzer Hand angefangen die Galerie selbst für die neue Version umzuschreiben.
    Erste Tests waren sehr erfolgreich und deshalb möchte ich euch die portierte Version auch nicht vorenthalten. Ich hoffe die Entwickler haben nichts dagegen.

    Im Anhang müsstet ihr das entsprechende Zip-Archiv finden.

    Diese Version kommt ohne den Legacy-Mode aus und läuft auf unserem Server bisjetzt auch fehlerfrei, aber aufgrund des riesigen Funktionsumfangs konnte ich natürlich nicht alle möglichen Konfigurationskombinationen ausprobieren.
    Deshalb würde ich mich auch sehr über Rückmeldungen über vorhandene Bugs freuen.

    Gruß
    Chraneco

    Bugfixes
    24.06.08 toolbar.ponygallery.html.php geändert (siehe Beiträge #6 und #8)
    27.06.08 Kodierung der Datenbankeinträge geändert (siehe Beiträge #12 und #13)
    27.06.08 Kodierung der Sprachdateien geändert (siehe Beiträge #24 und #25)
    01.07.08 Slash in common.ponygallery.php eingefügt(siehe Beiträge 16# und 18#)
    02.07.08 Pagination im Adminbereich funktioniert jetzt (siehe Beiträge #32 und #37)
    03.07.08 kleinere Fehler behoben (siehe Beiträge #43, #45 und #46)
    12.07.08 Kommentare vom Frontend aus löschen (siehe Beitrag #51)
    19.07.08 toolbar.ponygallery.html.php geändert (siehe Beiträge #89 und #90)
    20.07.08 Kommentarbenachrichtigung und send2friend-Mail angepasst (siehe Beitrag #100)
    24.08.08 Fix für lokale Xampp-Installationen (siehe Beiträge #53 und #54)
    24.08.08 größeres Rechte-Problem behoben (siehe Beitrag #139)
    24.08.08 neue EasyCaptcha-Version wurde im Backend nicht erkannt (siehe Beitrag #139)


    Diese Änderungen sind im folgenden Zip-Archiv schon enthalten.

    Hier findet ihr dann jetzt auch die angepassten Versionen des PonyImages-Moduls und der CB-Tabs.

    Hinweis: Da die JoomGallery 1.5 Stable jetzt erschienen ist, empfehle ich allen Usern der portierten Pony die Migration zur JoomGallery.
    Dazu müsst ihr sie euch nur hier herunterladen und im Migrationsmanager der JoomGallery die Migration starten.
    Die JoomGallery 1.5 benötigt den Legacy-Mode selbstverständlich ebenfalls nicht und wird ständig weiterentwickelt, während ich den Support der portierten Pony hier jetzt auch einstelle. Bei über 1800 Downloads (der Zähler unten wurde bei jedem Update wieder zurückgesetzt) kann man sagen, dass sie sehr gut angekommen ist.
    Darüber bin ich sehr froh und auch glücklich, dass ich über sie meinen Weg in das JoomGallery-Team gefunden habe.

    Die Galerie wurde inzwischen insgesamt 561x heruntergeladen
    Angehängte Dateien
    Geändert von Chraneco (27.12.2009 um 22:56 Uhr)


  2. #2
    videoandfun
    Gast

    Standard

    ich habe auf meiner 1.5 schon seit ein paar tagen die PonyGallery am laufen... weil i-wer hier im Forum auf einer anderer Seite so eine Joomla 1.5 Version gefunden hat...

    wenn das deine war... vielen Dank dafür
    wenn nicht, dann vielen Dank für diese Version

    Finde ich echt stark das die beste Gallery für Joomla nun auch endlich unter 1.5x lauft (natürlich nicht mit Herstellerbegutachtung und so)... aber für die nächsten 1-2 Monaten reicht diese Version allemal aus, wenn dann die so lang ersehnte JoomGallery kommen wird. Zeit bis zum Erscheinen wird jetzt einfach mal so von mir geschätzt...

    Aktueller Entwicklungsstatus siehe hier: http://www.joomgallery.net/roadmap-joom.html
    JoomGallery 1.0 ist dann der offiziele Nachfolger der Ponygallery 2.5.1 für Joomla 1.0x & 1.5x

  3. #3
    Gehört zum Inventar Avatar von deejey
    Registriert seit
    22.04.2006
    Ort
    HH
    Beiträge
    9.829
    Bedankte sich
    706
    Erhielt 1.916 Danksagungen
    in 1.683 Beiträgen

    Standard

    Hier gibts auch Infos zu einer angepassten PonyML für 1.5, habe sie nicht ausprobiert, allerdings weiß man wenigstens von welcher Seite sie kommt, im Gegensatz zu dem angebotenen Download vom relativ neuen Mitglied "Chraneco", der keinen Link zu seiner Vereinsanpassung oder irgendeinen Hinweis bezügl. Vertrauenswürdigkeit hinterlassen hat.
    Kein Support über PM; Ignoriermodus aktiv bei "dringend", "schnell", "eilt", denn: Zeit ist relativ

  4. #4
    War schon öfter hier
    Registriert seit
    09.10.2006
    Ort
    Berlin
    Alter
    58
    Beiträge
    236
    Bedankte sich
    8
    Erhielt 46 Danksagungen
    in 44 Beiträgen

    Standard

    Na gut, aber die oben vorgestellte Version kommt ohne den Legacy-Mode aus, die ältere benötigt ihn laut Ausage auf der Website. Ich muß allerdings zugeben, daß ich auch immer etwas skeptisch bin, wenn ein gutes Tool einfach so aus dem Nichts auftaucht. Es wäre wirklich schön, wenn man sich das mal auf der erwähnten Website in Aktion ansehen könnte. Die Version ohne Legacy wäre mir schon lieber.

  5. #5
    War schon öfter hier
    Registriert seit
    20.02.2008
    Beiträge
    185
    Bedankte sich
    10
    Erhielt 106 Danksagungen
    in 55 Beiträgen

    Standard

    das stimmt, bezüglich Vertrauenswürdigkeit kann ich nicht viel bieten, da ich bisjetzt hier noch nicht sehr aktiv war und selbst auch keine richtige Website habe.
    Ich hoffe dennoch, dass ihr die Galerie einmal ausprobiert und mir Feedback geben könnt.

    Hier findet ihr die Galerie des SC Weiler. Die Seite und die Galerie selbst sind natürlich noch nicht vollständig, aber ihr könnt sie euch hier ansehen. (EDIT 28.11.08: Link rausgenommen, da dort inzwischen die JoomGallery läuft)
    Betrachtet man die Galerie alleine, dürfte man auch keinen Unterschied zu den Installationen auf Joomla 1.0.x erkennen. Nur im Backend hat sich durch die neue Toolbar und die Untermenü-Leiste etwas geändert.
    Falls ich irgendwelche bestimmte Konfigurationspunkte zu Anschauungszwecken ändern soll, tu ich das gerne, da die Seite ja bisjetzt noch nicht die offizielle Homepage unseres Vereins ist.

    Hier hab ich die Version auch schon im JoomGallery-Forum vorgestellt.

    Gruß
    Chraneco

  6. #6
    War schon öfter hier
    Registriert seit
    09.10.2006
    Ort
    Berlin
    Alter
    58
    Beiträge
    236
    Bedankte sich
    8
    Erhielt 46 Danksagungen
    in 44 Beiträgen

    Standard

    So, hab das Pony mal installiert, die Installation verläuft ohne Fehlermeldung, beim Anlegen einer Kategorie erhalte ich dann aber
    Fatal error: Class 'Kategorie-Manager ' not found in /homepages/15/d185503986/htdocs/joomla/libraries/joomla/language/language.php on line 171

    Gruß
    Andreas

  7. #7
    Kommt häufiger vorbei
    Registriert seit
    14.12.2005
    Ort
    Neuhemsbach
    Alter
    55
    Beiträge
    438
    Bedankte sich
    20
    Erhielt 33 Danksagungen
    in 32 Beiträgen

    Standard

    Dito, hab s auch grad getestet.

  8. #8
    War schon öfter hier
    Registriert seit
    20.02.2008
    Beiträge
    185
    Bedankte sich
    10
    Erhielt 106 Danksagungen
    in 55 Beiträgen

    Standard

    Hi,

    mergwürdiger Fehler, aber je mehr ich nachdenke vielleicht doch logisch

    anscheinend werden im Funktionsaufruf

    PHP-Code:
    JToolBarHelper::titleJText::__PONYGALLERY_CAT_MANAGER ' :: ' _PONYGALLERY_ADD_CAT _PONYGALLERY_CATEGORY), 'categories'); 
    Datei: toolbar.ponygallery.html.php

    die beiden Doppelpunkte, die hier eigendlich nur als String (rot) dargestellt werden (zwischen_PONYGALLERY_CAT_MANAGER und _PONYGALLERY_ADD_CAT) als solche zwei Doppelpunkte interpretiert, die zum Aufruf einer Funktion innerhalb einer bestimmten Klasse dienen.
    Das ersetzen dieser Doppelpunkte durch einen anderen Text sollte Abhilfe schaffen (oder aber das ganze verschlimmern ), ich kanns leider nicht ausprobieren, da es bei mir irgendwie so, wie es ist, funktioniert.

    im Anhang eine bearbeitete toolbar-Datei zum ersetzen (EDIT: diese Datei ist seit dem 24.06.08 im Zip des ersten Beitrags auch geändert)

    meldet euch bitte wieder, falls es dann immer noch nicht funktioniert^^
    danke
    auch für den Hinweiß

    Gruß
    Chraneco
    Angehängte Dateien
    PHP ist Spaß

    JoomGallery.net

  9. Erhielt Danksagungen von:


  10. #9
    Kommt häufiger vorbei
    Registriert seit
    14.12.2005
    Ort
    Neuhemsbach
    Alter
    55
    Beiträge
    438
    Bedankte sich
    20
    Erhielt 33 Danksagungen
    in 32 Beiträgen

    Standard

    Hi, ja jetzt funktioniert die Pony einwandfrei! Danke nochmal!

  11. #10
    War schon öfter hier
    Registriert seit
    09.10.2006
    Ort
    Berlin
    Alter
    58
    Beiträge
    236
    Bedankte sich
    8
    Erhielt 46 Danksagungen
    in 44 Beiträgen

    Daumen hoch

    Das hat schon mal geklappt, danke
    Beim FTP-Upload habe ich jetzt das Problem, daß ich im Kategorienamen das Datum verwende. Dabei wird der Punkt im Datum als verbotenes Sonderzeichen abgelehnt.
    Umlaute im Kategorienamen werden als kryptische Zeichen dargestellt, die auch nicht mit der Ersatzfunktion in der Pony-Konfiguration ersetzt werden können.
    Im ersten Überblick sieht das ganze schon mal gut aus.

+ Antworten
Seite 1 von 27 1 2 3 4 5 11 ... LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein