Ergebnis 1 bis 4 von 4

Thema: Weißer, vertikaler Balken mit Internet Explorer

  1. #1
    Neu an Board Avatar von Nanz
    Registriert seit
    08.03.2006
    Alter
    31
    Beiträge
    92
    Bedankte sich
    12
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard Weißer, vertikaler Balken mit Internet Explorer

    Hallo!

    Erstmal sorry dass ich euch schon wieder nerven muss...aber wen soll ich sonst fragen?

    Also: Meine Seite wird mit Firefox ohne Probleme dargestellt. MIt IE dagegen entsteht rechts so ein weißer, vertikaler Balken: www.bv-nittendorf.de
    In einem anderen Thread habe ich gelesen dass das an der Größe des Bildes im Content liegt, was aber bei mir nicht der Fall ist...
    Bitte dringend um Hilfe!!!
    Danke, Nanz
    Geändert von Nanz (23.03.2006 um 19:29 Uhr)

  2. #2
    Kommt häufiger vorbei
    Registriert seit
    08.12.2004
    Beiträge
    431
    Bedankte sich
    8
    Erhielt 73 Danksagungen
    in 57 Beiträgen

    Standard

    Hallo,
    im IE sind die Schalter vom pollmodul nebeinander, "Abstimmen" "Ergebnisse" im FF untereinander. Deshalb wird im IE das Modul verbreitert mit den Effekt des weißen Streifens. Deinen Quellcode konnt ich mir nicht anschauen wegen Frames (warum das eigentlich?).

    Torsten
    aktuelle Projekte:
    Sitzmöbel - www.sedaro.de – Webshop
    Bildbearbeitung - www.adtp.de – statische W3C Seite
    Designverzeichnis - www.co-designtrends.de – Architektur, Fotografie etc.

  3. #3
    Neu an Board Avatar von Nanz
    Registriert seit
    08.03.2006
    Alter
    31
    Beiträge
    92
    Bedankte sich
    12
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Jo, da hast du recht...stimmt
    Hier ist der Quelltext des moduls:
    Hoffe du kannst mir weiterhelfen, habe leider keine Ahnung von sowas

    defined( '_VALID_MOS' ) or die( 'Direct Access to this location is not allowed.' );

    if (!defined( '_MOS_POLL_MODULE' )) {
    /** ensure that functions are declared only once */
    define( '_MOS_POLL_MODULE', 1 );

    function show_poll_vote_form( $Itemid ) {
    global $database;

    $Itemid = mosGetParam( $_REQUEST, 'Itemid', 0 );

    $query1 = "SELECT p.id, p.title"
    ."\nFROM #__poll_menu AS pm, #__polls AS p"
    ."\nWHERE (pm.menuid='$Itemid' OR pm.menuid='0') AND p.id=pm.pollid"
    ."\nAND p.published=1";

    $database->setQuery( $query1 );
    $polls = $database->loadObjectList();

    if($database->getErrorNum()) {
    echo "MB ".$database->stderr(true);
    return;
    }

    foreach ($polls as $poll) {
    if ($poll->id && $poll->title) {

    $query = "SELECT id, text FROM #__poll_data"
    . "\nWHERE pollid='$poll->id' AND text <> ''"
    . "\nORDER BY id";
    $database->setQuery($query);

    if(!($options = $database->loadObjectList())) {
    echo "MD ".$database->stderr(true);
    return;
    }
    poll_vote_form_html( $poll, $options, $Itemid );
    }
    }
    }

    function poll_vote_form_html( &$poll, &$options, $Itemid ) {
    $tabclass_arr=array("sectiontableentry2","sectiont ableentry1");
    $tabcnt = 0;
    ?>
    <form name="form2" method="post" action="<?php echo sefRelToAbs("index.php?option=com_poll&amp;Itemid= $Itemid"); ?>">
    <table width="95%" border="0" cellspacing="0" cellpadding="1" align="center">
    <tr>
    <td colspan="2" class="poll"><b><?php echo $poll->title; ?></b></td>
    </tr>
    <tr>
    <td align="center">
    <table class='pollstableborder' cellspacing='0' cellpadding='0' border='0'>
    <?php
    for ($i=0, $n=count( $options ); $i < $n; $i++) { ?>
    <tr>
    <td class='<?php echo $tabclass_arr[$tabcnt]; ?>' valign="top"><input type="radio" name="voteid" id="voteid<?php echo $options[$i]->id;?>" value="<?php echo $options[$i]->id;?>" alt="<?php echo $options[$i]->id;?>" /></td>
    <td class='<?php echo $tabclass_arr[$tabcnt]; ?>' valign="top"><label for="voteid<?php echo $options[$i]->id;?>"><?php echo $options[$i]->text; ?></label></td>
    </tr>
    <?php
    if ($tabcnt == 1){
    $tabcnt = 0;
    } else {
    $tabcnt++;
    }
    }
    ?>
    </table>
    </td>
    </tr>
    <tr>
    <td colspan="2" align="center">
    <input type="submit" name="task_button" class="button" value="<?php echo _BUTTON_VOTE; ?>" />&nbsp;&nbsp;
    <input type="button" name="option" class="button" value="<?php echo _BUTTON_RESULTS; ?>" onclick="document.location.href='<?php echo sefRelToAbs("index.php?option=com_poll&amp;task=re sults&amp;id=$poll->id"); ?>';" />
    </td>
    </tr>
    </table>
    <input type="hidden" name="id" value="<?php echo $poll->id;?>" />
    <input type="hidden" name="task" value="vote" />
    </form>
    <?php
    }
    }
    show_poll_vote_form( $Itemid );
    ?>

  4. #4
    Neu an Board Avatar von Nanz
    Registriert seit
    08.03.2006
    Alter
    31
    Beiträge
    92
    Bedankte sich
    12
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    So, habs jetzt doch selbst geschafft!
    Hab die .php file des Modules einfach mal im Dreamweaver geöffnet, und siehe da, die haben sich dort ganz einfach untereinander setzen lassen!
    Also trotzdem vielen Dank

Ähnliche Themen

  1. PNG Transparenz auch im MS Internet Explorer
    Von Benax im Forum Tipps, Tricks und Kurzanleitungen
    Antworten: 20
    Letzter Beitrag: 02.03.2012, 11:01
  2. MBT Transmenu: Internet Explorer zeigt keine Submenus
    Von rainerk im Forum Joomla Module
    Antworten: 9
    Letzter Beitrag: 13.03.2006, 23:39
  3. Kontaktformular im Internet Explorer
    Von stan83 im Forum Joomla Templates
    Antworten: 1
    Letzter Beitrag: 21.02.2006, 18:06
  4. Design Problem FireFox vs Internet Explorer
    Von jambalaya im Forum Allgemeine Fragen zu Joomla
    Antworten: 7
    Letzter Beitrag: 21.01.2006, 13:32
  5. Internet Explorer zickt bei CSS-Angaben
    Von veronica im Forum Mambo Templates
    Antworten: 5
    Letzter Beitrag: 05.09.2005, 15:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein