Ergebnis 1 bis 6 von 6

Thema: Eigenartiges Anzeigeproblem: Online IE, Lokal FF

  1. #1
    Neu an Board
    Registriert seit
    22.03.2006
    Beiträge
    88
    Bedankte sich
    13
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Eigenartiges Anzeigeproblem: Online IE, Lokal FF

    HAllo Leute
    ich verwende das Template 247portal-b-red. Online funktioniert es im FF ohne Probleme. Im IE zeigen sich hingegen verschiebungen im oberen Bereich.
    Nun habe ich für Testzwecke das Ganze lokal unter XAMPP laufen.
    Hier bekomme ich allerdings vor der eigentlichen HP den Fehler
    Code:
    Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Stefan\Desktop\xampp\htdocs\web\ff-puchberg\mambots\editors\jce.php:506) in C:\Users\Stefan\Desktop\xampp\htdocs\Web\FF-Puchberg\index.php on line 250
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Stefan\Desktop\xampp\htdocs\web\ff-puchberg\mambots\editors\jce.php:506) in C:\Users\Stefan\Desktop\xampp\htdocs\Web\FF-Puchberg\index.php on line 251
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Stefan\Desktop\xampp\htdocs\web\ff-puchberg\mambots\editors\jce.php:506) in C:\Users\Stefan\Desktop\xampp\htdocs\Web\FF-Puchberg\index.php on line 252
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Stefan\Desktop\xampp\htdocs\web\ff-puchberg\mambots\editors\jce.php:506) in C:\Users\Stefan\Desktop\xampp\htdocs\Web\FF-Puchberg\index.php on line 253
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Stefan\Desktop\xampp\htdocs\web\ff-puchberg\mambots\editors\jce.php:506) in C:\Users\Stefan\Desktop\xampp\htdocs\Web\FF-Puchberg\index.php on line 254
    Dieser Fehler kommt unter FF und IE. Bezieht sich der nun auf die Index.php oder auf den Editor? Ein Leerzeichen in der configuration.php hinter einem ; ist nicht vorhanden.
    Sicherheitshalber hier noch die Configuration.php:
    Code:
    <?php 
    if(!defined('RG_EMULATION')) { define( 'RG_EMULATION', 0 ); }
    $mosConfig_MetaAuthor = '1';
    $mosConfig_MetaDesc = 'Feuerwehr Puchberg am Schneeberg - Die Website mit Informationen über die Freiwillige Puchberg am Schneeberg, Berichte über die Jugendfeuerwehr und die Arbeit der ehrenamtlichen Hilfsorganisation.';
    $mosConfig_MetaKeys = 'Feuerwehr, Puchberg am Schneeberg,Brandschutz, Feuer, Hilfe, Retten, Bergen, Schützen, Erste Hilfe, Hilfsorganisation, atastrophenschutz, Freiwillige, Gemeinde, Blaulicht, Löschen, Feuerwehrfahrzeuge, Feuerwehrfahrzeug, Tanklöschfahrzeug, Verkehrsunfall, Brände, Gefahrgut, Unfall, Brand, Einsatzbericht, Feuerwehrtermine, 112, Notruf, Katastrophe, Notfall, Emergency, Fire, Firefighter, 
    
    Jugendfeuerwehr, JF, Fire-Department, Freiwllige Feuerwehr, Feuerwehren, Brandschutz, Brandschutzerziehung, 
    
    Feuerwehrgeräte, Florian, Einsatz, Alarmierung, Sirene, 
    
    Gerätehaus, Feuerwehrhaus, Feuermelder, Feuerwehrverein, Ehrenamt ';
    $mosConfig_MetaTitle = '1';
    $mosConfig_absolute_path = $_SERVER['DOCUMENT_ROOT'] . '/web/ff-puchberg';
    $mosConfig_admin_expired = '1';
    $mosConfig_allowUserRegistration = '0';
    $mosConfig_back_button = '0';
    $mosConfig_cachepath = $_SERVER['DOCUMENT_ROOT'] . '/web/ff-puchberg/cache';
    $mosConfig_cachetime = '900';
    $mosConfig_caching = '0';
    $mosConfig_db = 'db128224';
    $mosConfig_dbprefix = 'jos_';
    $mosConfig_debug = '0';
    $mosConfig_dirperms = '';
    $mosConfig_editor = 'jce';
    $mosConfig_enable_log_items = '0';
    $mosConfig_enable_log_searches = '0';
    $mosConfig_enable_stats = '0';
    $mosConfig_error_message = 'Diese Site ist vorübergehend nicht erreichbar.<br />Bitte kontaktieren Sie den System Administrator.';
    $mosConfig_error_reporting = '-1';
    $mosConfig_favicon = 'favicon.ico';
    $mosConfig_fileperms = '';
    $mosConfig_fromname = 'FF Puchberg am Schneeberg';
    $mosConfig_frontend_login = '1';
    $mosConfig_frontend_userparams = '1';
    $mosConfig_gzip = '0';
    $mosConfig_helpurl = 'http://help.joomla.de';
    $mosConfig_hideAuthor = '1';
    $mosConfig_hideCreateDate = '1';
    $mosConfig_hideEmail = '1';
    $mosConfig_hideModifyDate = '1';
    $mosConfig_hidePdf = '1';
    $mosConfig_hidePrint = '1';
    $mosConfig_hits = '0';
    $mosConfig_host = 'localhost';
    $mosConfig_icons = '0';
    $mosConfig_item_navigation = '1';
    $mosConfig_itemid_compat = '0';
    $mosConfig_lang = 'german';
    $mosConfig_lifetime = '3600';
    $mosConfig_link_titles = '0';
    $mosConfig_list_limit = '50';
    $mosConfig_live_site = 'http://127.0.0.1/web/ff-puchberg';
    $mosConfig_locale = 'de_DE';
    $mosConfig_mailer = 'mail';
    $mosConfig_mailfrom = 'webmaster@ff-puchberg.at';
    $mosConfig_multilingual_support = '0';
    $mosConfig_multipage_toc = '1';
    $mosConfig_offline = '0';
    $mosConfig_offline_message = 'Diese Site ist wegen technischer Wartung momentan nicht erreichbar.<br />Bitte versuchen Sie es später wieder.';
    $mosConfig_offset = '0';
    $mosConfig_offset_user = '1';
    $mosConfig_pagetitles = '1';
    $mosConfig_password = '';
    $mosConfig_readmore = '1';
    $mosConfig_secret = 'xxxxxx';
    $mosConfig_sef = '0';
    $mosConfig_sendmail = '/usr/sbin/sendmail';
    $mosConfig_session_life_admin = '1800';
    $mosConfig_session_type = '0';
    $mosConfig_shownoauth = '1';
    $mosConfig_sitename = 'FF Puchberg am Schneeberg';
    $mosConfig_smtpauth = '0';
    $mosConfig_smtphost = 'localhost';
    $mosConfig_smtppass = 'xxxxxx';
    $mosConfig_smtpuser = '';
    $mosConfig_uniquemail = '1';
    $mosConfig_user = 'root';
    $mosConfig_useractivation = '0';
    $mosConfig_vote = '0';
    setlocale (LC_TIME, $mosConfig_locale);
    ?>
    Hat jemand eine Idee, woran das liegen kann? Bin schon echt am verzweifeln. Die Suche hat auch nichts brauchbares gebracht.
    Ach ja, die Seite findet ihr unter www.ff-puchberg.at

    Ich danke euch im Voraus.
    lG
    Stefan

    Wer glaubt etwas zu sein, hat aufgehört etwas zu werden!

  2. #2
    Verbringt hier viel Zeit
    Registriert seit
    08.01.2006
    Beiträge
    922
    Bedankte sich
    9
    Erhielt 260 Danksagungen
    in 249 Beiträgen

    Unglücklich Wiedermal Quirks Mode

    Hi,
    wahrscheinlich das "alte Problem". Dieses Template wurde wohl mal für den IE 5.x gecoded. Da diese Versionen ganz schön "verbuggt" waren/sind, wirken die Hacks noch nach. Da der XML-Prolog den IE 6 in den Quirks Mode versetzt, wird dort das Template "ordentlich" angezeigt. Nur im IE 7 führen die Hacks zur falschen Darstellung. Du musst also den IE 7 auch in den Quirks Mode zwingen. Füge einfach nach dem XML-Prolog irgendeinen Komentar ein z.B. -> <!-- IE in QM -->

    Allerdings ist diese Lösung nicht mehr ganz zeitgemäß ...
    Gruß, <matti />
    __________________________________________________ _____
    Ist dein Problem gelöst - Thread als solchen markieren [Hilfe]
    Kostenfreie Hilfe nur(!) hier im Forum. Danke!

  3. #3
    Neu an Board
    Registriert seit
    22.03.2006
    Beiträge
    88
    Bedankte sich
    13
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo Matti,

    danke. die Seite wird nun im Web richtig angezeigt, allerdings die lokale Darstellung ist funktioniert noch immer nicht. Hast du auch dazu eine Idee?
    lG
    Stefan

    Wer glaubt etwas zu sein, hat aufgehört etwas zu werden!

  4. #4
    Verbringt hier viel Zeit
    Registriert seit
    08.01.2006
    Beiträge
    922
    Bedankte sich
    9
    Erhielt 260 Danksagungen
    in 249 Beiträgen

    Idee Google: PHP-Fehlermeldungen

    Schau mal hier ...
    Gruß, <matti />
    __________________________________________________ _____
    Ist dein Problem gelöst - Thread als solchen markieren [Hilfe]
    Kostenfreie Hilfe nur(!) hier im Forum. Danke!

  5. #5
    Neu an Board
    Registriert seit
    22.03.2006
    Beiträge
    88
    Bedankte sich
    13
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo,
    es gibt in dem Template keine Header-Funktion

    Code:
    <?php defined( "_VALID_MOS" ) or die( "Direct Access to this location is not allowed." );$iso = split( '=', _ISO );echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'><!-- IE in QM -->';?>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head>
    
    <?php mosShowHead(); ?>
    
    <meta **********="Content-Type" content="text/html;><?php echo _ISO; ?>" />
    
    <?php if ( $my->id ) { initEditor(); } ?>
    
    <?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/template_css.css\" type=\"text/css\"/>" ; ?><?php echo "<link rel=\"shortcut icon\" href=\"$GLOBALS[mosConfig_live_site]/templates/247portal-b-red/favicon.ico\" />" ; ?>
    
    <!--     Auskommentiert 09.07.2007
        <link rel="alternate" title="<?php echo $mosConfig_sitename; ?>" href="<?php echo $GLOBALS['mosConfig_live_site']; ?>/index2.php?option=com_rss&no_html=1" type="application/rss+xml" />
    -->
    
    <script language="JavaScript" type="text/javascript">
    
    <!--
    
    function MM_reloadPage(init) { //reloads the window if Nav4 resized
    
    if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
    
    document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
    
    else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
    
    }
    
    MM_reloadPage(true);
    
    //-->
    
    </script>
    
    <style type="text/css">
    
    <!--
    
    .Stil1 {font-size: xx-small;
    
    color: #FFFFFF;
    
    }
    
    -->
    
    </style>
    
    </head>
    
    
    
    <body>
    
    <div>
    
    <a name="up" id="up"></a>
    
    <table width="100%" height="20" border="0" align="center" cellpadding="0" cellspacing="0">
    
    <tr>
    
    <td align="center" class="mt"><a href="http://www.mamboteam.com" class="Stil1" >www.mamboteam.com</a></td>
    
    </tr>
    
    </table>
    
    <table width="100%" border="0" align="center" cellpadding="0" cellspacing="0">
    
    <tr>
    
    <td><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/space.gif" width="770" height="1" /></td>
    
    </tr>
    
    <tr>
    
    <td><div class="background">
    
    <table width="100%" border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/center.jpg">
    
    <tr>
    
    <td width="26"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/left.jpg" width="26" /></td>
    
    <td class="title"> <table width="100%" border="0" cellspacing="0" cellpadding="0">
    
    <tr>
    
    <td height="100" colspan="2" class="title" style="padding-top:14px;"><div align="center"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/wappen_links.gif" width="45" height="75" /> <img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/banner_130jahre.gif" width="300" height="75" /><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/wappen_rechts.gif" width="120" height="72" /></div></td>
    
    </tr>
    
    <tr>
    
    <td width="400" height="29"><div id="search">
    
    <?php mosLoadModules ( 'user4', -1 ); ?>
    
    </div></td>
    
    <td width="100%" height="29" valign="bottom" class="mainlevel-nav"><?php mosLoadModules ( 'user3' ); ?></td>
    
    </tr>
    
    </table></td>
    
    <td width="26"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/right.jpg" width="26" /></td>
    
    </tr>
    
    </table>
    
    <table width="100%" border="0" align="center" cellpadding="0" cellspacing="0">
    
    <tr>
    
    <td width="11" height="25" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/shadowl.jpg"><div>
    
    </div></td>
    
    <td height="25" bgcolor="#F1F1F1" style="border-bottom: 1px solid #999999; border-top: 5px solid #FFFFFF;"><?php mosPathWay(); ?></td>
    
    <td height="25" align="right" bgcolor="#F1F1F1" style="border-bottom: 1px solid #999999; border-top: 5px solid #FFFFFF;"><div class="date"><?php echo mosCurrentDate(); ?></div></td>
    
    <td width="11" height="25" align="right" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/shadowr.jpg">&nbsp;</td>
    
    </tr>
    
    </table>
    
    <table width="100%" border="0" align="center" cellpadding="0" cellspacing="0">
    
    <tr>
    
    <td valign="top" style="padding-left:8px; background-repeat: repeat-y;" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/shadowl.jpg">&nbsp;</td>
    
    <td valign="top" style="background-repeat: repeat-y;"background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/lb.gif"><?php if (mosCountModules('left')) { ?>
    
    <div class="leftrow">
    
    <?php mosLoadModules ( 'left' ); ?>
    
    </div>
    
    <?php } ?></td>
    
    <td valign="top" bgcolor="#FAFAFA" width="100%"><div class"main">
    
    <table width="100%" border="0" cellspacing="0" cellpadding="0">
    
    <tr valign="top" bgcolor="#F1F1F1">
    
    <?php if (mosCountModules('top')) { ?><td colspan="3" style="border-top: 3px solid #FFFFFF;">
    
    <div>
    
    <?php mosLoadModules ( 'top' ); ?>
    
    </div>
    
    </td><?php } ?>
    
    </tr>
    
    <tr>
    
    <?php if (mosCountModules('user1')) { ?><td valign="top" bgcolor="#F1F1F1" style="border-top: 3px solid #FFFFFF;"><div>
    
    <?php mosLoadModules ( 'user1' ); ?>
    
    </div></td>
    
    <td width="4" class="mod" valign="top" bgcolor="#FFFFFF" style="border-top: 3px solid #FFFFFF;"><div class="mod"> <?php } ?><?php if (mosCountModules('user2')) { ?> </div></td>
    
    
    
    <td valign="top" bgcolor="#F1F1F1" style="border-top: 3px solid #FFFFFF;"><div>
    
    <?php mosLoadModules ( 'user2' ); ?>
    
    </div></td><?php } ?>
    
    </tr>
    
    <tr align="left" valign="top">
    
    <td colspan="3" style=" border-top: 4px solid #FFFFFF; padding: 5px;"><div class="main">
    
    <?php mosMainBody(); ?>
    
    </div></td>
    
    </tr>
    
    <tr bgcolor="#F1F1F1">
    
    <td colspan="3" valign="top" style="border-top: 3px solid #FFFFFF;"><?php if (mosCountModules('bottom')) { ?>
    
    <div>
    
    <?php mosLoadModules ( 'bottom' ); ?>
    
    </div>
    
    <?php } ?></td>
    
    </tr>
    
    </table>
    
    </td>
    
    <td valign="top" style="background-repeat: repeat-y; "background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/rb.gif"><?php if (mosCountModules('right')) { ?>
    
    <div class="rightrow">
    
    <?php mosLoadModules ( 'right' ); ?>
    
    </div>
    
    <?php } ?></td>
    
    <td valign="top" style="padding-right: 8px; background-repeat: repeat-y;" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/shadowr.jpg">&nbsp;</td>
    
    </tr>
    
    </table>
    
    <table width="100%" border="0" cellpadding="0" cellspacing="0" background="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/center2.jpg">
    
    <tr>
    
    <td width="26"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/left2.jpg" /></td>
    
    <td>
    
    <table width="100%" border="0" cellspacing="0" cellpadding="0">
    
    <tr>
    
    <td width="30" align="left"><a href="<?php echo sefRelToAbs($_SERVER['REQUEST_URI'])."#up"; ?>"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/ltop.jpg" alt="Top!" border="0" /></a> </td>
    
    </div>
    
    </td>
    
    <td width="30" align="right"><a href="<?php echo sefRelToAbs($_SERVER['REQUEST_URI'])."#up"; ?>"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/rtop.jpg" alt="Top!" border="0" /></a></td>
    
    </tr>
    
    </table></td>
    
    <td width="26"><img src="<?php echo $mosConfig_live_site;?>/templates/247portal-b-red/images/right2.jpg" /></td>
    
    </tr>
    
    </table>
    
    </div></td>
    
    </tr>
    
    </table>
    
    </div>
    
    <?php
    
    if (file_exists($mosConfig_absolute_path."/components/com_ebackup/ebackup.php")){
    
    echo "<img src=\"".$mosConfig_live_site."/index2.php?option=com_ebackup\" width=\"0\" height=\"0\" alt=\"\" />\n";
    
    }
    
    ?>
    
    </body>
    
    </html>
    Hier gäbe es das Template zum runterladen
    lG
    Stefan

    Wer glaubt etwas zu sein, hat aufgehört etwas zu werden!

  6. #6
    Neu an Board
    Registriert seit
    22.03.2006
    Beiträge
    88
    Bedankte sich
    13
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hat denn keiner mehr eine Idee, woran der XAMPP-Fehler liegt?
    lG
    Stefan

    Wer glaubt etwas zu sein, hat aufgehört etwas zu werden!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein