Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Wieder mal "wwwrun" Rechte Problem, Apache...

  1. #1
    Neu an Board
    Registriert seit
    23.01.2006
    Beiträge
    46
    Bedankte sich
    4
    Erhielt 2 Danksagung
    in 1 Beitrag

    Frage Wieder mal "wwwrun" Rechte Problem, Apache...

    Hallo Joomla-Gemeinde,

    ich hab mich in die wwwrun-Thematik schon etwas eingelesen...aber so richtig schlau bin ich noch nicht, obwohl der Thread ganz interessant war: klick

    Bis jetzt hatte ich joomla immer als Testinstallation Local laufen, deshalb ist das wwwrun Thema nicht aufgefallen. Jetzt will ich aber mit meiner Seite live ins Netz gehen - Server hab ich schon - Vollzugriff....

    Jetzt hab ich immer gelesen, das der Apache nicht als Modul, sonder als CGI laufen sollte....um das besagte wwwrun Problem zu umgehen.
    Kann mir da wer was genaues zu sagen??? Ich meine der Server ist im moment noch blanko, und wenn dann wollte ich es gleich "richtig" machen

    Als Admin-SW wollte ich Syscp einsetzten -> Syscp + Suse

    Und dann versuchen mit der Config einzurichten: Apache Instanzen

    Ist das, wenn ich so installiere "falsch" oder "richtig" -> geht das überhaupt so???
    Bin über jeden Tipp dankbar...

  2. #2
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.777
    Bedankte sich
    92
    Erhielt 1.597 Danksagungen
    in 1.280 Beiträgen

    Standard

    Was hast Du denn für eine Distribution?
    Deine beiden geannten Links beziehen sich auf Suse und auf Debian. Da wirst Du einiges anpassen müssen.

    Im zweiten Link willst Du suexec anpassen, das Syscp patchen und auch noch PHP kompilieren. Nicht das das nicht machbar wäre, aber Du entkoppelst Dich damit von der Paketverwaltung für den Security-Patches und musst zukünftig den ganzen Kram jedesmal manuell updaten.
    Ob Deine normalen CGI's (also z.B. Perl) dann noch mit dem gepachten suexec funktionieren wäre im Vorfeld mal zu erörtern. Sonst gibs ne unangnehme Überraschung.

    Die fastcgi-Installation nach dem bekannten Debian-HowTo ist eine klassische Laborlösung. Für Massenhosting nicht so besonders geeignet. Du musst sicherstellen, das das überordnete Verwaltungssystem (also syscp) die gesamte Umgebung für die virtuellen Hosts generiert. Wenn Du jedesmal manuell die php.ini-Dateien "nachrüsten" musst, dann macht das im Endeffekt wenig Sinn.

    Wenn Du Deinen Server ganz für Dich alleine hast, dann würde ich PHP als Modul einsetzen, also "ganz normal". Für Deine Joomla-Webs setzte Du den Owner der ganzen Dateien einfach auf den PHP-User und schon hast Du kein wwwrun-Problem mehr.

    Wenn Du Fremduser auf dem System hast (Kunden, Freund etc.), dann wäre PHP als CGI eine sinnvolle Geschichte.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  3. #3
    Neu an Board
    Registriert seit
    23.01.2006
    Beiträge
    46
    Bedankte sich
    4
    Erhielt 2 Danksagung
    in 1 Beitrag

    Standard ...mhmmm...

    Die Distribution ist Suse 9.3 Prof....nen Debian wäre mit lieber gewesen, aber egal...
    Die ganze Sache war mit Plesk aufgesetzt, das hab ich erstmal platt gemacht und neu aufgesetzt, ohne Plesk...da ich bei ersten Versuch (mit Plesk) das wwwrun Problem hatte...

    Also wenn ich es richtig verstanden habe....installiere ich ganz normal Apache als mpm-worker und dazu das mod_php4 modul. Danach syscp rauf...einrichten, testen ob es funktioniert, User anlegen mit Host, und dann Joomla installieren...

    Was meinst Du mit, dem php user die recht geben???

    Dann hat meine Joomla installation "theoretisch" folgende rechte 1002:1002 -> 755...aber dann kann ich doch das wwwrun Problem...aber bin ich jetzt irgenwie falsch...??

  4. #4
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.777
    Bedankte sich
    92
    Erhielt 1.597 Danksagungen
    in 1.280 Beiträgen

    Standard

    Du willst Plesk gegen Syscp eintauschen ?? Na gut, wenn Du meinst...

    Die alles entscheidene Frage ist, ob der Server für Dich alleine ist oder ob noch andere drauf sind. Danach richten sich Deine Sicherheitseinstellungen.

    Falls er für Dich alleine ist (so hört es sich an), dann liegt Du hier richtig:
    Also wenn ich es richtig verstanden habe....installiere ich ganz normal Apache als mpm-worker und dazu das mod_php4 modul. Danach syscp rauf...einrichten, testen ob es funktioniert, User anlegen mit Host, und dann Joomla installieren...
    Ein bißchen mehr gehört schon noch dazu, wie z.B. die rewrite-engine usw.

    Was meinst Du mit, dem php user die recht geben???
    Ich beschrieb es doch:
    Für Deine Joomla-Webs setzte Du den Owner der ganzen Dateien einfach auf den PHP-User und schon hast Du kein wwwrun-Problem mehr.
    Wenn PHP bei Dir als Modul läuft, dann wird Dein PHP mit dem User des Webservers ausgeführt. Bei Suse ist das glaube ich: User: "nobody", Gruppe "nobody"

    Du gehst nach Aufspielen der Joomladaten also via SSH in Dein Web und gibst ein:

    chown -R nobody:nobody *
    Achte darauf, das der Prompt wirklich in Deinem Web steht!!!

    Dann hat meine Joomla installation "theoretisch" folgende rechte 1002:1002 -> 755...aber dann kann ich doch das wwwrun Problem...aber bin ich jetzt irgenwie falsch...??
    Definier doch mal das "wwwrun-Problem" in zwei, drei einfachen Sätzen. Wenn Du begriffen hast, um WAS es genau geht, kannst Du es auch ganz einfach umgehen.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  5. #5
    Neu an Board
    Registriert seit
    26.09.2006
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ich hab auch das Problem mit wwwrun.
    Das Problem ist das alle sachen die ich übers WEB mache dann dem USER wwwrun gehören, und ich die nicht per ftp verändern kann.
    Ich hab ein Vserver mit root zugriff - SuSE Linux SuSE 10.0 Plesk-Version psa v8.0.1.

    Kann ich nicht einfach per yast PHP als CGI installieren und das wars oder stelle ich mir das zu einfach vor.

    Oder vserver kündigen und neuen besorgen ??

    MFG

  6. #6
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.777
    Bedankte sich
    92
    Erhielt 1.597 Danksagungen
    in 1.280 Beiträgen

    Standard

    Zitat Zitat von fitte23 Beitrag anzeigen
    Kann ich nicht einfach per yast PHP als CGI installieren und das wars oder stelle ich mir das zu einfach vor.
    Ja das kannst Du machen, aber dann laufen Deine Webs sehr wahrscheinlich nicht mehr - ebenso das Plesk wird nicht mehr funktionieren. Also VORSICHT bei solch gravierenden Systemänderungen.

    Als Eigentümer eines VServers mit root-Rechten ist man natürlich der eigene Systemadministrator und kann damit sein System genau so einrichten, wie man es haben will/muss. NUR DESWEGEN bucht man VSERVER.

    Die meisten User nutzen VServer aber wie normalen Webspace und das Admin-Wissen beschränkt sich auf die Bedienung der Admin-Oberfläche. Damit kommt man natürlich nicht weit - und lebt im übrigen auf einer Zeitbombe

    Falls das bei Dir also der Fall sein sollte "fitte23", überlege eine Wechsel auf Joomla-optimierten Webspace. Wenn Du aber Admin-Ambitionen hast, suche nach den richtigen Anleitungen und rekonfiguriere Deinen Server nach Deinen Vorgaben.
    Was für Dich der bessere Weg ist, kannst Du nur selbst beantworten.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  7. #7
    Neu an Board
    Registriert seit
    26.09.2006
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Was meinst du mit rekonfigurieren?
    Ein anderes BS kann ich nicht aufsetzen hat mein Hoster mir gesagt.
    Er meinte ich soll mir ein Script schreiben was immer Automatisch ausgeführt wird.
    Was die Rechte wieder auf den FTP User setzt.

    Gibts gute anleitungen für Suse ? Alles was ich bis jetzt zum Thema PHP als CGI bezog war für Debian was ich leider nicht drauf habe.
    Und wenn ich das mache wie Du es beschrieben hast das ich den PHP User gleich auf wwwrun setze. Wie geht das am einfachsten kann ich da einfach den kompletten Ordner /httpdocs auf wwwrun setzen?

    Danke schonmal.
    mfg

  8. #8
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.777
    Bedankte sich
    92
    Erhielt 1.597 Danksagungen
    in 1.280 Beiträgen

    Standard

    Zitat Zitat von fitte23 Beitrag anzeigen
    Was meinst du mit rekonfigurieren?
    ... na die PHP-Konfiguration ändern...

    Und wenn ich das mache wie Du es beschrieben hast das ich den PHP User gleich auf wwwrun setze. Wie geht das am einfachsten kann ich da einfach den kompletten Ordner /httpdocs auf wwwrun setzen?
    Immer vorsichtig mit globablen Änderungen! Woher soll ich wissen, was Du mit httpdocs meinest und was dort alles drin ist?
    Führe die chown-Änderung doch für die gesamten Joomla-Dateien durch.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  9. #9
    Neu an Board
    Registriert seit
    26.09.2006
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    In /httpdocs ist meine Installation drine immer von einer Domain.

    Wie ändere denn die php einstellungen muß ich dazu nicht die php als cgi haben.

    Bin ziemlich neu auf dem gebiet, habe alles sonst auf webspace da läuft alles so wie es soll .
    MFG

  10. #10
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.777
    Bedankte sich
    92
    Erhielt 1.597 Danksagungen
    in 1.280 Beiträgen

    Standard

    Du bringst jetzt hier jetzt einiges durcheinander. Du wolltest Deinen Dateien den User "wwwrun" verpassen und nicht PHP als CGI betreiben. Das sind unterschiedliche Dinge.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

Seite 1 von 2 1 2 LetzteLetzte

Ähnliche Themen

  1. Mambo 4.5.2.3 admin login problem
    Von stonkbonk2 im Forum Allgemeine Fragen zu Mambo
    Antworten: 20
    Letzter Beitrag: 25.10.2006, 15:33
  2. Problem bei der Installation..etwas anders..
    Von Don Gucci im Forum Joomla Installation
    Antworten: 3
    Letzter Beitrag: 26.12.2005, 23:15
  3. Simpleboard 1.1.0 Rechte Problem
    Von Hessix im Forum Mambo Komponenten
    Antworten: 1
    Letzter Beitrag: 22.12.2005, 11:05
  4. Login Problem, Problem mit dem jos_usesr Table
    Von fixmer im Forum Joomla Installation
    Antworten: 2
    Letzter Beitrag: 07.12.2005, 14:14
  5. Joomla SMF Bridge Problem
    Von Joerg_Langer im Forum Joomla Komponenten
    Antworten: 2
    Letzter Beitrag: 29.11.2005, 14:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein