+ Antworten
Ergebnis 1 bis 3 von 3

Thema: Problem mit helix3 plugin

  1. #1
    Kommt häufiger vorbei Avatar von haraldlohmann
    Registriert seit
    15.12.2007
    Ort
    Neuenkirchen, NRW
    Alter
    62
    Beiträge
    382
    Bedankte sich
    283
    Erhielt 15 Danksagungen
    in 14 Beiträgen

    Standard Problem mit helix3 plugin

    Ich weiß nicht, was das ist und kann mir den Fehler auch nicht erklären, doch nachdem ich das Backup wieder aufgespielt bekommen habe (anderer Thread - gelöst), habe ich diese Fehlermeldung, wenn ich einen Menüpunkt aufrufen möchte:
    Fatal error: Cannot use object of type stdClass as array in /www/htdocs/w013a901/homepage2015/plugins/system/helix3/helix3.php on line 31

    Der Inhalt der Datei ist hier:
    PHP-Code:
    <?php
    /**
    * @package Helix3 Framework
    * @author JoomShaper http://www.joomshaper.com
    * @copyright Copyright (c) 2010 - 2015 JoomShaper
    * @license http://www.gnu.org/licenses/gpl-2.0.html GNU/GPLv2 or Later
    */    

    //no direct accees
    defined ('_JEXEC') or die ('resticted aceess');

    jimport('joomla.plugin.plugin');
    jimport'joomla.event.plugin' );

    class  
    plgSystemHelix3 extends JPlugin
    {

        protected 
    $autoloadLanguage true;


        function 
    onContentPrepareForm($form$data) {

            
    $doc JFactory::getDocument();
            
    $plg_path JURI::root(true).'/plugins/system/helix3';
            
    JForm::addFormPath(JPATH_PLUGINS.'/system/helix3/params');

            if (
    $form->getName()=='com_menus.item') { //Add Helix menu params to the menu item   
                
                
    JHtml::_('jquery.framework');

                if(
    $data['id'] && $data['parent_id'] == 1) {
                    
                    
    $doc->addScript($plg_path.'/assets/js/jquery-ui.min.js');
                    
    $doc->addStyleSheet($plg_path.'/assets/css/bootstrap.css');
                    
    $doc->addStyleSheet($plg_path.'/assets/css/font-awesome.min.css');
                    
    $doc->addStyleSheet($plg_path.'/assets/css/modal.css');
                    
    $doc->addStyleSheet($plg_path.'/assets/css/menu.generator.css');
                    
    $doc->addScript($plg_path.'/assets/js/modal.js');
                    
    $doc->addScript$plg_path'/assets/js/menu.generator.js' );
                    
    $form->loadFile('menu-parent'false);
                } else {
                    
    $form->loadFile('menu-child'false); 
                }

                
    $form->loadFile('page-title'false);

            }

            
    //Article Post format
            
    if ($form->getName()=='com_content.article') {
                
    JHtml::_('jquery.framework');
                
    $doc->addStyleSheet($plg_path.'/assets/css/font-awesome.min.css');
                
    $doc->addScript($plg_path.'/assets/js/post-formats.js');

                
    JForm::addFormPath(JPATH_PLUGINS.'/system/helix3/params');
                
    $form->loadFile('post-formats'false);
            }

        }
    }
    Was kann ich tun? Sieht jemand einen Lösungsansatz?

    Gruß,
    Harald
    www.ajg.eu

    Sorry, zu spät gesehen, falscher Bereich, habe 3.8 installiert.
    Geändert von haraldlohmann (04.08.2018 um 05:21 Uhr)

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.462
    Bedankte sich
    148
    Erhielt 2.132 Danksagungen
    in 1.902 Beiträgen

    Standard

    Musst nur das Plugin bzw. Template updaten. Da ist am 28.Juni ein Update erschienen. 2.5.5, wo das gefixt ist.
    Mir wird das Update fürs kostenlose Helix 3 auf einer Altseite unter Erweiterungen > aktualisieren jedenfalls angezeigt.

    Download-Link:
    https://www.joomshaper.com/index.php...on&id=41&sub=1

    Auch angebotenes Updates:
    Helix3 - Ajax Plugin:
    https://www.joomshaper.com/index.php...on&id=42&sub=1

    Sowie das Template Shaper Helix3 selbst, was o.g. Plugins gleich mit drin hat:
    https://www.joomshaper.com/index.php...te&id=68&sub=2

    Bei Template würde ich jedenfalls vorher Backup machen. Weiß ja nicht, was du ggf. geändert hast.
    Joomlafachmann: https://www.ghsvs.de

  3. #3
    Kommt häufiger vorbei Avatar von haraldlohmann
    Registriert seit
    15.12.2007
    Ort
    Neuenkirchen, NRW
    Alter
    62
    Beiträge
    382
    Bedankte sich
    283
    Erhielt 15 Danksagungen
    in 14 Beiträgen

    Standard

    Besten Dank, Re-later,
    das Problem konnte ich so schnell lösen.

    LG Harald

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein