+ Antworten
Seite 1 von 4 1 2 3 4 LetzteLetzte
Ergebnis 1 bis 10 von 40

Thema: WBB Forumticker 2.0

  1. #1
    emy
    emy ist offline
    Neu an Board
    Registriert seit
    09.02.2008
    Beiträge
    8
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard WBB Forumticker 2.0

    hi

    hab da auch ein paar Probleme mit den Forumticker vielleicht kann mir ja einer helfen

    PHP-Code:
    Notice: Use of undefined constant neues assumed 'neues' in /is/htdocs/wp1034433_JBJSV6JUCS/zzHSN/hsn/modules/mod_forenticker/mod_forenticker.php on line 24

    Notice
    : Use of undefined constant wbb30 assumed 'wbb30' in /is/htdocs/wp1034433_JBJSV6JUCS/zzHSN/hsn/modules/mod_forenticker/mod_forenticker.php on line 32

    Notice
    : Use of undefined constant wbb23 assumed 'wbb23' in /is/htdocs/wp1034433_JBJSV6JUCS/zzHSN/hsn/modules/mod_forenticker/mod_forenticker.php on line 40 
    und das ganze sieht dann so aus


    kann mir da einer helfen oder ein guten Ratschlag geben ?

  2. #2
    Wohnt hier Avatar von hermione
    Registriert seit
    31.01.2005
    Alter
    37
    Beiträge
    3.068
    Bedankte sich
    64
    Erhielt 1.027 Danksagungen
    in 951 Beiträgen

    Standard

    was denn jetzt, wbb2 oder wbb3??
    http://www.joomlaportal.de/joomla-mo...tml#post585603

    und welche joomla-version hast du? ist der ticker überhaupt für deine version?

  3. #3
    emy
    emy ist offline
    Neu an Board
    Registriert seit
    09.02.2008
    Beiträge
    8
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    ich hab joomla 1.5 (Vorgängerversion plugin eingeschaltet )
    und hab wbb 2.3.6

    wbb2 forumticker
    Beschreibung:
    Mit diesem Ticker ist es möglich, die X Beiträge eines WBB Lite, WBB 2.3.x oder des WBB 3.0.x auf der Joomla 1.5.0 Hauptseite anzeigen zu lassen. Im Backend kann man die Datenbank, die Anzahl der Beiträge, die Forenversion sowie die nicht einzublendenden Beiträge (also zum Beispiel bei Internen Foren) einstellen.

    hergeholt hab ich es mir hier http://www.joomlaos.de/option,com_re...ct/id,344.html

    forumticker.php
    PHP-Code:
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta **********="Content-Type" content="text/html; charset=utf-8" />
    </head>
    <body>
    <?php
    defined
    '_JEXEC' ) or die( 'Restricted access' );
    //Parameter
    $sqlserver $params->get'sqlserver');
    $sqlbenutzer $params->get'sqlbenutzer' );
    $sqlpasswort $params->get'sqlpasswort' );
    $sqldb $params->get'sqldb' );
    $n $params->get'wbbnummer' );
    $typ $params->get'typ' );
    $url $params->get'url' );
    $fenster $params->get'fenster' );
    $limit $params->get'limit' );
    $ausgeschlossen $params->get'ausgeschlossen' );
    //Verbindung zur Datenbank
    mysql_connect("$sqlserver","$sqlbenutzer","$sqlpasswort");
    mysql_select_db("$sqldb");


    if(
    $fenster==neues){
      
    $target="target=\"_blank\"";
      }
      else {
        
    $target="target=\"_self\"";
      }

    $count=1//Zhlvariable
    if($typ==wbb30) {
     
    $abfrage="SELECT threadID, boardID, topic, lastPostTime FROM wbb".$n."_1_thread WHERE boardid NOT IN  ($ausgeschlossen) ORDER BY lastPostTime DESC LIMIT $limit";
     
    $ergebnis=mysql_query($abfrage);
    while(
    $row mysql_fetch_object($ergebnis))
        {
        echo 
    "<a href=\"$url/index.php?page=Thread&amp;threadID=$row->threadID&action=firstNew\" $target$count$row->topic</a><br />";
        
    $count++;
        }
    } elseif(
    $typ==wbb23) {
       
    $abfrage="SELECT threadid, boardid, topic, lastposttime FROM bb".$n."_threads WHERE boardid NOT IN  ($ausgeschlossen) ORDER BY lastposttime DESC LIMIT $limit";
       
    $ergebnis=mysql_query($abfrage);
    while(
    $row mysql_fetch_object($ergebnis))
        {
        echo 
    "<a href=\"$url/thread.php?goto=lastpost&amp;threadid=$row->threadid\" $target$count$row->topic</a><br />";
        
    $count++;
        }
    } else {
      
    $abfrage="SELECT threadid, boardid, topic, lastposttime FROM bb".$n."_threads WHERE boardid NOT IN  ($ausgeschlossen) ORDER BY lastposttime DESC LIMIT $limit";
      
    $ergebnis=mysql_query($abfrage);
    while(
    $row mysql_fetch_object($ergebnis))
        {
        echo 
    "<a href=\"$url/thread.php?goto=lastpost&amp;threadid=$row->threadid\" $target$count$row->topic</a><br />";
        
    $count++;
        }
    }

    ?>
    </body>
    </html>

  4. #4
    emy
    emy ist offline
    Neu an Board
    Registriert seit
    09.02.2008
    Beiträge
    8
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    hmmm kann mir keiner helfen ??

  5. #5
    Neu an Board Avatar von HipHopRulez
    Registriert seit
    28.01.2008
    Beiträge
    24
    Bedankte sich
    2
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Ich bin der Autor dieses Moduls.

    Das Problem was du hast, liegt nicht am Modul direkt sondern an deiner Serverkonfiguration.

    Probiere mal folgendes über //Parameter zu setzen:

    define('neues', 'wbb30','wbb23');

    Klappt das?

  6. Erhielt Danksagungen von:

    emy

  7. #6
    emy
    emy ist offline
    Neu an Board
    Registriert seit
    09.02.2008
    Beiträge
    8
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    hi

    erstmal danke ,das du mir hilfst
    ich hab das mal eingetragen ist schon mal ein Fehler weniger .. bleiben nur noch 2
    irgend wie kann der mit den Wörter nichts anfangen

    ich poste mal die schritte die gemacht habe

    PHP-Code:
    <body>
    <?php

    defined
    '_JEXEC' ) or die( 'Restricted access' );
    define('neues''wbb30','wbb23');

    //Parameter
    $sqlserver $params->get'sqlserver');
    Resultat :


    Fehlermeldung:

    PHP-Code:
    Notice: Use of undefined constant wbb30 assumed 'wbb30' in /is/htdocs/wp1034433_JBJSV6JUCS/zzHSN/hsn/modules/mod_forenticker/mod_forenticker.php on line 35

    Notice
    : Use of undefined constant wbb23 assumed 'wbb23' in /is/htdocs/wp1034433_JBJSV6JUCS/zzHSN/hsn/modules/mod_forenticker/mod_forenticker.php on line 43 

  8. #7
    War schon öfter hier Avatar von KleenMicha
    Registriert seit
    23.09.2005
    Ort
    Dresden
    Alter
    36
    Beiträge
    188
    Bedankte sich
    2
    Erhielt 106 Danksagungen
    in 61 Beiträgen

    Standard

    Der Fehler begründet sich darin dass ein String in der Abfrage verwendet wurde und dieser nicht richtig markiert wurde.

    Die Lösung sieht wie folgt aus:
    Öffne die Datei: ./modules/mod_forenticker/mod_forenticker.php
    Suche nach:
    PHP-Code:
    if($fenster==neues){ 
    und ersetz es durch:
    PHP-Code:
    if($fenster=='neues'){ 
    Suche nach:
    PHP-Code:
    if($typ=wbb30) { 
    und ersetz es durch:
    PHP-Code:
    if($typ=='wbb30') { 
    Suche nach:
    PHP-Code:
    } elseif($typ==wbb23) { 
    und ersetz es durch:
    PHP-Code:
    } elseif($typ=='wbb23') { 
    .
    Gruß Micha
    -------------
    [SIGPIC][/SIGPIC]

  9. Erhielt Danksagungen von:

    emy

  10. #8
    emy
    emy ist offline
    Neu an Board
    Registriert seit
    09.02.2008
    Beiträge
    8
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    super micha

    jetzt funktioniert alles einband frei
    *danke*

    ich häng mal die fertige umgeschriebene php-datei in Anhang
    vielleicht hilft es ja noch weiteren Leuten
    Angehängte Dateien

  11. #9
    Neu an Board Avatar von HipHopRulez
    Registriert seit
    28.01.2008
    Beiträge
    24
    Bedankte sich
    2
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Moin Micha, wusste ja gar nicht dass du auch hier bist. hehe

    Das hätte ich als nächstes vorgeschlagen. Da ist die Fehlerausgabe sehr hoch gesetzt in der PHP Konfiguration...

    Werde mein Modul aktualisieren.

  12. Erhielt Danksagungen von:

    emy

  13. #10
    Neu an Board
    Registriert seit
    23.10.2005
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard Umlaute

    Hi

    Ich hab den Forenticker installiert (Joomla 1.5.1 / WBB3.0 pl1)
    Hab alles sauber konfiguriert.
    Nun sind mir zwei Dinge aufgefallen
    a) Ich bekomme keine Umlaute angezeigt Sondern nur Fragezeichen "?"

    b) Es werden HTML Body und Header Informationen mitten in der Seite eingefügt. Das sollte AFAIK aber nicht sein. Ich habe jetzt erstmal aus der mod_forenticker.php die Zeilen
    PHP-Code:
    <html xmlns="http://www.w3.org/1999/xhtml">
    <
    head>
    <
    meta **********="Content-Type" content="text/html; charset=utf-8" />
    </
    head>
    <
    body
    und
    PHP-Code:
    </body>
    </
    html
    entfernt.

    Jemand ne Idee, woran das mit den Umlauten liegen könnte? Joomla und WBB sind auf UTF-8 eingestellt.

+ Antworten
Seite 1 von 4 1 2 3 4 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein