Ergebnis 1 bis 6 von 6

Thema: Internet Explorer und SSL-Verschlüsselung

  1. #1
    Neu an Board
    Registriert seit
    20.11.2006
    Beiträge
    66
    Bedankte sich
    7
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard Internet Explorer und SSL-Verschlüsselung

    Hallo an alle!
    Ich habe mir ein eigenes SSL-Zertifikat gekauft und nun sollten alle Bestellungen in VirtueMart verschlüsselt übergeben werden. Nach einigen Schwierigkeiten habe ich das auch hinbekommen, allerdings nur für Firefox. Im IE7 gibt es Sicherheithinweise, dass Teile der Seite nicht verschlüsselt seien - man muss diese beim Bestellvorgang jedes Mal bestätigen um diesen leztlich auszuführen. Tödlich für erfolgreiches Verkaufen. In älteren IE-Versionen bekommt man nach Bestätigung des Hinweises einen leeren Warenkorb. Bestellungen sind also nicht möglich.
    Ich habe auch Dynamic Life Sites installiert - keine Änderung, bis auf, dass ich nicht mehr 100%ig in den Adminbereich (Backend) komme und ein Nutzername und Passwort verlangt wird. Das Fenster habe ich dann so lange weggeklickt, bis der Adminbereich zumindest teilweise (ohne die Menüleiste oben) wieder geladen war, um Dynamic Life Sites wieder auszustellen.
    Auch wenn ich in der Configuration.php die Life-Site auf https.www.olivenoelkontor.de stelle, habe ich dasselbe Problem mit dem Backend, der Bestellvorgang im IE lässt sich genauso wie oben beschrieben ausführen - oder halt nicht.
    Wer jetzt weiß, was man machen muss, damit das auch im IE funktioniert, der melde sich bitte.
    Ich benutze Joomla 1.0.12 und Virtuemart 1.0.10
    Der Link zur Seite: www.olivenoelkontor.de

    Danke schon mal im Voraus für Eure Mühe.

    Gruß
    Mike

  2. #2
    Neu an Board
    Registriert seit
    04.07.2007
    Beiträge
    23
    Bedankte sich
    1
    1 Danksagung in 1 Beitrag

    Standard

    Hallo Mike,

    wie genau hast du das SSL auf deiner Seite eingerichtet?

    Gruß

    Chr1s

  3. #3
    Neu an Board
    Registriert seit
    20.11.2006
    Beiträge
    66
    Bedankte sich
    7
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Hallo Chris!
    Indem ich im Virtuemart unter Global Configuration die sichere Seite unter "Server" mit https://www.olivenoelkontor.de angegeben habe. Zudem habe ich noch ein paar Pfade in https geändert, die auf http standen und pinkbacks enthielten: <link rel="pingback"
    href="https://www.olivenoelkontor.de/components/com_jd-wp/xmlrpc.php".
    Im Firefox funktioniert das auch einwandfrei, nur nicht im Internet Explorer. Ich kann zwar in IE7 gemischte Inhalte (d.h. verschlüsselt und unverschlüsselt) zulassen, um die Sicherheitswarnung auszuschalten, dies müsste dann aber jeder Kunde tun - und wohl tunlichst unterlassen. Installiert hat das Zertifikat mein Provider (domainfactory).
    Was sich mir nicht erschließt: Warum sind im Firefox alle Inhalte verschlüsselt und im IE nicht?

    Gruß
    Mike

  4. #4
    Neu an Board
    Registriert seit
    20.11.2006
    Beiträge
    66
    Bedankte sich
    7
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard Teilerfolg

    Einen sehr guten Hinweis bekam ich in folgendem Post: http://www.joomlaportal.de/geloeste-...n-objekte.html

    Allerdings war das auch nicht der Weisheit letzter Schluss. Ich habe mir dann die unsicheren Objekte zeigen lassen (im IE7). Dabei stellte sich heraus, dass es teilweise einige Bilder waren (nicht alle) und zwei Werbeeinblendungen (Immowelt und "Berge und Meer") sowie einige Verweise auf andere Webseiten in der linken Position unten. Letztere habe ich einfach nach rechts gepackt, und schon funktioniert die verschlüsselte Bestellung im IE7 (weil das rechte Modul nicht mehr angezeigt wird, im Bestellvorgang). Lediglich in älteren IE bekommt man einen leeren Warenkorb.
    Wer weiß, was ich jetzt noch anpassen muss, der helfe bitte!

    Gruß
    Mike

    www.olivenoelkontor.de

  5. #5
    Kommt häufiger vorbei
    Registriert seit
    18.04.2006
    Beiträge
    386
    Bedankte sich
    9
    Erhielt 58 Danksagungen
    in 46 Beiträgen

    Standard

    hallo
    hatte auch das problem

    bei mir waren es die links zu meinen eigenen bildern

    zsb.
    schreibt der fckw editor die url zu einem bild so:
    http://www.deinedomain/images/stories/xxxx/xxxx.jpg

    das mag die ssl verschlüsselung nicht und sagt das ist eine fremde domain ---also unsicher

    der pfad zum bild muss für ssl so aussehen:
    images/stories/xxxx/xxxx.jpg

    dann gibts auch keine meldung wegen unsichere objekte im ie mehr

  6. #6
    Neu an Board
    Registriert seit
    28.05.2007
    Beiträge
    4
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo Maverik,

    das ist doch schon mal ein Hinweis (im Virtuemart Forum findet man nicht so richtig die Antworten). Wie muss man da vorgehen um dein Vorschlag zu verwirklichen? Ich habe bisher in der virtumart.cfg.php datei alle Bilder auf SECUREURL umgestellt, ist aber unschön. Mich würde die Anwendung deines Vorschlages sehr interessieren.

    Grüßle
    Nobi

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein