+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Nur noch error - grundsätzliche Fragen

  1. #1
    Verbringt hier viel Zeit Avatar von saardaniel
    Registriert seit
    10.08.2005
    Beiträge
    557
    Bedankte sich
    24
    Erhielt 7 Danksagungen
    in 6 Beiträgen

    Standard Nur noch error - grundsätzliche Fragen

    Hallo alle,

    ich habe eben eine Joomla 3.9 (EDIT: doch 3.8.x) kopiert (DB + Code kopiert)
    Die Daten der laufenden Joomla Version runtergeladen und in einen neuen Folder auf den Server geladen.
    Dann die Confi-Datei angepasst mit den DB- Daten.

    Leider bekomme ich eine weise Seite in der nur "Error" steht.
    Dann nahm ich die config-Datei mit den alten DB-Verbindungsdaten.
    Das Selbe!

    Grundsätzlche Fragen:

    Wenn ich das ändere:
    public $error_reporting = 'maximum';

    sehe ich nicht mehr Fehlermeldungen als zuvor.
    -Was muss ich noch tun, um mehr Fehlermeldungen, bzw genauere zu bekommen.
    - An welcher Stelle könnte man noch einen Fehler machen ausser: Anpassung Config-File?
    - Ist es wichtig, dass in der Config der Log-Path stimmt?

    Das Umnennen der Config bringt einen Fehler, dass die ConfigDatei fehlt. Daher wirst also auch die korrekte config geladen.

    - Warum gibt es überhaupt eine Fehlermeldung "error"? Warum nicht gleich etwas spezifischer?

    In der Config kann scheinbar stehen was will. Bei einer leeren Config kommt auch nur "error".

    - Warum wird bei einer leeren Config nicht darauf hingewiesen, dass die Config fehlerhaft ist?

    Beste Grüße
    Daniel
    Geändert von saardaniel (18.05.2019 um 08:16 Uhr)
    :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    Mein erstes Joomla Projekt war www.saar-wingchun.de

  2. #2
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    61
    Beiträge
    19.597
    Bedankte sich
    756
    Erhielt 4.001 Danksagungen
    in 3.759 Beiträgen

    Standard

    Wir fangen mal mit einem Fehler an - und dann schauen wir die "Warum-Fragen" als Folgefehler an. So als Idee

    Welche PHP-Version läuft denn auf dem Webserver? Wer ist der Hoster?
    Kommst du ins Backend, bzw. gibt es überhaupt eins?
    Eine Warum-Frage kann ich schon mal beantworten: Was genau alles bei der Fehlermeldung ausgegeben wird und ob es überhaupt einen Unterschied bei den Variationen (Standard, maximum, etc.) gibt, hängt von Einstellungen im Webserver ab, wo normalsterbliche Menschen normalerweise keinen Zugang zu haben. Zumindest wenn du ein normales Webpaket hast.
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    CCK SEBLOD-Das Handbuch als kostenloses Onlinebook

  3. #3
    Verbringt hier viel Zeit Avatar von saardaniel
    Registriert seit
    10.08.2005
    Beiträge
    557
    Bedankte sich
    24
    Erhielt 7 Danksagungen
    in 6 Beiträgen

    Standard

    Hallo time4mambo,

    ich dachte mir auch, dass der Grund im php liegt.
    Ich checke das: Hosteurope ist übrigens der Hoster (normales Packet).

    Configuration File (php.ini) Path /etc/php7.2
    Loaded Configuration File /etc/php7.2/php.ini


    Joomla System:
    PHP erstellt für Linux wp218 4.4.74-1-xenu-static-he+1+ #2 SMP Mon Jun 26 12:35:59 CEST 2017 x86_64
    Datenbanktyp mysql
    Datenbankversion 5.6.43-84.3-log
    Datenbankzeichensatz utf8_general_ci
    Datenbankverbindungszeichensatz utf8mb4_general_ci
    PHP-Version 7.1.29-he.0
    Webserver Apache
    PHP-Interface für den Webserver apache2handler
    Joomla!-Version Joomla! 3.8.12 Stable [ Amani ] 28-August-2018 14:00 GMT
    Joomla!-Plattform-Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    Browsererkennung Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

    ::::::::::::

    Login Fehler für Admin:
    JAuthentication: :authenticate: Fehler beim Laden des Plugins: plgauthenticationjoomla
    JAuthentication: :authenticate: Fehler beim Laden des Plugins: plgauthenticationcookie

    :::EDIT1:.
    Ich schau später in die logfiles des Servers. Vielleicht finde ich was schlaues.

    Zur index.php:
    echo "hallo5"; // wird angezeigt
    // Instantiate the application.
    $app = JFactory::getApplication('site');
    echo "hallo6"; // wird nicht mehr angezeigt


    lg daniel
    :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    Mein erstes Joomla Projekt war www.saar-wingchun.de

  4. #4
    Hat hier eine Zweitwohnung Avatar von Sieger66
    Registriert seit
    23.05.2010
    Beiträge
    1.798
    Bedankte sich
    14
    Erhielt 470 Danksagungen
    in 442 Beiträgen

    Standard

    joom-config benutzen:

    https://www.fc-hosting.de/support/tools.php

    Eventuell ist aber auch dein Backup unvollständig bzw. fehlerhaft.

    Deine Jommla-Version ist veraltet:
    https://forum.joomla.de/thread/7818-joomla-3-9-6/

    Dein Browser ist veraltet:
    Firefox 66.0.5 ist derzeit die aktuelle Version
    Geändert von Sieger66 (15.05.2019 um 17:49 Uhr)
    Gelöstes Problem bitte so markieren http://www.joomlaportal.de/forenrege...tel-ndern.html
    Fragen und Antworten zu Joomla in den Joomla FAQ
    - Danke für den Klick auf Danke

  5. #5
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.733
    Bedankte sich
    153
    Erhielt 2.226 Danksagungen
    in 1.995 Beiträgen

    Standard

    1.) Entpacke ein FULL-Zip-Paket deiner Joomlaversion. Lösche Ordner /installation/ und /templates/. Kopiere Rest per FTP über deine Installation drüber.
    2.) Weil du bei HostEurope bist:
    - Prüfe stichprobenartig Ordner-Rechte. Sollten 0755 sein.
    - ... Datei-Rechte: Sollten 0644 sein.
    Kannst ggf. über FileZilla im Sammellauf ändern. Vielleicht auch aus Hosteurope-Kunden-Login. Bei mir ging das letztens nicht, also mit FileZilla erzwungen.
    3.)
    "PHP-Interface für den Webserver apache2handler"
    Sollte eigentlich was mit "cgi", fcgi, fpm-fcgi oder ähnlich genannt sein statt "apache2handler". Damit Webseite überhaupt auf Dateien zugreifen darf, die per FTP hochgeladen wurden. "www-run"-Problem.
    Weiß nicht mehr, ob es bei HE Möglichkeit gibt, nach FTP-Uploads die Dateien auf Besitzer/Owner: PHP-User umzustellen im Hosteurope-Kunden-Login.
    Vielleicht gibts ja auch tatsächlich irgendeine Mögl. auf fcgi umzuschalten. Kann mich nicht mehr erinnern.

    4.) Dann das durchspielen:
    https://forum.joomla.de/thread/6467-...us-call-stack/

    Und oben Gesagtes sind paar der Gründe, warum ich Kunden überrede, zu einem anderen Hoster als HE zu wechseln, wenn sie nicht mehr wollen, als Joomlaseite oder ähnlich Kleinkram zu betreiben, was bei den meisten Providern ohne jegliches Zutun möglich ist. Auch, wenn das für mich geschäftsschädigend ist, weil Kunde dann nicht regelmäßig meine Mithilfe braucht ;-) Oder anders: Man sollte einen triftigen Grund haben bei HE zu sein.
    Geändert von Re:Later (15.05.2019 um 18:34 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  6. #6
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    776
    Bedankte sich
    51
    Erhielt 101 Danksagungen
    in 98 Beiträgen

    Standard

    Zitat Zitat von saardaniel Beitrag anzeigen
    ich habe eben eine Joomla 3.9 kopiert (DB + Code kopiert)
    Die Daten der laufenden Joomla Version runtergeladen und in einen neuen Folder auf den Server geladen.
    Dann die Confi-Datei angepasst mit den DB- Daten.
    Hallo Daniel,

    was ich nicht verstehe ist, von wo hast Du Joomla + DB kopiert? Beschrieben hast Du die Version 3.9

    Unter deinen Systemangaben in Post #3 jedoch schreibst Du von Joomla 3.8.12

    Zitat Zitat von saardaniel Beitrag anzeigen
    Joomla System:
    Joomla!-Version Joomla! 3.8.12 Stable [ Amani ] 28-August-2018 14:00 GMT
    Kannst Du daher bitte nochmal genau erklären, um welche Joomlaversion es bei dir tatsächlich geht?


    Gruß Faro

  7. #7
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    61
    Beiträge
    19.597
    Bedankte sich
    756
    Erhielt 4.001 Danksagungen
    in 3.759 Beiträgen

    Standard

    ...und eine Kleinigkeit: stelle in der Joomla-Konfig mal den Datenbanktyp auf mySQLi - wird sich war nicht auf die weiße Seite auswirken, aber auf deine Daten.


    Axel
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    CCK SEBLOD-Das Handbuch als kostenloses Onlinebook

  8. #8
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.733
    Bedankte sich
    153
    Erhielt 2.226 Danksagungen
    in 1.995 Beiträgen

    Standard

    "...und in einen neuen Folder auf den Server geladen. Dann die Confi-Datei angepasst mit den DB- Daten."

    Dann fehlen noch die tmp und logs-Angaben.

    Aber faro02 hat schon recht. Ganz blicke ich auch nicht durch, was du eigentlich gemacht hast und welche nun eigentlich nicht läuft.
    Joomlafachmann: https://www.ghsvs.de

  9. #9
    Verbringt hier viel Zeit Avatar von saardaniel
    Registriert seit
    10.08.2005
    Beiträge
    557
    Bedankte sich
    24
    Erhielt 7 Danksagungen
    in 6 Beiträgen

    Standard

    Danke Sieger66.

    bitte beantworte noch diese Fragen.

    Würde Joomla diese (oben in meinem TExt beschriebene) Fehlermeldung bringen wenn

    a) Der Path falsch gesetzt ist in der config? ( Den kann man übrigens ganz einfach mit jedem Editor ändern. Datei öffnen, ändern, speichern, hochladen).

    b) Mein Jooma vielleicht 1,2 Versionen (3.9.(letzte Version minus x)( x Element (1,2)) älter ist?

    c) Mein Browser nicht in der aktuellsten sondern in der vorletzten Version installiert ist. Dein Hinweis auf 66.0.5 erweckt bei mir den Eindruck, dass das zb in einer Version 65... das Joomla diesen Fehler erzeugen würde.
    Verstehe ich dich damit richtig?

    EDIT1:
    Bei c glaube ich nämlich, dass jede Browser Version (FF,Chrome, Edge, Safari usw) den Fehler bringt, da dieser serverseitig entsteht.


    lg daniel
    Geändert von saardaniel (18.05.2019 um 08:15 Uhr)
    :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    Mein erstes Joomla Projekt war www.saar-wingchun.de

  10. #10
    Verbringt hier viel Zeit Avatar von saardaniel
    Registriert seit
    10.08.2005
    Beiträge
    557
    Bedankte sich
    24
    Erhielt 7 Danksagungen
    in 6 Beiträgen

    Standard

    Re:Later

    Gute Idee!

    grundsätzliches: Wegen den Verzeichnissrechten wäre es gut, wenn Joomla hier dann mehr passende Fehlermeldungen bringen würde.
    Vielleicht macht es das ja, wenn ich den richtigen Schalter umlege
    Sowas wie: " Keinen ZUgriff auf Folder XY, bitte prüfen Sie die Verzeichnissrechte, diese sollten mindestens sein 777 ..."

    Die Daten die grade nicht laufen sind eine Kopie einer Joomla-Page im selben Packet.
    Dein Punkt 3 sollte es nicht sein, aber ich schau denoch.


    ..
    Mich ärgert etwas der Weg und das Verhalten des Filzezilla (Ich vertaue ihm kaum).
    Ich muss alle Joomla-Daten auf mein lokales System laden und dann nochmal hochlade.
    Hätte ich einen Shellzugriff ginge so eine Datenkopie in einer Sekunde.
    Manchmal bringt dann Filezila Fehlermeldungen beim Upload. Das ist immer dann der Fall, wenn der Upload (warum auch immer)
    abbricht. Das Tool baut dann nochmal eine neue Verbindung auf. Da scheint manchmal was schief zu gehen.
    Da könnte es wirklich sein, dass mal ein wichtiges File fehlt.

    Was ich bei Wordpress gut finde, ist dieses wp-import/ Export - Plugin.
    In einer "nackten" Wordpress-Installation importiere ich ein zuvor mit dem Tool exportiertes Wordpress.
    Darin sind alle wichtigen Daten enthalten. Also DB-Daten, Bilder usw.

    Gibt es da etwas professionelles für Joomla?

    liebe Grüße,
    Daniel
    :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    Mein erstes Joomla Projekt war www.saar-wingchun.de

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein