+ Antworten
Ergebnis 1 bis 7 von 7

Thema: Joomla! mit PHP 7 betreiben- wie?

  1. #1
    Verbringt hier viel Zeit
    Registriert seit
    24.07.2005
    Ort
    oberfrangen-midde
    Beiträge
    553
    Bedankte sich
    28
    Erhielt 42 Danksagungen
    in 42 Beiträgen

    Standard Joomla! mit PHP 7 betreiben- wie?

    Hallo,
    die Suchmaschine zeigt mir keine Anleitung...
    Wie im Backend gefordert möchte ich meine aktuellen Seiten von PHP 5.6x bei dem Provider ( DomainExpress) mit PHP 7.x zukünftig betreiben.

    Wenn ich beim Provider im Kundenmenue das PHP auf 7 stelle, bekomme ich auf der Joomlaseite nur " Error" gemeldet.
    Auskunft Provider :in config.php den $ Host = 127.0.0.1 einstellen -nicht localhost..

    Leider war damit auch keine Änderung erkennbar.
    ( ich bin zwischenzeitig wieder auf PHP5.6 zurück - und damit läufts)

    Wo liegt mein Fehler-- danke für alle Infos

    hannerich grüßt aus Franken

  2. #2
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    785
    Bedankte sich
    51
    Erhielt 104 Danksagungen
    in 101 Beiträgen

    Standard

    Moin,

    welche Joomla - Version ist bei dir aktuell?

  3. #3
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.980
    Bedankte sich
    201
    Erhielt 1.272 Danksagungen
    in 1.238 Beiträgen

    Standard

    Betrifft es Frontend und Backend?
    Sind auch alle Erweiterungen PHP 7-tauglich?
    Sonst erst aktualisieren!
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  4. #4
    Verbringt hier viel Zeit
    Registriert seit
    24.07.2005
    Ort
    oberfrangen-midde
    Beiträge
    553
    Bedankte sich
    28
    Erhielt 42 Danksagungen
    in 42 Beiträgen

    Standard

    Bei mir ist V. 3.9.4 seit vorgestern installiert...

    Und es betrifft Front und Backend -- und .. hmm es gibt eine Bilder-Galleriefunktion , die ich nicht genau beurteilen kann - werde diese abschalten...

  5. #5
    Verbringt hier viel Zeit Avatar von hechtnetz
    Registriert seit
    02.08.2010
    Ort
    OWL
    Beiträge
    935
    Bedankte sich
    302
    Erhielt 190 Danksagungen
    in 180 Beiträgen

    Standard

    Zitat Zitat von hannerich Beitrag anzeigen
    Wenn ich beim Provider im Kundenmenue das PHP auf 7 stelle, bekomme ich auf der Joomlaseite nur " Error" gemeldet.
    Auskunft Provider :in config.php den $ Host = 127.0.0.1 einstellen -nicht localhost..
    Das würde ich jetzt nicht unbedingt als wahrscheinliche Ursache annehmen.
    Ich nehme mal an, dass Du in der Kundenoberfläche des Providers die PHP-Versionen umstellst?
    Denno:
    Während 5.6 läuft im BE "Fehler berichten" auf Maximum stellen und Debug-Modus einstellen (>> Link).
    Meldungen hier posten (bitte nicht als Screenshot, da i. d. R. unlesbar).

    Ansonsten:
    Ist die htaccess aktiviert und wenn ja: original oder angepasst?

    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose )

  6. #6
    Verbringt hier viel Zeit
    Registriert seit
    24.07.2005
    Ort
    oberfrangen-midde
    Beiträge
    553
    Bedankte sich
    28
    Erhielt 42 Danksagungen
    in 42 Beiträgen

    Standard

    Danke " hechtnetz"
    für die Hinweise .. ich werde diese mal abarbeiten und sehen.

    .... ja,, die Einstellung für PHP 7 geschieht im Kundenmenu des Providers durch Auswahl... und ich gehe davon aus , dass die Anweisung
    den " localhost" gegen die Einstellung 127.0.0.1 in der zentralen Config.php auszutauschen korrekt ist.

    ich gebe dann Rückmeldung

    Hannerich

  7. #7
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.980
    Bedankte sich
    201
    Erhielt 1.272 Danksagungen
    in 1.238 Beiträgen

    Standard

    ... es ist immer die Rede von PHP 7. In aller Regel meint man damit PHP 7.0.

    Wenn du sowieso gerade alles optimierst, dann nutze gleich PHP 7.2!

    Auf PHP 7.3 zunächst verzichten, auch wenn viele Seiten damit bereits einwandfrei laufen. Auch hier kommt es auf die Kompatibilität von Drittanbieter-Erweiterungen an. Wichtig also, zunächst die Fehler zu ermitteln. Link, wie man das macht, wurde dir ja bereits gegeben.

    Während der Fehler-Ermittlung muss natürlich die neue PHP-Version eingestellt sein. Bedenke, dass eine Umstellung beim Hoster immer ein wenig Zeit benötigen kann, bis die Änderung wirksam wird. Und leere danach erst einmal alle Caches.
    Geändert von JoomlaWunder (15.03.2019 um 10:44 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  8. Erhielt Danksagungen von:


+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein