+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Warning: Class 'Joomla\Registry\Registry' not found

  1. #1
    Neu an Board
    Registriert seit
    09.09.2013
    Ort
    Altdorf bei Nürnberg
    Beiträge
    5
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Beitrag Warning: Class 'Joomla\Registry\Registry' not found

    Die Joomla-Website https://example.de/ beim Provider lima-city, auf die sich diese Anfrage bezieht, kann nicht mehr geöffnet werden. Aus diesem Anlass wurde auch ein Versuch unternommen, die Website auch unter Xampp zu installieren. Unter Xampp lautet die Fehlermeldung :
    Warning: Class 'Joomla\Registry\Registry' not found in C:\xampp\htdocs\Holger\html\libraries\loader.php on line 685
    Error: Failed to start application: Class 'Joomla\Registry\Registry' not found

    Unter lima-city muss man als Freespace-Nutzer erst die php-Datei im doing yourself ergänzen, aber dann kriegt man unter lima-city analog zu Xampp die Fehlermeldung:

    Warning: Class 'Joomla\Registry\Registry' not found in /home/webpages/lima-city/example(Holger)/html/libraries/loader.php on line 685
    Error: Failed to start application: Class 'Joomla\Registry\Registry' not found

    Informationen zum Störfall:
    Keine Lösung mit Suchmaschine gefunden.
    Joomla-Version: Bezogen auf 3.9 vermutlich 2 updates noch ausstehend.
    PHP-Version: lima-city und Xampp: 7.1
    SQL-Version: lima-city: 4.7.0, Xampp:: 4.8.4
    Betriebssystem PC: Win 10
    Fehlervermutung: Im Zuge der verzögerten Umstellung der PHP-Version bei lima-city und der für die Website versäumten updates für Joomla ist Sand ins Getriebe gekommen.
    Mein Wissensstand: Ich bin zwar kein Fortgeschrittener, aber auch kein blutiger Laie. Einen zielführenden Hinweis kann ich in aller Regel erfolgreich umsetzen.
    Dafür im voraus herzlichen Dank!
    Geändert von adopol (10.02.2019 um 17:44 Uhr)

  2. #2
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Zitat Zitat von adopol Beitrag anzeigen
    Joomla-Version: Bezogen auf 3.9 vermutlich 2 updates noch ausstehend.
    PHP-Version: lima-city und Xampp: 7.1
    SQL-Version: lima-city: 4.7.0, Xampp:: 4.8.4
    Betriebssystem PC: Win 10
    Welche genaue Xampp-Version? Welche MySQL-Version (5.1 /5.5/ 5.7) ? Vermutlich hast du nicht die richtigen Versionen gepostet.

    Schau auch mal hier: https://downloads.joomla.org/technical-requirements

    Grundsätzlich ist "Warning" keine Fehlermeldung. Kannst du mittels "Fehler berichten" auf "keine" setzen dann vermeiden.
    Gibt es weitere Probeme auf der Seite oder nur dies "Warning"?
    Mögliche Drittanbieter-Erweiterungen sind alle aktuell?

    Soll das mit dem "html"-Ordner so sein oder wäre der überflüssig?
    Hast du einen Link zur Seite?
    Geändert von JoomlaWunder (02.02.2019 um 12:06 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  3. #3
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.795
    Bedankte sich
    156
    Erhielt 2.255 Danksagungen
    in 2.022 Beiträgen

    Standard

    @joomlawunder Auf die Warning folgt ein Fatal Error.

    1) in Datei administrator\manifests\files\joomla.xml nachsehen, welche Joomla-Version das ist, z.B.
    <version>3.9.2</version>

    2) Full-Paket der gefundenen Version entpacken und Ordner installation/ und templates/ löschen. Rest über das Joomla drüberkopieren.

    3) Prüfen, ob die PHP-Version passt. Wenn Joomla zu alt ist, ist PHP 7 nicht geeignet.

    4) In der configuration.php folgende Werte umschreiben und schauen, ob (mit Glück) mehr angezeigt wird.
    Code:
    public $debug = '1';
    public $error_reporting = 'maximum';
    Joomlafachmann: https://www.ghsvs.de

  4. Erhielt Danksagungen von:


  5. #4
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Zitat Zitat von Re:Later Beitrag anzeigen
    @joomlawunder Auf die Warning folgt ein Fatal Error.
    Glatt überlesen!
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  6. #5
    Neu an Board
    Registriert seit
    09.09.2013
    Ort
    Altdorf bei Nürnberg
    Beiträge
    5
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Antwort auf die Fragen des Kommentars von JoomlaWunder
    Versionen:
    Xampp 7.1.26
    MySQL 5.7 (Anwendung Xampp)
    MySQL 5.6 (Anwendung lima-city)
    Zu „Warning“-Kommentar:
    „Warning“ ist nur die Begleitmusik zum zentralen Problem, dass die Website nicht mehr geöffnet werden kann, sowohl unter lima-city wie auch unter Xampp.
    Keine Drittanbieter-Erweiterungen.
    html-Ordner: Bei lima-city eine feste Vorgabe, unter Xampp nicht zwingend.
    Link zur Website: http://holger-kies.de/

  7. #6
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Da du wohl Joomla 3.9.1 installiert hast, lade dir das Full-Paket 3.9.1 herunter, entpacke es und kopiere es einfach drüber.
    (In Xampp geht das ja recht flott und auf dem Webserver könnte man es auch direkt dort entpacken, wenn du weißt wie. Dann bräuchtest du nur 1 Datei hochladen.)
    In Beitrag 3 steht bereits, was du genau machen musst und welche Verzeichnisse du nicht drüberkopieren solltest.
    Sobald du im Backend bist, dort auch nochmal unter "Datenbank" auf "Reparieren" klicken.

    Wenn du keine Drittanbieter-Erweiterungen hast, um so besser. Dann könnte es damit bereits erledigt sein. Ansonsten "Fehler berichten" und "Debugging" aktivieren. Anleitung auch in Beitrag 3! Weitere Infos auch hier: https://forum.joomla.de/thread/6467-...4707#post44707

    Wenn die Webseite wieder läuft, abschließend über die entsprechende Komponente "Joomla Aktualisierung" auf 3.9.2 aktualisieren!
    Geändert von JoomlaWunder (03.02.2019 um 09:58 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  8. #7
    Neu an Board
    Registriert seit
    09.09.2013
    Ort
    Altdorf bei Nürnberg
    Beiträge
    5
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Antwort auf Post von Re:Later
    1) <version>3.9.1><version> (zu meiner Überraschung)
    2) Full-Paket Version 3.9.1 geladen und nach Anweisung verfahren: Leider nach wie vor kein Zugriff auf das backend
    3) PHP-Version 7.1 müsste geeignet sein.
    4) Configuration.php wie vorgeschlagen umgeschrieben: kein Glück! Es wird nicht mehr angezeigt sondern die alte Warning.

  9. #8
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Sonst stell mir mal einen FTP-Zugang zur Verfügung (wenn du magst)!
    Hast du Joomla nur lokal oder auch schon auf dem Webserver "drüberkopiert"?
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  10. Erhielt Danksagungen von:


  11. #9
    Neu an Board
    Registriert seit
    09.09.2013
    Ort
    Altdorf bei Nürnberg
    Beiträge
    5
    Bedankte sich
    3
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Nach derzeitigem Stand gibt es für die Website, bei der sich weder backend noch frontend öffnen lässt, bei allen Varianten (das Original bei lima-city, die identische Version auf Xampp und die mit Hilfe des Full-Pakets der Joomla-Version 3.9.1 gewonnene modifizierte Variante) eine auffällige Konstante: Die Art der immer gleichen Fehlermeldung, die offensichtlich ihrerseits fehlerhaft ist: ...\libraries\loader.php on line 685. An dieser Stelle ist aber mitnichten irgendetwas Erhellendes abzulesen, denn es ist ja standardisierter Text, der im Übrigen für gestörte und ungestörte Websites identisch ist.
    Welcher Grund kann hier vorliegen und kann man daraus einen Ansatz für die Fehlersuche gewinnen?

    Zur letzten Post:
    FTP-Zugang: .........., Benutzer: ..........., Passwort: ...... (Das Passwort soll natürlich nach der Aktion von mir geändert werden)
    Auf dem Webserver habe ich nichts "drüberkopiert" .
    Die nochmalige Änderung (Löschung jetzt auch bei FTP-Zugang und Benutzer) geht auf Empfehlung von JoomlaWunder zurück.
    Geändert von adopol (04.02.2019 um 08:52 Uhr)

  12. #10
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    785
    Bedankte sich
    51
    Erhielt 104 Danksagungen
    in 101 Beiträgen

    Standard

    JoomlaWunder wollte den FTP Zugang mit Sicherheit per PN haben.

    FTP Zugänge bitte niemals öffentlich Posten.

    Bitte diesen Zugang ganz schnell wieder deaktivieren und per PN einen neuen senden.

  13. Erhielt Danksagungen von:


+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein