+ Antworten
Ergebnis 1 bis 8 von 8

Thema: Installation in falsche Datenbank

  1. #1
    Neu an Board
    Registriert seit
    28.02.2010
    Beiträge
    12
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Installation in falsche Datenbank

    Hallo, mir ist ein folgenschwerer Fehler unterlaufen.
    Bei dem Überarbeiten meins Webangebots ist mir ein Fehler unterlaufen. Beim Hochkopieren auf den Server habe ich aus Versehen das falsche Verzeichnis gewählt und Dateien vom Joomla 3.9 in das aktuelle Webangebot kopiert. Das ist allerdings noch auf Joomla 2.5. Da das noch nicht genug ist, ich habe keine Sicherung von dem Angebot.
    Dann habe ich eine neue Installation von 2.5.28 in ein neues Verzeichnis vorgenommen, allerdings in die gleiche Datenbank. Bei der Installation wurde die alten Datenbankinhalte gesichert.

    Jaaa, ich weiß, ich habe hier mehrere kapitale Fehler begangen.

    Um das alte Angebot wenigstens für mich zugänglich zumachen, will ich die alten Datenbankinhalte in das neuaufgesetzte System der Version 2.5x einspielen.

    Nun zu meiner Frage, wie komme ich an die bei der Installation angelegte Sicherung der Datenbank, denn dies habe ich bei der Installation ausgewählt.

    Im voraus vielen Dank für eure Hilfe.

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.682
    Bedankte sich
    152
    Erhielt 2.211 Danksagungen
    in 1.981 Beiträgen

    Standard

    Haben beide Joomlas vielleicht unterschiedliche Datenbankprefixe? Wenn ja, hast vielleicht Glück und die Joomla-Tabellen kommen sich eh nicht in die Quere. Und du musst in der Joomla-Konfiguration nur den Prefix umstellen.

    Zur Frage: Im Normalfall erhalten die gesicherten Tabellen ein bak_-Prefix. Die kannst ja bei Export auswählen. In der SQL-Datei tauscht dann diese Prefixe z.B. mit Editor Notepad++ gegen die richtigen per Sammelsuchen/ersetzen aus, bevor du sie importierst
    Joomlafachmann: https://www.ghsvs.de

  3. Erhielt Danksagungen von:


  4. #3
    Neu an Board
    Registriert seit
    28.02.2010
    Beiträge
    12
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ja, sie haben unterschiedliche Präfixe.

    Ok, die Sicherung der alten Datenbank habe ich nun auf meinem Rechner

    Vielen Dank, werde versuchen das Präfix in der Datei zu ändern und dies dann neu zu importieren.

  5. #4
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.682
    Bedankte sich
    152
    Erhielt 2.211 Danksagungen
    in 1.981 Beiträgen

    Standard

    Eigentlich musst nur, wenn altes Joomla und neues Joomla in der selben DB liegen, aber unterschiedliche Prefixe verwenden im Backend vom neuen Joomla in der Konfiguration den alten Prefix unter Datenbank-Überschrift reinschreiben.
    Nach meiner Denke musst da nix neu importieren. Außer du hast alte Tabellen gelöscht.
    Joomlafachmann: https://www.ghsvs.de

  6. Erhielt Danksagungen von:


  7. #5
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.848
    Bedankte sich
    201
    Erhielt 1.226 Danksagungen
    in 1.193 Beiträgen

    Standard

    Zitat Zitat von karlchen63 Beitrag anzeigen
    Ja, sie haben unterschiedliche Präfixe.
    Joomla in neuem Verzeichnis und alte DB verwendet, aber mit neuem Präfix: Dann sollte deine Webseite einwandfrei laufen, es sei denn, dir sind weitere Fehler passiert.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  8. Erhielt Danksagungen von:


  9. #6
    Neu an Board
    Registriert seit
    28.02.2010
    Beiträge
    12
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo Leute, zuerst einmal vielen Dank für eure Hinweise und Anregungen und hier ein Zwischenstand.
    Ich habe den Dump der Datenbank mit dem alten Präfix exportiert und das Präfix in das neue geändert und wieder importiert. Hat nicht geholfen.
    Dabei habe ich festgestellt, dass die beiden Strukturen nicht identisch sind, es sind unterschiedliche Anzahl von Tabellen und es sind kleine Abweichungen in der Bezeichnung einiger Tabellen. Die Tabellennamen habe ich in dem Dump entsprechend der neueren Struktur angepasst. Hat auch nicht geholfen

    Habe dann eine Joomla Versin 2.5.18 und 2.5.1 installiert und das Gleich für jede Version noch einmal gemacht. Auch hier ist die Anzahl der Tabellen und deren Bezeichnung etwas abweichend. Hat auch nicht geholfen. Meine Ausgangsversion war die 2.5.28.

    Als nächstes werde ich nur die Tabellen mit Inhalten, *banner, *banner_client, *categories, *content, *menu und *menu_typs, aus dem Dump extrahieren und in einefrische 2.5.28 importieren.
    Wenn auch das nicht funktioniert, bin ich mit meinem Latein am Ende.

    Hat vielleicht von euch noch jemand eine Idee?

  10. #7
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.682
    Bedankte sich
    152
    Erhielt 2.211 Danksagungen
    in 1.981 Beiträgen

    Standard

    Natürlich müssen die Versionen übereinstimmen. Und zuinstallierte Erweiterungen legen nat. auch gelegentlich Tabellen an und viele davon löschen sie bei Deinstallation auch nicht.
    Joomlafachmann: https://www.ghsvs.de

  11. Erhielt Danksagungen von:


  12. #8
    Neu an Board
    Registriert seit
    28.02.2010
    Beiträge
    12
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Okay Leute, vielen Dank für eure Hilfe.

    Habe das Angebot geschrottet und muss nun wohl aus dem Datenbank-Dump die Inhalte einzeln extrahieren und die Seite neu aufbauen.

    Viele Grüße karlchen

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein