+ Antworten
Seite 2 von 4 ErsteErste 1 2 3 4 LetzteLetzte
Ergebnis 11 bis 20 von 33

Thema: PHP Versionsmeldung im Backend

  1. #11
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.756
    Bedankte sich
    200
    Erhielt 1.194 Danksagungen
    in 1.161 Beiträgen

    Standard

    Es gibt PHP 7.0, 7.1, 7.2 .
    PHP 7 gibt es nicht. Deshalb immer die konkrete Version angeben, damit wir nicht aneinander vorbeireden.

    Du schreibst, dass du zunächst auf PHP 7.0 einstellst, wo dann die Fehlermeldung kommt. Dann schreibst du, dass du den Eintrag herausnimmst, der für die Einstellung auf PHP 7.2 verantwortlich ist. Beide dürfen nicht gleichzeitig in der .htaccess stehen.
    Man stellt also nicht zuerst eine Art Grundversion PHP 7 ein und ergänzend dann die 7.2, sondern es darf nur 1 Eintrag geben, der auf PHP 7.0 oder PHP 7.1 oder PHP 7.2 umschaltet.
    Aber wie gesagt, nimm zuerst mal alles raus und schau, welche PHP-Version im Backend angezeigt wird!

    EDIT: Beiträge haben sich gerade überschnitten.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  2. #12
    Kommt häufiger vorbei
    Registriert seit
    01.06.2012
    Ort
    In der Höll
    Beiträge
    478
    Bedankte sich
    123
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Ich habe den Befehl mit 7.0 erfasst.
    Nun würde diese Meldung im Frontend angezeigt werden.

    Forbidden
    You don't have permission to access /index.php on this server.


    Würdest Du mir bitte den genauen Befehl schicken. Vielleicht fehlt ein Leerzeichen oder so.

  3. #13
    Hat hier eine Zweitwohnung Avatar von kitepascal
    Registriert seit
    19.03.2009
    Ort
    bei Aachen
    Beiträge
    1.377
    Bedankte sich
    96
    Erhielt 539 Danksagungen
    in 511 Beiträgen

    Standard

    Lass den .htaccess Eintrag am besten ganz weg und steuere die PHP Version über Strato.
    ↙ | website-bereinigung.de → Support-Chat

  4. #14
    Kommt häufiger vorbei
    Registriert seit
    01.06.2012
    Ort
    In der Höll
    Beiträge
    478
    Bedankte sich
    123
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Wenn ich den Eintrag aus der .htaccess lösche kommt der Fehler: Umleitungsfehler im Frontend.
    Habe vorher den Cache etc. vom Browser gelöscht.
    Schaust dir bitte mal meine Eintragung in der .htaccess Datei ein. Siehe Beitrag #9

  5. #15
    Wohnt hier Avatar von gottypower
    Registriert seit
    19.11.2005
    Ort
    im Core
    Alter
    53
    Beiträge
    2.053
    Bedankte sich
    60
    Erhielt 616 Danksagungen
    in 581 Beiträgen

    Standard

    wirf deine .htaccess einmal über Bord und lade dir das aktuelle Paket runter und verwende die .htaccess aus dem Paket... Wenn es dann funktioniert, kannst Optimierungen vornehmen.
    Einfach kann jeder...

    und immer schön danke sagen

  6. #16
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.756
    Bedankte sich
    200
    Erhielt 1.194 Danksagungen
    in 1.161 Beiträgen

    Standard

    Zitat Zitat von JMLA_Userin Beitrag anzeigen
    Wenn ich den Eintrag aus der .htaccess lösche kommt der Fehler: Umleitungsfehler im Frontend.
    Schritt für Schritt:
    Wenn du die PHP-Versionseinstellung in der .htaccess mal gelöscht hast, welche PHP-Version wird dann im Backend angezeigt?
    Wir versuchen immer noch herauszfinden, welche PHP-Version du bei Strato eingestellt hast.
    Link zur Webseite?
    Beachte auch den Joomla-Cache (falls verwendet), den man auch leeren kann!
    Geändert von JoomlaWunder (04.12.2018 um 16:22 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  7. #17
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.436
    Bedankte sich
    122
    Erhielt 1.893 Danksagungen
    in 1.484 Beiträgen

    Standard

    Nebenbei:
    Das Joomla die PHP-Version als "Fehler" deklariert ist wirklich nicht hinzunehmen. Wir merken das hier im Support sehr stark, wenn sich plötzlich massenhaft Kunden über einen solchen "Fehler" beschweren. Viele stellen dann blind um und oft sind noch alte Erweiterungen im Einsatz und dann gibts echte Fehler....

    Die PHP-Version sollte allerhöchstens als Warnung angezeigt werden.

  8. Erhielt Danksagungen von:


  9. #18
    Hat hier eine Zweitwohnung Avatar von kitepascal
    Registriert seit
    19.03.2009
    Ort
    bei Aachen
    Beiträge
    1.377
    Bedankte sich
    96
    Erhielt 539 Danksagungen
    in 511 Beiträgen

    Standard

    Warnung vs. Fehler richtet sich denke ich nach den offiziellen Terminen.
    http://php.net/eol.php

    7.0 ist seit 1 Tag unsupported - seitdem ist die Warnung nehme ich an ein Fehler. Als ich meinen Blogpost dazu geschrieben habe, war das nämlich noch nicht so.
    Oder das kam mit dem 3.9.1 Update - wie auch immer..
    ↙ | website-bereinigung.de → Support-Chat

  10. #19
    Kommt häufiger vorbei
    Registriert seit
    01.06.2012
    Ort
    In der Höll
    Beiträge
    478
    Bedankte sich
    123
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Hallo JoomlaWunder,

    Punkt 1 ok mache ich mal.
    Punkt 2 wie im Beitrag #1 geschrieben.
    Beim Webhoster ist PHP Version 7.2 in Verwendung.
    Punkt 3 Link zur Seite: www.ergo-tec.com
    Punkt 4 Ich lösche auch mal den Joomla-Cache. Melde mich wieder.

    Hallo flotte,
    ich habe alle angezeigten Erweiterungen aktualisiert und auch Joomla 3.9.1 - seit heute
    Geändert von JMLA_Userin (04.12.2018 um 19:04 Uhr)

  11. #20
    Kommt häufiger vorbei
    Registriert seit
    01.06.2012
    Ort
    In der Höll
    Beiträge
    478
    Bedankte sich
    123
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    So, ich habe es getestet:
    Als erstes den Joomla Cache geleert.

    Wenn ich den Befehl aus der .htaccess heraus lösche zeigt es mir im Backend die PHP 7.2.10 an.
    Wenn ich den Befehl wieder einfüge in die .htaccess zeigt es mir im Backend die PHP 7.0.32 an.
    Ich würde sagen, dass der Befehl richtig arbeitet.

    Aber wenn ich den Befehl heraus lösche zeigt es mir im Frontend wieder eine leere Seite an.
    Ich habe auch andere Websites die mit dem gleichen Template und der aktuellen PHP Version funktionieren. Also liegt es nicht am Template!

    Als nächstes tausche ich die .htaccess aus einem neuen Joomla Paket mal aus.
    Ergebnis: Leider zeigt es mir nun wieder im Frontend einen Umleitungsfehler an.
    Geändert von JMLA_Userin (04.12.2018 um 19:13 Uhr)

+ Antworten
Seite 2 von 4 ErsteErste 1 2 3 4 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein