+ Antworten
Seite 1 von 4 1 2 3 4 LetzteLetzte
Ergebnis 1 bis 10 von 31

Thema: Migration von 2.5 auf 3.x Überprüfung der/aller Erweiterungen

  1. #1
    War schon öfter hier
    Registriert seit
    07.09.2008
    Beiträge
    109
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Migration von 2.5 auf 3.x Überprüfung der/aller Erweiterungen

    Hallo zusammen,

    ich muss (dringend) diese Seite von Joomla 2.5.28 nach 3.x (aktuellste Version) upgraden/migrieren.
    http://j3.sgcessen.de/

    Hierzu habe ich mir mehrere "Anleitungen" durchgelesen und versuche nun Schritt-für-Schritt sauber und korrekt vorzugehen. Die genannte Seite ist bereits eine Sicherheitskopie (vermerkt an dem Modul mit dem Eintrag "Testumgebung") und ein Backup der DB wurde auch erstellt.

    In dieser Anleitung:
    https://docs.joomla.org/Joomla_2.5_t...p_Migration/de

    wird als nächster Schritt "Jede Erweiterung einschätzen" genannt.
    Hier stehe ich allerdings vor dem Problem, dass ich das beim besten Willen nicht umfänglich hinbekomme. Die Liste aller Erweiterungen umfasst über 150 Einträge und ich kann nur bei den allerwenigsten die tatsächliche Notwendigkeit oder Herkunft einschätzen (z.B. ImageSizer oder Wrapper – diese hatte ich selbst mal installiert soweit ich mich erinnern kann).
    Sicherlich sind einige der Erweiterungen systembedingt, einige andere nicht (mehr) notwendig, wiederum andere muss ich ggfs. gar nicht beachten.

    Hier ein Screenshot der kompletten Liste:


    Wie "dramatisch" wäre es, wenn ich diesen Schritt einfach überspringen würde?

    Da ich sowieso ein neues template finden und anpassen muss/will, wären alle Erweiterungen zum Thema template ohnehin irrelevant. Weiterhin habe ich – laut meiner Erinnerung – nur wenige Plugins auf der Seite aktiv (z.B. Image gallery), die könnte ich sicherlich mit vertretbarem Aufwand nachträglich erneut installieren.

    Was würde passieren, wenn ich einfach eine frische J3.x Installation verwenden und diese auf die aktuelle Datenbank verweisen würde? Würde das überhaupt funktionieren oder kommt es dann zwangsläufig zu Fehlern?

    Über kompetente Ratschläge wäre ich sehr dankbar.
    Geändert von Fralle (16.11.2018 um 09:53 Uhr)

  2. #2
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Zu einer Sicherung gehören die Dateien/Verzeichnisse und die Datenbank-Tabellen, und zwar zum gleichen Zeitpunkt gesichert. Es kann schon sein, dass wenn du die DB-Tabellen ein paar Tage früher oder später sicherst, diese nicht mehr zum Joomla bzw. dessen Erweiterungen passen. Zwingend müsste es sich auch um die gleiche Version handeln, also DB-Tabellen von 3.9.0 und Dateien von 3.9.0. Kurz gesagt: Vergiss dein Vorhaben mir der Datenbank!

    Interessant sind die Erweiterungen mit einer ID > 10.000 (Drittanbieter-Erweiterungen). Akeeba könntest du deinstallieren und neu installieren.
    JCE solltest du einfach aktualisieren können. Ist Sigplus noch im Einsatz? Sind wohl noch Reste vorhanden oder du hast es einfach nur deaktiviert.
    JEvents müsste man auch einfach aktualisieren können.
    Dein T3 Framework scheint aktuell zu sein. Problem könnte das JAT3-Template sein. Aber wenn du dir eh ein neues suchen möchtest, dann schalt erst einmal auf Protostar um und installiere dir später das neue.

    Im großen und ganzen sollte man das eigentlich ganz gut hinbekommen.

    Falls die Seite eher kleiner ist, könntest du dir auch Joomla 3.9 frisch installieren, Menüs/Module anlegen und die Beiträge aus der bisherigen Version übernehmen, entweder per Copy&Paste oder mittels eines Export-/Importtools.

    Tipp: Regelmäßige Sicherungen beim Aktualisieren spart Arbeitszeit, wenn mal 1 Schritt nicht so funktionieren sollte.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  3. #3
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.795
    Bedankte sich
    156
    Erhielt 2.255 Danksagungen
    in 2.022 Beiträgen

    Standard

    "Interessant sind die Erweiterungen mit einer ID > 10.000 (Drittanbieter-Erweiterungen)"
    Meine von der Historie sehr alte Seite ist gespickt mit Drittanbieter-Erweiterungen < 10.000, weil das leider erst irgendwann mal eingeführt wurde, das mit dem 10.000.

    Wollte aber nicht stören und bin schon wieder weg...
    Joomlafachmann: https://www.ghsvs.de

  4. #4
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.946
    Bedankte sich
    201
    Erhielt 1.263 Danksagungen
    in 1.229 Beiträgen

    Standard

    Zitat Zitat von Re:Later Beitrag anzeigen
    Meine von der Historie sehr alte Seite ist gespickt mit Drittanbieter-Erweiterungen < 10.000, weil das leider erst irgendwann mal eingeführt wurde, das mit dem 10.000.
    Gut! Das müsste noch beachtet werden. Weiß gar nicht, wann das überhaupt eingeführt wurde. Schon so lange her.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  5. #5
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.795
    Bedankte sich
    156
    Erhielt 2.255 Danksagungen
    in 2.022 Beiträgen

    Standard

    Ich schwitz schon immer bei jedem Joomla-Update mit neuen Erweiterungen (z.B. zuletzt Privacy), wann's mich trifft mit "geht nicht wegen doppelter ID".
    In Joomla4 versucht man das wohl abzuschaffen, aber wohl nur bei Neuinstallation(?)

    EDIT:
    Autor = Joomla! Project
    scheint (halbwegs) verlässlich zu sein.
    Geändert von Re:Later (17.11.2018 um 12:54 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  6. #6
    War schon öfter hier
    Registriert seit
    07.09.2008
    Beiträge
    109
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Erstmal danke für die kompetente Hilfe.

    Eine Prüfung der Erweiterungen (ID > 10.000) ergibt, dass "eigentlich" nur die Plugins ImageSizer und Image gallery - sigplus im aktiven Einsatz sind. Das T3 Framework ist aktuell und für J3.x geeignet.
    Ich habe dann das Upgrade auf 3.6 durchgeführt. Das hat halbwegs funktioniert. Nur halbwegs, weil auch ein Umschalten auf das Standard Protostar Template im Frontend eine Fehlermeldung im Content-Bereich zur Folge hatte (die Menüpunkte wurden korrekt angezeigt).
    Ich wollte dann den Plugin-Bereich ein bisschen aufräumen und habe nach und nach Plugins auf deaktiv geschaltet. Leider hatte dies plötzlich zur Folge, dass nun diese Fehlermeldung angezeigt wird, sobald ich im Backend aus dem Kontrollzentrum heraus auf irgendeinen anderen Menüpunkt klicke:


    Ja, sicherlich habe ich irgendwo einen Fehler gemacht und möglicherweise das Plugin "Sigplus" im Vorfeld nicht sauber geupdated. :-/

    Jetzt bin ich mir nicht sicher, ob ich versuchen soll, diese Installation zu reparieren (a), das Backup der J2.5 erneut einzuspielen (der upload der Daten dauert leider über eine Stunde) (b) oder mit einer frischen J3.9 Intallation die Seite ganz neu aufzusetzen (c).

    Was würdet ihr mir empfehlen?

    Momentan tendiere ich zu (c), Voraussetzung dafür ist allerdings, dass der Import aller Beiträge reibungslos klappt (manuelles Copy & Paste ist ausgeschlossen, das Archiv beinhaltet ca. ~200 Beiträge). Menüs und Module kann ich manuell neu anlegen, diesen Aufwand halte ich für vertretbar. Ich muss allerdings noch herausfinden, wie ich den Export/Import-Vorgang des Contents durchzuführen habe (Tipps willkommen!) :-)
    Geändert von Fralle (20.11.2018 um 12:44 Uhr)

  7. #7
    Hat hier eine Zweitwohnung Avatar von kitepascal
    Registriert seit
    18.03.2009
    Ort
    bei Aachen
    Beiträge
    1.378
    Bedankte sich
    96
    Erhielt 539 Danksagungen
    in 511 Beiträgen

    Standard

    Deaktiviere das Sigplus Plugin und aktualisiere es dann.

    https://bitbucket.org/hunyadi/sigplus/downloads/
    ↙ | website-bereinigung.de → Support-Chat

  8. #8
    Gehört zum Inventar
    Registriert seit
    26.07.2007
    Ort
    RZ / EA / B
    Beiträge
    7.515
    Bedankte sich
    443
    Erhielt 1.763 Danksagungen
    in 1.642 Beiträgen

    Standard

    Sigplus einfach aktuelle Version besorgen. Den ImageResizer musst du imho auch ersetzen.
    Gruß, Chris
    Joomla kaputt? Gehackt? Migration mißlungen? Datensalat?
    www.cms-reparatur.de - Soforthilfe & Webentwicklung

  9. #9
    War schon öfter hier
    Registriert seit
    07.09.2008
    Beiträge
    109
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von kitepascal Beitrag anzeigen
    Deaktiviere das Sigplus Plugin und aktualisiere es dann.

    https://bitbucket.org/hunyadi/sigplus/downloads/
    Im Backend kann ich die Seite "Plugins" ja gar nicht mehr aufrufen, es kommt fast überall eine leere Seite mit der oben gezeigten Fehlermeldung.

    Kann ich den Ordner einfach löschen stattdessen??

  10. #10
    War schon öfter hier
    Registriert seit
    07.09.2008
    Beiträge
    109
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von kitepascal Beitrag anzeigen
    Deaktiviere das Sigplus Plugin und aktualisiere es dann.

    https://bitbucket.org/hunyadi/sigplus/downloads/
    Im Backend kann ich die Seite "Plugins" ja gar nicht mehr aufrufen, es kommt fast überall eine leere Seite mit der oben gezeigten Fehlermeldung.

    Kann ich den Ordner einfach löschen stattdessen??

+ Antworten
Seite 1 von 4 1 2 3 4 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein