+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Aktualisierung schlägt fehl

  1. #1
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Aktualisierung schlägt fehl

    Hi zusammen,

    Joomla-Noob braucht Eure Hilfe!

    Wenn ich Joomla aktualisieren möchte (3.3.1 -> 3.6.5) erhalte ich immer folgende Meldung:

    ERROR:
    could not open /meinpfad/.../administrator/cache/index.html for writing.

    wenn ich nun die Rechte ändere scheint das zu klappen; dann motzt er an der nächsten Datei rum und immer so weiter, habe dann irgendwann aufgehört und die Rechte wieder zurückgestellt.

    Woran liegt das? Gibt´s irgendwo eine Administrative Einstellung der Art "nötige Rechte zum aktualisieren von Joomla freigeben"? Damit man das hinterher wieder zu machen kann?
    Welchen Ordner könnte ich anpacken?
    Wie sollten genrell Rechte an Ordnern/Dateien aussehen, damit man kein offenes Scheunentor für gelangweilte Scripkiddies darstellt?

    Bin für Tipps Dankbar!
    Lg,
    Jonas

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.808
    Bedankte sich
    156
    Erhielt 2.259 Danksagungen
    in 2.026 Beiträgen

    Standard

    Im Normalfalls Ordner/Dateien: 755/644

    Die Systemionformationen > Tabulator Systeminformationen sollte zeigen:
    PHP-Interface für den Webserver : irgendwas mit cgi, fcgi, f-cgi oder ähnlich

    FTP sollte in der Joomla-Konfiguration nicht aktiviert sein

    Der Verzeichnisrechte-Tabulator sollte alles grün zeigen, außer Datei configuration.php. Die darf rot sein.
    Joomlafachmann: https://www.ghsvs.de

  3. Erhielt Danksagungen von:


  4. #3
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    fast Zeitnah

    bei mir ist fast alles, bis auf die images-ordner rot. 755/644 passt aber.

  5. #4
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.808
    Bedankte sich
    156
    Erhielt 2.259 Danksagungen
    in 2.026 Beiträgen

    Standard

    Was steht unter System > Systeminformationen > Systeminformationen > PHP-Interface für den Webserver

    Da sollte irgendwas mit "cgi" stehen. fcgi, fpm-fcgi o.ä.

    Wer ist der Hoster/Provider?
    Joomlafachmann: https://www.ghsvs.de

  6. Erhielt Danksagungen von:


  7. #5
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zeitnah ist derzeit nicht so meins; mache das nur ehrenamtlich nebenher - sorry

    Hoster ist AllInkl.
    Dieses Update habe ich nun hinbekommen; das aktuelle auf 3.9.6 leider nicht:

    "Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 11018241 bytes) in /../.../.../libraries/joomla/utilities/buffer.php on line 104"

    Jemand eine Idee? Ich nämlich nicht. Welche PHP-Version ist für 3.9.6 erforderlich?

    Danke Euch!

  8. #6
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.808
    Bedankte sich
    156
    Erhielt 2.259 Danksagungen
    in 2.026 Beiträgen

    Standard

    Eine Datei libraries/joomla/utilities/buffer.php gibt es in Joomla 3.9.6 gar nicht.

    Klicke im Backend unter Erweiterungen > Datenbank den Reparieren-Knopf. Dadurch sollten veraltete Dateien und Verzeichnisse gelöscht werden.

    PHP-Version ist 7.2 empfohlen.
    Joomlafachmann: https://www.ghsvs.de

  9. Erhielt Danksagungen von:


  10. #7
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Sodele,
    habe nun auf 7.2 umgestellt und auch die DB repariert.
    nun bekomme ich im Backend auf verschiedesten Seiten folgende Meldung:

    Warning: count(): Parameter must be an array or an object that implements Countable in /.../.../.../libraries/cms/application/cms.php on line 464


    Beim Update kommt:

    Fatal error: Maximum execution time of 30 seconds exceeded in /.../.../.../libraries/joomla/utilities/buffer.php on line 102

    Irgendwas hat er mit dieser buffer.php....

    Danke für Eure Mühe,
    Jonas

  11. #8
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Im Kontrollzentrum zeigt er unter Backend nun folgendes an:
    Backend is up-to-date
    Unbekanntes Joomla!
    Unbekannte Erweiterungen

    Vorher stand dort ja immer der Hinweis auf Updates von Joomla und den Erweiterungen; außer DB-Reparatur und Umstellung auf PHP7.2 ist nichts verändert worden.

  12. #9
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    785
    Bedankte sich
    51
    Erhielt 104 Danksagungen
    in 101 Beiträgen

    Standard

    Moin,

    wie Re:Later es schon gesagt hat, diese Datei gehört nicht zu Joomla: /libraries/joomla/utilities/buffer.php

    Und auch diese gehört nicht zu Joomla: /libraries/cms/application/cms.php

    Welche Erweiterungen hast Du noch installiert? Jedoch glaube ich nicht, dass diese sich dann in diese Ordner schreiben.


    Gruß Faro

  13. #10
    Neu an Board
    Registriert seit
    03.07.2014
    Beiträge
    32
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo Faro,

    aber was will das Update dann mit diesen Dateien?!?

    Erweiterungen:

    Akeeba Backup
    JCE Editor
    jDownloads
    JFuploader
    Joomgallery

    das müssten sie sein.

    Jonas

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein