+ Antworten
Ergebnis 1 bis 9 von 9

Thema: Fehler in com_fields/models/field.php

  1. #1
    Kommt häufiger vorbei
    Registriert seit
    03.04.2005
    Beiträge
    261
    Bedankte sich
    26
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard Fehler in com_fields/models/field.php

    Guten morgen in die Runde!

    Ich suchte bereits im Web wie auch hier nach einer Lösung, fand aber leider nichts zutreffendes und frage daher ob jemand eine Idee oder Lösung hat.
    Eine meiner Websites liegt noch bei einem Anbieter, der immer noch auf PHP 5 setzt (und setzen möchte). Nach einem Update von Joomla 3.8.6 auf 3.8.7 erhielt ich bei Seitenaufruf nur noch eine weiße Seite.
    Daher änderte ich den Eintrag für's Error-Reporting in der cofiguration.php auf "maximum" und sehe jetzt folgendes:

    Warning: Unterminated comment starting line 997 in /home/jcp/amber197/www/administrator/components/com_fields/models/field.php on line 997
    Parse error: syntax error, unexpected end of file, expecting function (T_FUNCTION) in /home/jcp/amber197/www/administrator/components/com_fields/models/field.php on line 1000


    Ich sah mir die betroffene Datei und da steht in den erwähnten Zeilen nur:

    "/**
    * Clean the cache
    *
    * @param string $group
    "


    Ich weiß allerdings nicht, wo hier der Fehler liegt oder was fehlt.
    Im Backend führte ich eine Datenbankbereingung erfolgreich durch und prüfte auch mal im Erweiterungsmanager über die Sucher nach "Felder" ob es dort noch etwas zu aktualisieren oder installieren gab, aber die Liste war leer.

    'Ne Idee, was ich in diesem Fall tun kann?

    Die Installation erfolgte im Übrigen über das Kopieren der Dateien via FTP, weil das Update über Joomla diesmal den Fehler hatte, dass man immer die Meldung erhielt, dass man nicht angemeldet sei, was wohl auch ein bekannter Fehler ist.
    Daher umging ich die Installation über Joomla direkt, indem ich das manuelle Kopieren über FTP vornahm.
    Geändert von Niclas (27.04.2018 um 22:00 Uhr) Grund: Frage wurde gelöst

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.343
    Bedankte sich
    146
    Erhielt 2.091 Danksagungen
    in 1.861 Beiträgen

    Standard

    "was wohl auch ein bekannter Fehler ist."
    Mir ist dieser Fehler ehrlich gesagt gänzlich unbekannt. Noch dazu bei 3.8.6 auf 3.8.7. Wo hast du das her?

    Auf den ersten Blick klingt das nach einem Übertragungsfehler bei der FTP-Kopiererei (oder gelegentlich auch mal einem Hack).

    Bügel das 3.8.7-FULL(!)-Paket noch mal drüber und achte auf evtl. angezeigte Übertragungsfehler im FTP-Client. Kennst du: Anschließend "DB reparieren".

    Welche PHP-Version denn? PHP 5 gibt es ja viele. 5.6 sollte es schon sein.

    Ggf. hilft auch alle Felder-Erweiterungen in der Erweiterungs-Verwaltung zu deaktivieren (falls du sie gar nicht verwendest).
    Joomlafachmann: https://www.ghsvs.de

  3. Erhielt Danksagungen von:


  4. #3
    Kommt häufiger vorbei
    Registriert seit
    03.04.2005
    Beiträge
    261
    Bedankte sich
    26
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Die PHP-Version wollte ich eigentlich ursprünglich dazuschreiben.
    => PHP 5.4.45-0+deb7u13

    Bei meiner Suche nach der Problematik, dass nach einem Update die Meldung kommt, dass man nicht eingeloggt sei, fand ich zahlreiche Seiten (siehe hier: https://bit.ly/2HVY3Tm - auch in Zusammenhang mit Joomla 3.8). Die Lösung war wie gesagt die manuelle Installation der Update-Dateien, die in meinem Fall aber eben hierzu führte.
    Ich werde es nochmal mit dem kompletten Paket versuchen. Verzeichnis- und Datenbankbackup habe ich im Zweifelsfall ja.

  5. #4
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    52
    Beiträge
    16.960
    Bedankte sich
    625
    Erhielt 4.360 Danksagungen
    in 4.150 Beiträgen

    Standard

    Du benötigst aber vorher doch erst einmal die korrekte PHP Version - min 5.6 - besser 7.1/7.2

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  6. #5
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.422
    Bedankte sich
    200
    Erhielt 1.063 Danksagungen
    in 1.031 Beiträgen

    Standard

    Beherzige den Tipp mit "PHP 5.6 sollte es schon sein"! Zumindest das sollte bei deinem Provider doch möglich sein.

    Edit: Na.... nun hast du ihn dreifach, den Tipp.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  7. #6
    Kommt häufiger vorbei
    Registriert seit
    03.04.2005
    Beiträge
    261
    Bedankte sich
    26
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Ja, ich weiß. Aber bisher konnte ich ihn nicht davon überzeugen. Weiß auch nicht was da los ist. Einiges geht eben nicht mehr mit dieser Version und vom Thema Sicherheit will ich gar nicht erst anfangen. Naja, ich schaue mal, dass ich ihn die Tage nochmal anschreibe und bis dahin versuche, die Installation wieder irgendwie zum Laufen zu bekommen.

  8. #7
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.343
    Bedankte sich
    146
    Erhielt 2.091 Danksagungen
    in 1.861 Beiträgen

    Standard

    An den Meldungen gibts ja erst mal nix zu deuteln:
    "Unterminated comment "
    "unexpected end of file "

    Fällt mir noch ein. Häufiger Ursache für zerstümmelte Dateien:
    Bei einem Hoster, der 5.4 anbietet, kann das schon vorkommen, dass er auch beim FTP bei der Anzahl der möglichen gleichzeitigen Übertragungen spart (ggf. runtersetzen im FTP-Client).
    Joomlafachmann: https://www.ghsvs.de

  9. Erhielt Danksagungen von:


  10. #8
    Kommt häufiger vorbei
    Registriert seit
    03.04.2005
    Beiträge
    261
    Bedankte sich
    26
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Danke, Re:Later, das war die Lösung!
    Ich zog mir von Joomlaos.de einfach das Updatepackage und lud es nochmal hoch, wobei ich die bestehenden Dateien überschrieb und jetzt geht's wieder. ^^

  11. #9
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.343
    Bedankte sich
    146
    Erhielt 2.091 Danksagungen
    in 1.861 Beiträgen

    Standard

    Joomlaos.de sollte man aus Sicherheitsgründen nie was runterladen.

    Nimm zukünftig
    https://www.joomla.org/

    oder für ältere Pakete:
    https://github.com/joomla/joomla-cms/releases
    (Stable-Pakete)
    Joomlafachmann: https://www.ghsvs.de

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein