+ Antworten
Ergebnis 1 bis 10 von 10

Thema: Fehlermeldung beim Import der Datenbank auf den Server

  1. #1
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Fehlermeldung beim Import der Datenbank auf den Server

    Hallo,

    ich habe gerade versucht, von meiner lokalen Installation von Joomla 3.8.3 die Datenbank ins phpMyAdmin meines Providers zu importieren (ich habe dazu eine Anleitung benutzt, die ich bei Chip gefunden habe: http://praxistipps.chip.de/joomla-um...er-umzug_50888). Nach dem Exportieren der Datenbank habe ich diese lokal abgespeichert. Ich konnte den Export allerdings nicht genau nach der Anleitung machen, weil bei meinem lokalen phpMyAdmin kein Reiter "Navigieren" vorhanden ist. Ich habe statt dessen auf "Export" geklickt, die Datenbank (Name: Joomla) ausgewählt und dann alle Tabellen in der Datenbank selektiert. Dann habe ich auf "Export" geklickt und die Einstellung "SQL" übernommen, wie es in der Anleitung heißt. Dann habe ich auf "OK" geklickt und "Speichern" ausgewählt. Die Datenbank wurde ohne Dateinamen lediglich mit der Endung .sql im /tmp-Verzeichnis abgespeichert (ich verwende Ubunutu 16.04). Von da habe ich sie in mein /home-Verzeichnis verschoben, und als ich sie wieder importieren wollte, kam folgende Fehlermeldung:

    Code:
    Error
    
    There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem
    
    ERROR: Unknown Punctuation String @ 15
    STR: ><
    SQL: <!DOCTYPE HTML><html lang='de' dir='ltr' class='firefox firefox57'><head><meta charset="utf-8" /><meta name="robots" content="noindex,nofollow" /><meta ***********="X-UA-Compatible" content="IE=Edge"><style id="cfs-style">html{display: none;
    
    
    SQL query:
    
    <!DOCTYPE HTML><html lang='de' dir='ltr' class='firefox firefox57'><head><meta charset="utf-8" /><meta name="robots" content="noindex,nofollow" /><meta ***********="X-UA-Compatible" content="IE=Edge"><style id="cfs-style">html{display: none;
    
    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '<!DOCTYPE HTML><html lang='de' dir='ltr' class='firefox firefox57'><head><meta c' at line 1
    Weiß da jemand Rat? Ich mache das zum ersten Mal und komme allein nicht weiter. Ach ja, mein Provider verwendet nicht MySQL, sondern MariaDB.

    Vielen Dank,

    Claus.

    P.S.: Ich lese da am Schluß

    '#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use'. Soll ich da meinen Provider kontaktieren?

    P.P.S.: So, ich habe mit dem englischsprachigen Support meines Providers One.com gechattet und erfahren, dass ich Joomla! zuerst auf meinem Webspace installieren muss, bevor ich die Datenbank importiere. Ich hoffe, das Problem ist damit gelöst.
    Geändert von claus_01 (14.01.2018 um 15:56 Uhr)

  2. #2
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.954
    Bedankte sich
    134
    Erhielt 1.925 Danksagungen
    in 1.717 Beiträgen

    Standard

    Derf von dir gezeigte Ausschnitt der SQL ist mit Sicherheit nicht richtig, wenn bereits in Zeile 1 ein HTML-Gerüst angemahnt wird (, was da so in einer SQL-Datei nichts zu suchen hat.). Irgendeinen Fehler beim Export gemacht.

    Im Normalfall geht man nur in die Datenbank, dort, wo im rechten Fenster die Tabellen angezeigt werden und klickt oben auf den Reiter(!!!) Exportieren. Häkchen macht man da keine vor die Tabellen bzw. macht die Sache nur unhandlich je nach phpMyAdmin-Einstellungen und -Version.

    Dort (im Reiter Exportieren) hat man dann Möglichkeiten für Einstellungen des Exports. In Bezug auf deinen anderen Thread sollte das sein SQL, Struktur und Daten, DROP TABLE, CREATE TABLE, IF EXISTS, Ausgabe: Datei speichern (UTF-8, .

    Zippe deine Exportdatei und hänge sie deinem nächsten Post an. Kann man mal schauen, ob man damit überhaupt was anfangen kann oder versuche einen erneuten Export.
    Geändert von Re:Later (14.01.2018 um 07:14 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  3. #3
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von Re:Later Beitrag anzeigen
    Zippe deine Exportdatei und hänge sie deinem nächsten Post an. Kann man mal schauen, ob man damit überhaupt was anfangen kann oder versuche einen erneuten Export.
    Hallo,

    anbei die gezippte Datei.

    Claus
    Angehängte Dateien

  4. #4
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.954
    Bedankte sich
    134
    Erhielt 1.925 Danksagungen
    in 1.717 Beiträgen

    Standard

    Was du da gespeichert hast, ist eine HTML-Seite für Browser-Anzeige, nicht die SQL-Exportdatei. Es ist also was schief gelaufen beim Export.

    Leider ist die Datei unbrauchbar. Es sind keine verwertbaren Datenbank-Daten enthalten.
    Joomlafachmann: https://www.ghsvs.de

  5. #5
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von Re:Later Beitrag anzeigen
    Was du da gespeichert hast, ist eine HTML-Seite für Browser-Anzeige, nicht die SQL-Exportdatei. Es ist also was schief gelaufen beim Export.

    Leider ist die Datei unbrauchbar. Es sind keine verwertbaren Datenbank-Daten enthalten.
    Ich habe die Datenbank nochmal exportiert und dabei die Tabellen nicht ausgewählt, und das Ergebnis sieht deutlich besser aus (siehe Anhang).

    Claus
    Angehängte Dateien

  6. #6
    Gehört zum Inventar
    Registriert seit
    06.03.2013
    Ort
    /dev/random
    Beiträge
    6.060
    Bedankte sich
    130
    Erhielt 2.257 Danksagungen
    in 2.127 Beiträgen

    Standard

    Die angehängten sind SQL-Statements, die du in die Datenbank importieren kannst.
    Gruß FINWICK
    ↶ Danke Button nutzen, wenn es geholfen hat - Kein Suport via PN

  7. #7
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.954
    Bedankte sich
    134
    Erhielt 1.925 Danksagungen
    in 1.717 Beiträgen

    Standard

    Ja, sieht besser aus. Der export enthält allerdings ein paar störende Einträge, die später viel Arbeit machen werden. Aber trotzdem mal aufheben. Schadet nicht.

    - Erst in die Datenbank joomla gehen, die du ja als einzige exportieren willst. Also NICHT in der Übersicht bleiben mit allen Datenbanken im rechten Teilfenster.
    - Dann siehst du im rechten Teilfenster die TABELLEN der Datenbank joomla.

    - Jetzt wirst du feststellen, dass es da viele verschiedene Tabellenprefixe gibt und dadurch Unmengen an unnötigen Datenbanktabellen, was auch bei Import wieder Stress machen kann..
    Ich finde da (hab dann aufgehört weiterzusuchen):
    bak_hnd6y_
    bak_kl8p3_
    bak_xlta0_
    e9deo_
    hnd6y_
    kl8p3_

    - Jetzt hast du 2 Möglichkeiten vor dem Export.

    - - Entweder löscht du alle Tabellen mit falschem Prefix (also die, die nicht zum Joomla gehören), bevor du in den Tabulator Exportieren wechselst.

    - - Oder (sicherer) du klickst OBEN den Reiter "Exportieren" (NICHT unterhalb der Tabellen),
    wählst dann die Option "Angepasst – zeige alle möglichen Optionen an" und
    wählst dann nur die Tabellen im Auswahlfeld "Tabellen" zum Exportieren an, die den richtigen Prefix haben.

    - Weitere Einstellungen, falls nötig, siehe meinen oberen Post.
    Geändert von Re:Later (14.01.2018 um 10:55 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  8. Erhielt Danksagungen von:


  9. #8
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von Re:Later Beitrag anzeigen
    Ja, sieht besser aus. [ ... ] - - Oder (sicherer) du klickst OBEN den Reiter "Exportieren" (NICHT unterhalb der Tabellen),
    wählst dann die Option "Angepasst – zeige alle möglichen Optionen an" und
    wählst dann nur die Tabellen im Auswahlfeld "Tabellen" zum Exportieren an, die den richtigen Prefix haben.

    - Weitere Einstellungen, falls nötig, siehe meinen oberen Post.
    Ok, vielen Dank! Ich werde es mal so versuchen, wie Du vorgeschlagen hast.

    Claus

  10. #9
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo nochmal,

    ich bin jetzt so vorgegangen, wie Du vorgeschlagen hast und habe nur die Tabellen mit dem richtigen Prefix exportiert (siehen Anhang). Ist es so ok?

    Claus
    Angehängte Dateien

  11. #10
    Neu an Board
    Registriert seit
    06.01.2018
    Beiträge
    13
    Bedankte sich
    2
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard P. S.

    Ich habe die Datenbank erfolgreich importieren können. Darüber hinaus habe ich Joomla! erfolgreich auf meiner Site installiert, nachdem ich die 'configuration.php' entsprechend angepaßt habe.

    Claus
    Geändert von claus_01 (14.01.2018 um 16:01 Uhr)

+ Antworten

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein