+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 29

Thema: Error displaying the error page: Application Instantiation Error: Could not connect t

  1. #1
    War schon öfter hier
    Registriert seit
    02.08.2007
    Beiträge
    107
    Bedankte sich
    14
    Erhielt 3 Danksagung
    in 1 Beitrag

    Standard Error displaying the error page: Application Instantiation Error: Could not connect t

    Hallo zusammen,
    ich werde noch wahnsinnig und sehe den Wald vor lauter Bäumen nicht mehr.
    Ich wollte mit meiner Seite umziehen und nun bekomme ich immer den Fehler

    Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.

    Ich bekomme die Datei einfach nicht angepasst und finde den Fehler nicht.
    Joomla 3.8.1

    <?php
    class JConfig {
    public $offline = '0';
    public $offline_message = 'INSTL_STD_OFFLINE_MSG';
    public $display_offline_message = '1';
    public $offline_image = '';
    public $sitename = 'animotel';
    public $editor = 'jce';
    public $captcha = '0';
    public $list_limit = '20';
    public $access = '1';
    public $debug = '0';
    public $debug_lang = '0';
    public $dbtype = 'mysql';
    public $host = 'db570819935.db.1and1.com';
    public $user = 'dbo570819935';
    public $password = 'XXXXXXX';
    public $db = 'db570819935';
    public $dbprefix = 'j17_';
    public $live_site = '';
    public $secret = 'YEWXUYosueLTt2R0';
    public $gzip = '0';
    public $error_reporting = 'default';
    public $helpurl = 'http://help.joomla.org/proxy/index.php?option=com_help&keyref=Help16:{keyref}';
    public $ftp_host = '127.0.0.1';
    public $ftp_port = '21';
    public $ftp_user = '';
    public $ftp_pass = '';
    public $ftp_root = '';
    public $ftp_enable = '0';
    public $offset = 'UTC';
    public $offset_user = 'UTC';
    public $mailer = 'mail';
    public $mailfrom = 'info@animotel.de';
    public $fromname = 'animotel';
    public $sendmail = '/usr/sbin/sendmail';
    public $smtpauth = '0';
    public $smtpuser = '';
    public $smtppass = '';
    public $smtphost = 'localhost';
    public $smtpsecure = 'none';
    public $smtpport = '25';
    public $caching = '0';
    public $cache_handler = 'file';
    public $cachetime = '15';
    public $MetaDesc = 'Joomla! - dynamische Portal-Engine und Content-Management-System';
    public $MetaKeys = 'joomla, Joomla';
    public $MetaTitle = '1';
    public $MetaAuthor = '1';
    public $robots = '';
    public $sef = '1';
    public $sef_rewrite = '0';
    public $sef_suffix = '0';
    public $unicodeslugs = '0';
    public $feed_limit = '10';
    public $log_path = '/kunden/homepages/10/d71348971/htdocs/';
    public $tmp_path = '/kunden/homepages/10/d71348971/htdocs/';
    public $lifetime = '15';
    public $session_handler = 'database';
    public $MetaRights = '';
    public $sitename_pagetitles = '0';
    public $force_ssl = '0';
    public $feed_email = 'author';
    public $cookie_domain = '';
    public $cookie_path = '';
    }

    Kann mir jemand helfen und sieht den Fehler?

  2. #2
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.365
    Bedankte sich
    118
    Erhielt 1.855 Danksagungen
    in 1.459 Beiträgen

  3. #3
    Wohnt hier Avatar von Ellwood
    Registriert seit
    03.08.2011
    Ort
    Region Hannover
    Beiträge
    2.595
    Bedankte sich
    130
    Erhielt 606 Danksagungen
    in 589 Beiträgen

    Standard

    DB-Typ auf mysqli stellen?

    Und die Pfade \tmp und \logs nochmal überprüfen
    Bin auch hier: http://forum.joomla.de

  4. #4
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.156
    Bedankte sich
    414
    Erhielt 1.832 Danksagungen
    in 1.742 Beiträgen

    Standard

    Hallo,

    ob jetzt hier die Pfade stimmen, weiß ich nicht. Es fehlen (obige configuration.php) am Ende das: /logs; bzw. /tmp;

    public $log_path = '/kunden/homepages/10/d71348971/htdocs/'logs;
    public $tmp_path = '/kunden/homepages/10/d71348971/htdocs/'tmp;

    Liebe Grüße, Christine
    Geändert von christine2 (29.12.2017 um 10:27 Uhr)

  5. #5
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.365
    Bedankte sich
    118
    Erhielt 1.855 Danksagungen
    in 1.459 Beiträgen

    Standard

    Falsche Pfade verursachen keinen Fehler beim Datenbankzugang, aber sollten natürlich trotzdem korrekt sein.

    Dies muss korrgiert werden mit den Angaben die zu Deinen Account bei Deinem Provider passen. Frag ihn mal. Es sollte ja Support geben.

    public $dbtype = 'mysql';
    public $host = 'db570819935.db.1and1.com';
    public $user = 'dbo570819935';
    public $password = 'XXXXXXX';
    public $db = 'db570819935';
    public $dbprefix = 'j17_';

  6. #6
    War schon öfter hier
    Registriert seit
    02.08.2007
    Beiträge
    107
    Bedankte sich
    14
    Erhielt 3 Danksagung
    in 1 Beitrag

    Standard

    Super lieb das ihr mir helft.
    Jetzt habe ich diese Fehlermeldung:
    Error displaying the error page: Application Instantiation Error: syntax error, unexpected 'public' (T_PUBLIC), expecting end of file

  7. #7
    kdh
    kdh ist offline
    Neu an Board
    Registriert seit
    06.02.2013
    Ort
    Nähe Stuttgart
    Beiträge
    25
    Bedankte sich
    3
    Erhielt 6 Danksagungen
    in 6 Beiträgen

    Standard

    Kann es sein, dass du die Angaben von christine2 übernommen hast? Dort ist das abschließende Hochkomma an der falschen Stelle.

    Code:
    public $log_path = '/kunden/homepages/10/d71348971/htdocs/'logs;
    public $tmp_path = '/kunden/homepages/10/d71348971/htdocs/'tmp;
    Richtig ist:

    Code:
    public $log_path = '/kunden/homepages/10/d71348971/htdocs/logs';
    public $tmp_path = '/kunden/homepages/10/d71348971/htdocs/tmp';

  8. #8
    Gehört zum Inventar
    Registriert seit
    06.03.2013
    Ort
    /dev/random
    Beiträge
    6.061
    Bedankte sich
    130
    Erhielt 2.257 Danksagungen
    in 2.127 Beiträgen

    Standard

    Mit welchen Editor hast du die Datei bearbeitet?
    Gruß FINWICK
    ↶ Danke Button nutzen, wenn es geholfen hat - Kein Suport via PN

  9. #9
    War schon öfter hier
    Registriert seit
    02.08.2007
    Beiträge
    107
    Bedankte sich
    14
    Erhielt 3 Danksagung
    in 1 Beitrag

    Standard

    Oh ja das habe ich gemacht. Ich ändere das noch mal...
    Dankeschön

  10. #10
    War schon öfter hier
    Registriert seit
    02.08.2007
    Beiträge
    107
    Bedankte sich
    14
    Erhielt 3 Danksagung
    in 1 Beitrag

    Standard

    Ich glaube ich mache es nur noch schlimmer...
    Fatal error: Multiple access type modifiers are not allowed in /homepages/10/d71348971/htdocs/configuration.php on line 56

+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein