+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Nach Upgrade auf 3.7 Menu verschwunden

  1. #1
    Neu an Board
    Registriert seit
    25.01.2011
    Beiträge
    25
    Bedankte sich
    7
    1 Danksagung in 1 Beitrag

    Standard Nach Upgrade auf 3.7 Menu verschwunden

    hallo,
    nach Upgrade auf Joomla 3.7 ist eines von 2 menüs verschwunden. Die ehemaligen Menüeinträge tauchen plötzlich im Administratorbereich im Menü: Komponenten auf.
    Weiß jemand woran das liegen kann?
    danke und Grüße,
    Wolf.

  2. #2
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.304
    Bedankte sich
    114
    Erhielt 1.834 Danksagungen
    in 1.448 Beiträgen

    Standard

    Mit dem Menüs scheint in der Tat etwas nicht zu stimmen. Wir haben hier Fälle wo nach dem Update die Menüpunkte eines Menüs verschwinden und im Backend unter "Komponenten" wieder auftauchen. Dort in Großbuchstaben und natürlich ohne Funktion. Ich konnte das bei mehreren Joomla-Updates beobachten, aber aber noch nicht herausgefunden was die Ursache ist und wie man das vor oder nach dem Update bereinigen kann.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun?

  3. Erhielt Danksagungen von:


  4. #3
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.304
    Bedankte sich
    114
    Erhielt 1.834 Danksagungen
    in 1.448 Beiträgen

    Standard

    Ich habe mir das nun mal genauer angesehen. Wenn ein Menü existiert dessen Menütyp="menu" heisst, dann verschwinden nach dem Update ein Einträge und landen im Komponentenmenü im Backends.
    In der Tabelle #_menu sind im Feld "menutype" nach dem Update alle Einträge dieses Menüs auf "main" gesetzt worden (vorher "menu"). Auch die Menüeinträge des Komponentenmenüs heissen "main" (wie vor dem Update).

    --> Durch die Umbenennung des Inhalts im Feld "menutype" von "menu"->"main" landen die Menüeinträge nun unter dem Komponentenmenü.
    ==> Das scheint mir ein klarer Fehler der Updateroutine zu sein.

    Bin nun so nach dem Update vorgegangen:
    1) Menütyp des betroffenen Menüs umbenannt im Backend (von "menu" in etwas anderes wie z.B. "menuoben")
    2) In der Datenbank in Tabelle #_menu alle ehemaligen Einträge dieses Menüs gelöscht.
    3) Im Backend des Joomla die Menüpunkte neu eingerichtet
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun?

  5. Erhielt Danksagungen von:


  6. #4
    Neu an Board
    Registriert seit
    25.01.2011
    Beiträge
    25
    Bedankte sich
    7
    1 Danksagung in 1 Beitrag

    Standard

    ich hatte bei 10 Upgrades keinerlei Probleme, nur bei einer Website verschwand das Menu und die Einträge kamen als "Komponenten" wieder zum Vorschein. Betroffen war nicht das Hauptmenu, sondern ein eigenes Menü, das im Footer angezeigt wird.
    Ich hatte noch ein Backup vor dem Ugrade, habe dort das footer-menü deaktiviert, die Einträge ins Hauptmenü verschoben, danch ging das Upgrade wieder wie erwartet fehlerfrei.
    Gruß, wolf.

  7. #5
    Wohnt hier Avatar von Myrtus
    Registriert seit
    17.10.2008
    Ort
    Hessen
    Beiträge
    2.850
    Bedankte sich
    316
    Erhielt 745 Danksagungen
    in 656 Beiträgen

    Standard

    Hallo Uwe,
    vielen Dank für den Lösungsansatz. Ich hatte nämlich auch das Problem. Bin dann erst mal wieder zurück zur vorigen Version. Kann man denn den Menütyp voher ändern, damit das Durcheinander gar nicht erst entsteht? Alle Menüpunkte neu einrichten ist u.U. ein ziemlicher Aufwand. Aber immer noch besser als gar keine Lösung.

    @wolfmen
    Da haben wir wohl zeitgleich geschrieben. Werde deine Vorgehensweise mal testen und berichten.
    Geändert von Myrtus (28.04.2017 um 16:39 Uhr)
    -------- Gruß, Myrtus --------
    www.myrtus-communis.de

  8. #6
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.304
    Bedankte sich
    114
    Erhielt 1.834 Danksagungen
    in 1.448 Beiträgen

    Standard

    Aktuell konnte ich noch nicht prüfen, warum das Update den Menütyp auf "main" umbenannt hat. Ob es am alten Namen "menu" liegt oder andere Faktoren eine Rolle spielen, weiss ich nicht.

    Einen anderen Weg habe ich noch nicht geprüft. Wenn der Name "menu" der Grund ist sollte es klappen wenn man den Menütype VOR dem Update umbenennt.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun?

  9. Erhielt Danksagungen von:


  10. #7
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.304
    Bedankte sich
    114
    Erhielt 1.834 Danksagungen
    in 1.448 Beiträgen

    Standard

    Also ich habe es nun mal getestet und VOR dem Update den Menütyp von "menu" auf einen anderen Namen umgestellt.

    Ergebnis:
    Das Menü bleibt erhalten --> OK
    ABer leider zu früh gefreut. Nun sind im Komponentenmenü diverse andere Einträge verschwunden!
    Das Problem ist, das bei der Umbenennung des Menütyp auch diese Komponentenmenüeinträge umbenannt wurden.

    Mein Fazit zur Zeit:
    Erstgenannte Lösung scheint mir sinnvoller.
    Der Menütyp eines Menus darf einfach nicht "menu" heissen, weil dies auch bei den Komponentenmenüeinträgen so heisst.
    Für Joomla kleiner 3.7 war dieser Name allerdings nicht verboten und man konnte ihn nutzen - unabhängig davon das der Menütyp des Komponneteneinträge genauso heissen.

    Aus meiner Sicht daher noch immer ein Fehler beim Updater, der dies berücksichtigen müsste.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun?

  11. Erhielt Danksagungen von:


  12. #8
    Wohnt hier Avatar von Myrtus
    Registriert seit
    17.10.2008
    Ort
    Hessen
    Beiträge
    2.850
    Bedankte sich
    316
    Erhielt 745 Danksagungen
    in 656 Beiträgen

    Standard

    Das Verschieben der Menüpunkte ins Hauptmenü brachte bei mir keinen Erfolg. Nach dem Verschieben funktionierte das Aufklappen der Menüs nicht mehr. Ich werde also so vorgehen, wie in flottes Post #3 beschrieben.
    -------- Gruß, Myrtus --------
    www.myrtus-communis.de

  13. #9
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    6.304
    Bedankte sich
    114
    Erhielt 1.834 Danksagungen
    in 1.448 Beiträgen

    Standard

    Ich habe es jetzt bei mehreren Joomla getestet und funktioniert gemäß Post #3 ganz gut.
    Bei einem Joomla gab es aber den Effekt das die Standard-Komponenten-Menüeinträge verschwunden waren. Effekt wurde weiter oben auch mal beschrieben.
    Hier muss man dann nur die in der Datenbank #_menu die oberen Einträge (meist id 2 bis id 23 (kleiner 100)) das Feld "menütype" auf "main" setzen.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun?

  14. #10
    Neu an Board
    Registriert seit
    04.05.2010
    Ort
    Insel Usedom
    Beiträge
    21
    Bedankte sich
    4
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Vielen Dank für die Lösung!
    Ich hatte das Problem auch. Da das Menü aber sehr groß war, habe ich die Akeeba-Sicherung wieder installiert. Vor dem Update auf 3.7 habe ich jetzt das Menü umbenannt und alles ging gut. Jetzt passe ich bei den anderen Seiten auf, und sehe mir vorher die Menünamen (Aliase) an.

    Viele Grüße
    Manuel

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein