+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 20 von 20

Thema: Nach Upgrade auf 3.7 Menu verschwunden

  1. #11
    Wohnt hier Avatar von Myrtus
    Registriert seit
    17.10.2008
    Ort
    Hessen
    Beiträge
    2.850
    Bedankte sich
    316
    Erhielt 744 Danksagungen
    in 655 Beiträgen

    Standard

    Hallo,
    heute habe ich im BE ein Update für "Installer - Install from Web" angezeigt bekommen. Löst der vielleicht das Problem mit den Menüs? Bevor ich es selbst teste wollte ich mal nachfragen, ob es schon jemand ausprobiert hat.
    -------- Gruß, Myrtus --------
    www.myrtus-communis.de

  2. #12
    Gehört zum Inventar Avatar von j!-n
    Registriert seit
    26.07.2007
    Ort
    RZ / EA / B
    Beiträge
    7.325
    Bedankte sich
    420
    Erhielt 1.714 Danksagungen
    in 1.596 Beiträgen

    Standard

    Nö, das ist nur ein Installer-Plugin.
    Gruß, Chris
    Joomla kaputt? Gehackt? Migration mißlungen? Datensalat?
    www.joomla-notdienst.de - Soforthilfe & Webentwicklung
    Einsteiger- FAQ - bitte lesen!

  3. #13
    Wohnt hier Avatar von Myrtus
    Registriert seit
    17.10.2008
    Ort
    Hessen
    Beiträge
    2.850
    Bedankte sich
    316
    Erhielt 744 Danksagungen
    in 655 Beiträgen

    Standard

    So, habe heute bei meinen Seiten das Update gewagt. Nur bei einer Seite, wo es die Kollision mit dem Menütyp gab, musste ich nacharbeiten. Alles andere lief problemlos durch, und ich konnte bisher noch keine Fehler entdecken. Nochmals vielen Dank an alle Helfer, insbesondere Uwe.
    -------- Gruß, Myrtus --------
    www.myrtus-communis.de

  4. #14
    Neu an Board
    Registriert seit
    14.12.2009
    Beiträge
    98
    Bedankte sich
    46
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ich habe meine Seite auf 3.7 upgedatet. Die Kontakte kann ich über den Browserlink administrator/index.php?option=com_contact öffnen, das geht.

    Mir fehlt aber das Menü unter Komponenten oder sonst irgendwo im Backend, über die ich die Komponente Kontakte aufrufen kann.

    Ich habe bereits nochmal alle Dateien per FTP überschrieben und Datenbank überprüft und repariert ohne Erfolg.

  5. #15
    --- Avatar von anka
    Registriert seit
    01.05.2008
    Ort
    Basel
    Beiträge
    11.446
    Bedankte sich
    447
    Erhielt 4.306 Danksagungen
    in 3.961 Beiträgen

    Standard

    Vielleicht hilft das hier weiter.
    Gruss Anka

  6. #16
    Neu an Board Avatar von DerJohn
    Registriert seit
    13.05.2017
    Beiträge
    7
    Bedankte sich
    3
    1 Danksagung in 1 Beitrag

    Standard

    Bei 3.7 hatte ich auch Probleme, habe es dann wieder auf die vorherige Version zurückgesetzt, weil ich sowieso Joomla neuinstalliert hatte, weil ich mal versehentlich die Datenbank gelöscht habe und seit dem ständig Fehler beim Artikel speichern kamen.
    Vorerst bleibe ich mal bei meiner Version 3.6.4
    Vielleicht wird 3.8 besser oder bleiben die Menüs immer so? Wenn ja, muss ich in naher Zukunft mich drauf einstellen, die Menüs anzupassen für diese Änderung.
    Bei mir kamen bei 3.7 ständig Fehlermeldungen, wenn ich auf den Button Menüs geklickt habe.

  7. Erhielt Danksagungen von:


  8. #17
    Neu an Board
    Registriert seit
    12.09.2011
    Beiträge
    33
    Bedankte sich
    4
    1 Danksagung in 1 Beitrag

    Standard

    Hallo,

    ich habe eure Posts mit großem Interresse gelesen. Ich habe auch das Problem das nach der Umstellung bei mir Komponenten Menus verschwunden sind. es ist u.a. das Kontakt menu. dort sind einige
    Adressen eingetragen. Ich habe jetzt mal die Akeeba Sicherung auf meinen laptop gezogen und dort die Umstellung auf Joomla 3.7 unter XAmmp gemacht. eigenartigerweise hat es dort ohne Probleme geklappt.
    Alle Menupunkte sind vorhanden. Ein Unterschied ist mir eingefallen. Joomla unter XAMMP läuft mit der PHP 5.6.3 Version. Bei meinem Provider läuft Joomla mit PHP 5.6.29-nmm1
    kann das Damit zusammenhängen.
    Inzwischen bin ich wieder auf die Joomla Version 5.6.5 zurückgegangen und habe keine Idee für eine Lösung.

    Gruß
    wopi

  9. Erhielt Danksagungen von:


  10. #18
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.436
    Bedankte sich
    120
    Erhielt 1.749 Danksagungen
    in 1.551 Beiträgen

    Standard Workaround Menüs verschwunden bei Update Joomla 3.7

    Mein Workaround für verschwundene Menüs bei Update von 3.x auf 3.7: Aus dem Kopf.

    1)
    - Vor dem Update prüfe, ob sich unter Menüs > Verwalten Menütypen "menu" oder "main" befinden.
    Wenn ja, tue nichts im Backend.
    Wenn nein, hast du vermutlich ein anderes Problem.

    2)
    - Gehe in die Datenbank und in Tabelle #__menus:

    Bennene bei allen Einträgen mit
    client_id = 1 (gleichbedeutend mit Backend)
    in Spalte menutype in
    main
    um.

    - Prüfe dann die Einträge mit
    client_id = 0 (gleichbedeutend mit Frontend)

    Bennene alle Einträge mit
    main
    in der Spalte menutype z.B. um in
    mainfrontend
    .

    Bennene alle Einträge mit
    menu
    in der Spalte menutype z.B. um in
    menufrontend
    .

    - Gehe in die Tabelle #__menutypes

    Benenne menutype
    menu
    nach
    menufrontend
    um.

    Benenne menutype
    main
    nach
    mainfrontend
    um.

    3) Lade das FULL-Paket der Joomla 3.7 ohne Ordner /installation/ per FTP hoch ("drüberbügeln").

    4) Im Backend nichts machen und die URL
    index.php?option=com_installer&view=database
    aufrufen (also nach administrator/ in der Adresszeile einfügen).

    5) Klicke den Datenbank-Reparieren-Button.

    6) Wie immer:
    Klicke unter Menüs Wiederherstellen-Button.
    Prüfe unter Menüs > Verwalten, ob die Menütypen jetzt wie geändert angezeigt werden.
    Prüfe die Navigationsmodule, ob das richtige Menü eingetragen ist. Jetzt also menufrontend und/oder mainfrontend.
    Bzw. Einstellungen im Template, wo man ja oftmals auch ein Menü wöhlen kann.


    Das selbe Spiel ist mir auch bei einer halbfertigen Mischmasch-Joomla-3.7.1 gelungen.
    Hier war die Spalte client_id in Tabelle #__menutypes bereits vorhanden. Solange noch kein eigenes Backendmenü angelegt wurde (neues Feature seit 3.7) sollte client_id überall auf 0 stehen.


    Und mit der Anleitung habe ich mir wieder den einen oder anderen Job versaut ;-) ;-)
    Geändert von Re:Later (22.05.2017 um 12:06 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  11. Erhielt Danksagungen von:


  12. #19
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.436
    Bedankte sich
    120
    Erhielt 1.749 Danksagungen
    in 1.551 Beiträgen

    Standard

    Sorry! Ich hatte einen Fehler in der Beschreibung und habe gerade oben korrigiert
    client_id ist für Backend = 1
    für Frontend = 0
    Geändert von Re:Later (22.05.2017 um 12:05 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  13. #20
    Neu an Board
    Registriert seit
    14.12.2009
    Beiträge
    98
    Bedankte sich
    46
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo wopi,

    man kann ja eigene Menüeinträge seit der Version 3.7 im Backend neu anlegen, auch für die Komponente Kontakte. Aber ob das der Sinn sein soll, vielleicht wirklich eine gute Idee von Dir, auf eine ältere Version zurückzugehen...

    Die Kontakte sollte man ja direkt in Joomla bearbeiten können, ohne Umwege, und nicht indem man erst die Datenbank umfangreich bearbeiten muss.
    Vielen Dank für die Info.
    Geändert von Henny81Opel (23.05.2017 um 18:12 Uhr)

+ Antworten
Seite 2 von 2 ErsteErste 1 2

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein