+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 25

Thema: Blockierte Ressourcen durch...?

  1. #1
    War schon öfter hier
    Registriert seit
    15.12.2006
    Beiträge
    128
    Bedankte sich
    35
    Erhielt 4 Danksagungen
    in 4 Beiträgen

    Frage Blockierte Ressourcen durch...?

    Hallo,
    etwa seit der Verwendung von JCE (auch für Popups) häuft sich die Zahl der blockierten Ressourcen:
    www .MeineDomain .de/plugins/system/jcemediabox/js/jcemediabox.js?...
    www .MeineDomain .de/plugins/system/jcemediabox/css/jcemediabox.css?...
    www .MeineDomain .de/plugins/system/jcemediabox/.../style.css?…
    Jetzt verwende ich wieder TinyMCE "komplett". Leider habe ich dabei zwei Hindernisse, die ich kaum/nicht bewältige. Ich möchte weiter Popups (für PDF) verwenden:
    • Wähle ich Lightbox oder eine andere Darstellungsart, öffnet sich der Link wie jeder andere normale Link.
    • Ich muss den Pfad zum PDF immer über FTP suchen und händisch eintragen. Ich hab versucht PDF's über Bild einfügen einzubinden. Hat der Editor aber nicht genommen.

    Gibt es für beide Anliegen eine (bessere) Lösung.
    Evtl. könnte ich den JCE mit dieser Änderung weiter verwenden. Das traue ich mir aber mit meinem Halbwissen nicht zu. Außerdem hat mir JCE zusätzlich immer wieder die Darstellung der Überschriften durcheinandergehauen.

    Danke schon mal.
    Geändert von frieder (19.02.2017 um 15:26 Uhr)

  2. #2
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    644
    Bedankte sich
    50
    Erhielt 75 Danksagungen
    in 74 Beiträgen

    Standard

    Hallo,

    du brauchst doch nur in deiner "robots.txt" die angemahnten Ordner freigeben. Dann musst Du natürlich etwas warten und die blockierten Ressourcen werden wieder freigegeben.

    Nun sehe ich deine Pfade nicht genau, da es sich jedoch meistens um css und js Dateien handelt, würde es reichen den kompletten Ordner "/plugins/system/jcemediabox/" freizugeben.

    Würde dann so aussehen, wenn deine Domain ist: "www.MeineDomain.de/plugins/system/jcemediabox/css/jcemediabox.css?...

    Disallow: /plugins/
    Allow: /plugins/system/jcemediabox/

    Ist oben etwas Twicki beschrieben.
    Wie schon gesagt, ich kenne deine genauen Pfade nicht. Zumindest könntest Du somit wieder problemlos mit dem JCE weiterarbeiten.

    Gruß Faro
    Geändert von faro02 (01.11.2016 um 10:55 Uhr)
    Gruß Faro

  3. Erhielt Danksagungen von:


  4. #3
    War schon öfter hier
    Registriert seit
    15.12.2006
    Beiträge
    128
    Bedankte sich
    35
    Erhielt 4 Danksagungen
    in 4 Beiträgen

    Standard

    Danke für die Antwort. Die robot.txt habe ich später geändert. Sieht jetzt so aus:

    "User-Agent: * Disallow"

    Trotzdem kamen später weitere Einträge hinzu. Deshalb möchte ich einfach den JCE nicht mehr verwenden. Weil ich da nicht so durchblicke.

    Hier der Pfad ohne Link "http: // www . arbeitsvermittler . de/". Könnte in SEO negative Auswirkung haben?

  5. #4
    --- Avatar von anka
    Registriert seit
    01.05.2008
    Ort
    Basel
    Beiträge
    11.457
    Bedankte sich
    447
    Erhielt 4.311 Danksagungen
    in 3.966 Beiträgen

    Standard

    Zitat Zitat von frieder Beitrag anzeigen
    "User-Agent: * Disallow"
    So blockierst du alle Resourcen .

    Schau dir mal die robots.txt von hier an (im Spoiler). Damit kannst du den JCE weiterhin verwenden, ohne dass Google meckert.
    Gruss Anka

  6. Erhielt Danksagungen von:


  7. #5
    War schon öfter hier
    Registriert seit
    15.12.2006
    Beiträge
    128
    Bedankte sich
    35
    Erhielt 4 Danksagungen
    in 4 Beiträgen

    Standard

    Zitat Zitat von anka Beitrag anzeigen
    So blockierst du alle Resourcen .
    Die Unkenntnis der robots.txt ist ja mein Problem. Sinn und Zweck habe ich irgendwie verstanden. Es hapert an der Umsetzung. Und so wie die robots.txt jetzt aussieht, habe ich sie meines Wissens bei Google direkt in den (Webmaster-)Tools gefunden (Nachtrag: und falsch umgesetzt?).
    Vor drei Tagen habe ich etwa 20 Links berichtigt (gerendert). Damit ist die Zahl der blockierten Ressourcen um diese Zahl zurückgegangen?
    Deshalb überlege ich mir noch, ob ich eine Änderung vornehmen soll. Ich hoffe noch darauf, dass ich für meine Popup- und Link-Problem im TinyMCE eine Lösung bekomme.
    Danke.

    Hier hab ichs gefunden: https://webmaster-de.googleblog.com/...-wenn-ich.html
    Geändert von frieder (01.11.2016 um 13:04 Uhr)

  8. #6
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    644
    Bedankte sich
    50
    Erhielt 75 Danksagungen
    in 74 Beiträgen

    Standard

    Zitat Zitat von anka Beitrag anzeigen
    So blockierst du alle Resourcen .

    Schau dir mal die robots.txt von hier an (im Spoiler). Damit kannst du den JCE weiterhin verwenden, ohne dass Google meckert.

    Natürlich werden erst einmal alle Plugins im Ordner geblockt. Mit der zweiten Regel wird nur dieses eine Plugin freigegeben.

    Disallow: /plugins/
    Allow: /plugins/system/jcemediabox/

    @anka, die "robots.txt" im Spoiler ist schon Richtig. Jedoch wenn der TE NUR den JCE freigeben möchte, reicht der Eintrag von oben.

    Und: "# Disallow: /media/". Würde ich nicht machen. Denn, nicht jeder Crawler kann ein "#" richtig deuten. Einfacher und sicherer wäre, einfach weglassen.

    Edit: Ich Persönlich würde diese Zeilen:

    Allow: /**/*.css?*$
    Allow: /**/*.js?*$
    Allow: /**/*.css$
    Allow: /**/*.js$

    nie in meine "robot.txt legen.

    und weggeduckt.

    Gruß Faro
    Geändert von faro02 (02.11.2016 um 12:47 Uhr)
    Gruß Faro

  9. Erhielt Danksagungen von:


  10. #7
    War schon öfter hier
    Registriert seit
    15.12.2006
    Beiträge
    128
    Bedankte sich
    35
    Erhielt 4 Danksagungen
    in 4 Beiträgen

    Standard

    Etwa am 01.11.2016 (leider nicht notiert) oder kurz danach habe ich die robots.txt-Datei komplett geleert. Also nur noch leere robots.txt im Verzeichnis. Somit dürfte nichts blockiert werden(?). Die blockierten Ressourcen sind allerdings von 520 auf 930 gestiegen (Stand: 12.11.2016 - heute am 18.11.2016 erstmals in SearchConsole angezeigt).

    Gehe ich die ganzen Ressourcen/Links durch, steht unter "zuletzt erkannt" aber das Datum 21.10.2016 oder älter. Also kein Datum zwischen dem 01.11.-12.11.2016. Weiterhin erscheint als Linkadresse:
    http://www.meinehomepage.de>/plugins/system/jcemediabox/js/jcemediabox.js?2ee2100a9127451a41de5a4c2c62e127, obwohl ich alle Plugins etc. des JCE deaktiviert habe. Nur "Schnellstartsymbol - JCE-Datei-Browser" ist noch aktiv.

    Da ich das Ganze ja nicht wirklich verstehe, werde ich einen SEO-Anbieter mit der Behebung beauftragen. Vorher hätte ich aber noch folgende Verständnisfragen:
    • Wenn die robots.txt leer ist, dürfte doch nichts blockiert werden?
    • Ich habe alle jce-Plugins deaktiviert, warum spielt jce trotzdem noch eine Rolle? Weil ich einige Artikel damit erstellt habe? Müsste ich JCE deshalb eher wieder aktivieren, damit die Beiträge darauf zurückgreifen können?
    • Müssten die Blockierungen nicht aufgehoben und die Seiten wieder erkannt worden sein, weil ich ja am 01.11. die robots.txt geleert habe?
    • Kann das Blockieren irgendwo außerhalb meiner Homepage liegen? Also am Hoster?

    Für eine Antwort wäre ich dankbar.
    Geändert von frieder (18.11.2016 um 13:11 Uhr)

  11. #8
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.500
    Bedankte sich
    122
    Erhielt 1.768 Danksagungen
    in 1.568 Beiträgen

    Standard

    1) Bist zu ungeduldig. Die blockierten Ressourcen sind doch auch eigentlich nur Hinweise auf nicht ideal. Die Rest-Seite wird trotzdem indexiert. Es dauert in Webmastertools bis zu Monate bis die bR nach und nach alle verschwunden sind. Das gilt für die meisten Bereiche. Also auch immer mal einen Blick aufs Datum. Deshalb bleibt der JCE-Kram viel länger zu sehen, selbst, wenn gar nicht mehr verwendet auf der Seite und selbst, wenn die Seite gar nicht mehr existiert.

    BLOCKIERT WIRD NICHT DIE SEITE, SONDERN LEDIGLICH 1 CSS-Datei darin!!

    2) Ja, kein robots.txt, dann auch keine Blockierung. Führt aber ggf. dazu, dass auch "blöde Seiten" unter den Suchseiten erscheinen, was einem meist schlechter gefällt als der bR-Kram in Webmastertools einen stören sollte.

    3) "Die blockierten Ressourcen sind allerdings von 520 auf 930 gestiegen". Cool bleiben! Google braucht Zeit! Mir erzählt Google seit 2 Tagen eine Seite wäre blockiert durch robots.txt (mein Fehler). Repariert habe ich das vorgestern. Im Robots.txt-Tester wird mir bestätigt, dass die Seite nicht mehr blockiert ist. Nervt, aber sind halt die Realitäten im Hause Google. Beim Einreichen einer Sitemap selbe Warnung. Das sind verschiedene Systeme, die nicht aktuell synchron laufen.

    4) "Müsste ich JCE deshalb eher wieder aktivieren, damit die Beiträge darauf zurückgreifen können?" KEINESFALLS SOLLTEST DU JCE DEEEEAKTIVIEREN, wenn dir JCE gefällt. Wäre ja jetzt noch schöner, dass Leute wegen so Google-Panik anfangen, ihr Arbeitswerkzeug wegzuschmeißen... ;-)

    5) Check, ob Ressourcen tatsächlich noch blockiert werden.

    5 a) robots.txt wieder einrichten. Hier eine Version, die ich heute wegen einer "blöden Aktion" (bin mal nett zu mir selbst) ausgiebig getestet habe und die ich mit Faros Hinweisen (seh ich genauso mit den komischen Sternechen, die auch oft gar nicht wie erwartet funktionieren) für dein Problem gedingst und mit deinen Links noch mal getestet habe (als Strafarbeit quasi).

    Code:
    User-agent: *
    Disallow: /administrator/
    Disallow: /cache/
    Disallow: /cli/
    Disallow: /components/
    Disallow: /includes/
    Disallow: /installation/
    Disallow: /language/
    Disallow: /libraries/
    Disallow: /logs/
    Disallow: /modules/
    Disallow: /plugins/
    Disallow: /tmp/
    
    Allow: /plugins/system/jcemediabox/
    5 b) Webmastertools > Verwaltung der Domain > links den Robots.txt-Tester > Im Feld siehst die Irgendwann-Version deiner robots.txt > Kopierst in das Feld deine aktuelle Version rein > Unten hast ein Feld zum Testen. Da fügst deine angemahnten Links rein. > Klickst Testen-Button > Siehst, ob Zugelassen oder Blockiert.
    Du kannst dann im Feld Zeilen korrigieren oder hinzufügen, um erneut zu testen.

    5 c) Wenn alles gut ist, Senden-Button klicken. Aber vorher nicht vergessen, dass falls du beim Testen noch was ändern musstest auch die robots.txt deiner Domain entsprechend änderst.

    "werde ich einen SEO-Anbieter mit der Behebung beauftragen"
    Würde ich dafür nicht machen.
    Geändert von Re:Later (18.11.2016 um 13:59 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  12. Erhielt Danksagungen von:


  13. #9
    War schon öfter hier
    Registriert seit
    15.12.2006
    Beiträge
    128
    Bedankte sich
    35
    Erhielt 4 Danksagungen
    in 4 Beiträgen

    Standard

    Die robots.txt habe ich entsprechend geändert.

    Ein paar Dinge wurden mir klar. Andere wieder nicht:
    • Obwohl viele blockierte Seiten ausgeworfen werden, hat sich die Zahl der indexierten Seiten (lt. SearchConsole 2443 - Suche über Suchmaschine ergibt mehr) nicht verringert. Verstehe ich jetzt.
    • Beim Test bin ich immer über den Weg >blockierte Ressourcen > blockierte Seite >robots.txt-Tester gegangen. Als ich die ersten Fehler gesehen und die Zeile in robots gelöscht habe zeigten die anderen Seiten keine Fehler an. Dies bedeutet, dass der googlebot die Seite vermutlich wieder aufgenommen, aber nicht sofort aus der Liste gestrichen hat. War mir nicht klar.

    Bei dieser Einstellung der robots.txt muss ich jetzt allerdings einiges dazulernen. Wenn ich ein neues Plugin installiere oder aktiviere, ist ja der Pfad diese Plugins einzutragen. Die Pfadlogik habe ich jetzt zumindest schon mal gefunden.
    Ich werde mich jetzt doch irgendwo (Youtube usw.) über die robots.txt schlauer machen und vermutlich muss ich geduldiger werden! Danke.
    Geändert von frieder (19.11.2016 um 09:36 Uhr)

  14. #10
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    644
    Bedankte sich
    50
    Erhielt 75 Danksagungen
    in 74 Beiträgen

    Standard

    "Bei dieser Einstellung der robots.txt muss ich jetzt allerdings einiges dazulernen. Wenn ich ein neues Plugin installiere oder aktiviere, ist ja der Pfad diese Plugins einzutragen."

    Ja, es ist Mühselig, aber die sicherste Methode. Nochmal kurz zu dieser Lösung:

    Allow: /**/*.css?*$
    Allow: /**/*.js?*$
    Allow: /**/*.css$
    Allow: /**/*.js$

    Sie mag ja für Google funktionieren. Aber, es muss der gesamte Plugin Ordner nach css oder js durchsucht werden, um die css oder js Datei zu finden. Das möchtest Du jedoch nicht, weil Du ja "Disallow: /plugins/" gestzt hast.

    Somit bist Du wie schon erwähnt und auch von @Re:Later empfohlen bei deiser Regel hier am Besten aufgehoben:

    Disallow: /plugins/
    Allow: /plugins/system/jcemediabox/

    Und glaube mir, es funktioniert.

    Edit: Gut programmierte Extensions lagern ihre css und js Dateien eh im /media/ Ordner aus. Da dieser von Haus aus freigegeben ist, sind somit auch keinerlei Probleme zu erwarten.

    Gruß Faro
    Geändert von faro02 (19.11.2016 um 11:10 Uhr)
    Gruß Faro

  15. Erhielt Danksagungen von:


+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein