+ Antworten
Ergebnis 1 bis 5 von 5

Thema: Suche Button funktioniert nicht.

  1. #1
    Neu an Board Avatar von getnuts
    Registriert seit
    02.03.2011
    Beiträge
    24
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Daumen hoch Suche Button funktioniert nicht.

    Hallo Freunde,

    vielleicht könnt ihr mir weiter helfen.

    Auf dieser Seite www.ilka-chemie.berlin funktioniert leider der Suche Button/Schaltfläche nicht! Ich verwende die einfache Suche nicht die Index Suche. Wenn ich die Suche mit Enter starte funktioniert alles wie es soll.

    Habt ihr vielleicht eine Idee?

    Gruß Nuts
    Geändert von getnuts (13.03.2018 um 13:42 Uhr)

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.795
    Bedankte sich
    156
    Erhielt 2.254 Danksagungen
    in 2.021 Beiträgen

    Standard

    Im Moment sieht der Button so aus

    Code:
    <input class=" btn-primary" onclick="this.form.searchword.focus();" value="Suchen" type="button">
    Ändern in
    Code:
    <input class=" btn-primary" onclick="this.form.searchword.focus();" value="Suchen" type="submit">
    Joomlafachmann: https://www.ghsvs.de

  3. Erhielt Danksagungen von:


  4. #3
    Neu an Board Avatar von getnuts
    Registriert seit
    02.03.2011
    Beiträge
    24
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Würde ich gerne machen aber ich finde das einfach nicht. Gibts du mir ein Tipp wo ich suchen muss?

  5. #4
    Gehört zum Inventar
    Registriert seit
    06.03.2013
    Ort
    /dev/random
    Beiträge
    6.283
    Bedankte sich
    143
    Erhielt 2.364 Danksagungen
    in 2.223 Beiträgen

    Standard

    Erstelle ein Override des Moduls, falls noch nicht vorhanden unter dem Template, dann kannst du es ändern.
    Gruß FINWICK
    ↶ Danke Button nutzen, wenn es geholfen hat - Kein Suport via PN

  6. Erhielt Danksagungen von:


  7. #5
    Neu an Board Avatar von getnuts
    Registriert seit
    02.03.2011
    Beiträge
    24
    Bedankte sich
    5
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ich hab jetzt beim Override vom mod_search type ="button" in "submit" geändert (siehe code) und jetzt scheint es zu funktionieren. Ich verstehe zwar nur Bahnhof aber ich sag mal Danke für die Hilfe.

    Code:
    if ($button) :
    					if ($imagebutton) :
    						$button = ' <input type="button" class="' . $moduleclass_sfx . ' btn-primary" onclick="this.form.searchword.focus();" value=' . $button_text . ' />';
    					else :
    						$button = ' <input type="submit" class="' . $moduleclass_sfx . ' btn-primary" onclick="this.form.searchword.focus();" value=' . $button_text . ' />';
    					endif;

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein