+ Antworten
Ergebnis 1 bis 6 von 6

Thema: Modul im Backend verschwunden

  1. #1
    Neu an Board
    Registriert seit
    17.12.2014
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Modul im Backend verschwunden

    Hallo!
    Ich habe ein Modul erstellt (Eigenes Modul), das im Frontend nur für Gäste sichtbar ist. Wenn ich als Gast die Seite ansehe ist im Frontend das Modul sichtbar.
    Nur leider finde ich im Backend unter "Module" das Modul nicht, es scheint nicht mehr zu existieren. Es ist kein Suchfilter gesetzt.
    Ich verwende das Yoo Avion Theme, wo man Modulen auch Icons verpassen kann, auch im Theme Editor ist das Modul zu finden, also muß es existieren

  2. #2
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    52
    Beiträge
    16.357
    Bedankte sich
    582
    Erhielt 4.220 Danksagungen
    in 4.026 Beiträgen

    Standard

    Und wo kann man das sehen?
    Modulopositionsvorschau aktiviert?

  3. #3
    Neu an Board
    Registriert seit
    17.12.2014
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    http://www.br-villach.at/index.php/n...erne-news?tp=1

    Es handelt sich um das Modul auf Position "main-top"

  4. #4
    Neu an Board
    Registriert seit
    17.12.2014
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Habe das Problem gerade selbst lösen können.

    Dadurch, dass das Modul die Zugriffsebene "Gast" hat, ist es komischerweise im Backend für den Admin auch nicht sichtbar.
    Unter "Benutzer - Zugriffsebenen" mußte ich die Ebene "Gast" öffnen und einen Haken bei "SuperUser" setzen.
    Dadurch wird das Modul im Backend wieder sichtbar.

  5. #5
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    60
    Beiträge
    18.843
    Bedankte sich
    720
    Erhielt 3.844 Danksagungen
    in 3.607 Beiträgen

    Standard

    ist es komischerweise
    Das ist auch so korrekt und nicht etwa ein Fehler, wie du glaubst

    "Publish" gilt immer. Auch dann wenn man nicht mehr "Public", sondern "Regsitriert" ist oder einer anderen Benutzergruppe zugeordnet ist.
    "Gast" hingegen ist eine eigenständige Benutzergruppe, die nach dem Ändern der Benutzergruppe nicht mehr angezeigt wird.
    "Public" ist immer da
    "Gast" hingegen nur, solange man tatsächlich "Gast" zugeordnet ist.

    Damit kann man beispielsweise Module nach dem Login verstecken. Was dir ja auch passiert ist


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  6. #6
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    52
    Beiträge
    16.357
    Bedankte sich
    582
    Erhielt 4.220 Danksagungen
    in 4.026 Beiträgen

    Standard

    Habe auch irgendwo gelesen, dass es sich um einen Bug handelt... Lösung hier: https://github.com/joomla/joomla-cms/pull/18548/files

    @Axel, er spricht vom Backend...
    Geändert von NinjaTurtle (14.11.2017 um 20:07 Uhr)

  7. Erhielt Danksagungen von:


+ Antworten

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein