+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: Java Script Problem mit Google MAP.

  1. #1
    Neu an Board
    Registriert seit
    19.06.2009
    Beiträge
    6
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Ausrufezeichen Java Script Problem mit Google MAP.

    Hallo leute , ich hoffe es kann mir einer helfen weil ich sitzt seit 3 Stunden und bekomme das Problem nicht gebacken...


    Ich möchte auf unserer Firmenseite ne Karte mit Standort einfügen.

    Hab schon mehrere Varianten probiert:

    Als benutzerdefioniertes Modul mit Einbindung des Codes direkt von Google (http://maps-generator.com/de) über den Editor

    Die Komponente Google Map

    Die Komponente Phoca Map

    Aber jedesmal wenn es die karte anzeigen soll kommt kurz darauf folgende Fehlermeldung:

    Hoppla! Ein Fehler ist aufgetreten.
    Google Maps wurde auf dieser Seite nicht richtig geladen. Technische Details dazu entnimmst du der JavaScript-Konsole.



    Bei den Komponenten sogar im Backend, kann nicht mal dort eine karte erstellen geschweige Koordinaten eingeben....

    Hab mich dann durchgewühlt durchs www und gelesen man braucht nen API Code von Google.

    So den hab ich jetzt kann ihn aber nirgends eingeben, weder in den Komponenten noch in nem Plugin !!

    Laut den Entwicklern von Phoca und Google Map braucht man für Ihre Programme auch gar nicht .


    Ich finde auch im Backend nirgends wo etwas wo ich Java ein oder ausschalten kann oder sonst ähnliches..
    Bin echt am Verzweifeln...

    Meine Daten:

    Joomla 3.5.1 Stable
    Joomla Platform 13.1.0 Stable
    PHP 5.6.21
    Webserver Apache

    PS.: die Seite www.sonnenschutz-grötz.at kann ich leider noch nicht online stellen , weil noch andere rechtliche Sachen mit Firmen zu klären sind.
    Angehängte Grafiken

  2. #2
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.771
    Bedankte sich
    130
    Erhielt 1.858 Danksagungen
    in 1.655 Beiträgen

    Standard

    "kann ich leider noch nicht online stellen"
    Dann stell die Frage erneut, wenn sie online ist...! Ich wunder mich halt immer, bei so, sorry: Blahblah. Ich hatte noch nie ein Problem dabei, wenn ich Hilfe benötigte, Helfern Zugang zur Seite einzuräumen (ich bezahl die halt im Unterschied zu dir (Zaunpfahlwink), "wenn ich am Verzweifeln bin") und wurde noch nie verklagt ;-)

    Nur 3 Stunden reichen bei dir, um zu verzweifeln? Da habe ich andere Maßstäbe ;-)



    API-Code: Die Zeiten sind vorbei. Immer aufs Datum der Fundsachen im Netz schauen.

    "Java": Die Rede ist von JavaScript, nicht Java. Was ganz anderes. Ich entnehme deinem Post, dass du dich professionell damit beschäftigst. Solltest du also wissen.

    JavaScriptkonsole, auch Webkonsole, Browserkonsole oder ähnlich genannt, findest in jedem entwickler-brauchbaren Browser und zeigt dir unter anderem JavaScript-Fehler an. Auch FireBug kannst verwenden.

    Es liegt mit hoher Wahrscheinlichkeit NICHT an den Maps selbst, sondern an irgendeinem anderen "JavaScript-Murx", der schon zuvor auftrat. Wenns noch dazu im Backend ist, ist die Wahrscheinlichkeit groß, dass es an einem murxigen Template-Framework-Plugin liegt (muss aber nicht).

    BTW: Generell ist der Joomla-Wartungsmodus eine sauschlechte Idee zum Testen und Entwickeln von Seiten. Man sollte stattdessen htaccess-Verzeichnisschutz verwenden, um die Seite so zu sehen, wie nicht joomla-angemeldete Besucher später dann auch. Es werden andere Dinge geladen. Je nach Erweiterungen ggf. auch andere JavaScripte.

    Da aber alles hochgeheim, gehts halt hier nicht weiter ;-)
    Geändert von Re:Later (29.06.2016 um 13:55 Uhr)

  3. #3
    Wohnt hier Avatar von SniperSister
    Registriert seit
    23.09.2005
    Ort
    Köln
    Alter
    27
    Beiträge
    2.951
    Bedankte sich
    96
    Erhielt 947 Danksagungen
    in 609 Beiträgen

    Standard

    Die Entwickler müssen ihre Erweiterung anpassen, da Google den Zugriff ohne API Key nicht mehr zulässt:
    http://googlegeodevelopers.blogspot....to-google.html

  4. Erhielt Danksagungen von:


  5. #4
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.771
    Bedankte sich
    130
    Erhielt 1.858 Danksagungen
    in 1.655 Beiträgen

    Standard

    Danke! Dachte, es wäre umgekehrt. Mit neueren APIs kein Key mehr nötig. Schon wieder alles anders.

    Dann könnte das natürlich das Problem des TE sein... Mea culpa!
    Geändert von Re:Later (29.06.2016 um 13:55 Uhr)

  6. #5
    Neu an Board
    Registriert seit
    19.06.2009
    Beiträge
    6
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Erstens danke für die promte Antwort !!

    Das mit dem Online stellen ist leider so ne Sache.....wir brauchen zuerst die Genehmigung für die Verwendung der Bilder.
    Nachdem es grosse Firmen sind, warten wir lieber , da wir eben nicht verklagt werden wollen :-)

    Und es sollte vorher eben die Seite fertig sein....
    Klar meinte ich JavaScript...hab nur abgekürzt. So professionell erstell ich keine Hp's, mach sie für meinen Schwiegervater.(Drum reichen bei mir schon 3 Stunden mit einem Problem :-) )
    Hab zwar schon 3 erstellt, ist aber schon ne Zeitlang her... (Joomla 1.5), und da gabs keine Probleme mit den Google Maps.

    Mit FireBug hab ich geschaut natürlich, sorry dass ich es vergessen hab zu erwähnen.

    Mit Firebug kommen folgende Meldungen:

    "Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error"
    "Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys"
    "Google Maps API warning: InvalidVersion https://developers.google.com/maps/documentation/javascript/error-messages#invalid-version"

    Drum kam ich auf die Sache mit dem API Code, weil er bei der zweiten Meldung "no-api-keys" schreibt.

    Template ist ein Standard Template von Joomla 3.5.1 Stable (Protostar), bei der ich nur die CSS umgeschrieben habe um es farblich anzupassen.

    Und den Wartungsmodus hab ich nachts, wenn ich an der Hp arbeite, ausgeschaltet. ;-) (nachts dehalb weil die Firmen geschlossen haben)

    Aber ich lese aus Deiner Antwort heraus, dass ich mir heute abend mal das Templat Framework anschaue....

  7. #6
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.771
    Bedankte sich
    130
    Erhielt 1.858 Danksagungen
    in 1.655 Beiträgen

    Standard

    Momentan funktionieren bei mir die o.g. Erweiterungen und weitere alle noch ohne Key. Kommt dann wohl erst mit nächstem API-Update.

  8. #7
    Neu an Board
    Registriert seit
    19.06.2009
    Beiträge
    6
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Die Frage ist nur wo gebe ich den Key ein ??

    Es funktioniert ja nicht mal wenn ich es als benutzerdefiniertes Modul mit Einbindung des Codes über den Editor probiere....

  9. #8
    Wohnt hier Avatar von SniperSister
    Registriert seit
    23.09.2005
    Ort
    Köln
    Alter
    27
    Beiträge
    2.951
    Bedankte sich
    96
    Erhielt 947 Danksagungen
    in 609 Beiträgen

    Standard

    @Re:Later es gibt scheinbar noch eine Schonfrist für Domains, die die Maps API schon vor dem 22. genutzt haben, das Problem ist hier bei mir auch nur nach nem Domainumzug aufgetreten.

  10. #9
    Wohnt hier Avatar von SniperSister
    Registriert seit
    23.09.2005
    Ort
    Köln
    Alter
    27
    Beiträge
    2.951
    Bedankte sich
    96
    Erhielt 947 Danksagungen
    in 609 Beiträgen

    Standard

    Zitat Zitat von ot16 Beitrag anzeigen
    Die Frage ist nur wo gebe ich den Key ein ??

    Es funktioniert ja nicht mal wenn ich es als benutzerdefiniertes Modul mit Einbindung des Codes über den Editor probiere....
    Deshalb sage ich ja: Du musst darauf warten dass die Erweiterungen für die Eingabe des Keys angepasst wurden.

  11. #10
    Neu an Board
    Registriert seit
    19.06.2009
    Beiträge
    6
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hab ne Lösung gefunden...auch wenn die wie ich finde für mich nur vorübergehend ist.

    Mann muss sich bei Google anmelden, Maps öffnen; Ort suchen und die karte dann einbetten.

    Es wird der Framcode erzeugt und dann über den Editor als benutzerdefiniertes Modul erstellen.

    Weil jetzt klappt es endlich..

    Link

    https://support.google.com/maps/answer/144361?rd=1

    Nur als Endlösung find ich es nicht gut, weil man sonst nichts angeben kann.

    So einfach....nur finden muss man es mal

+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein