+ Antworten
Ergebnis 1 bis 8 von 8

Thema: Fehler bei PhocaDownload im Administrationbereich

  1. #1
    Neu an Board Avatar von binnurich
    Registriert seit
    21.07.2014
    Ort
    Gelsenkirchen
    Beiträge
    15
    Bedankte sich
    9
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Fehler bei PhocaDownload im Administrationbereich

    Hallo liebe Joomla-Gemeinschaft!
    Seit der Umstellung bei All-Inkl auf eine neue PHP-Version bekomme ich im Administrationbereich folgende Fehlermeldungen:


    Warning: Illegal string offset 'name' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'type' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'creationDate' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'author' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'copyright' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'authorEmail' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Cannot assign an empty string to a string offset in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'authorUrl' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'version' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'description' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'group' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Cannot assign an empty string to a string offset in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38
    Warning: Illegal string offset 'filename' in /www/htdocs/xxxxx/xxxxx/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php on line 38

    Die Google-Suche ergab leider keine Lösung. Hat jemand einen Rat. Die Neuinstallation der Komponente brachte leider auch nichts.

    Joomla Version: 3.6.5
    Phoca-Downlod: com_phocadownload_v3.1.2

    Vielen Dank im Voraus für Eure Mühe!!!
    Geändert von binnurich (30.03.2017 um 15:50 Uhr)

  2. #2
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    53
    Beiträge
    17.594
    Bedankte sich
    653
    Erhielt 4.544 Danksagungen
    in 4.324 Beiträgen

    Standard

    Fehler berichten auf "Keine" stellen.

    Gibt es evtl. eine aktuelle Version, die Du noch nicht installiert hast

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  3. Erhielt Danksagungen von:


  4. #3
    Neu an Board Avatar von binnurich
    Registriert seit
    21.07.2014
    Ort
    Gelsenkirchen
    Beiträge
    15
    Bedankte sich
    9
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Wo kann ich die auf "Keine" stellen?
    Ich hab die aktuellste Version genommen

    habs gefunden
    Geändert von binnurich (30.03.2017 um 15:19 Uhr)

  5. #4
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    53
    Beiträge
    17.594
    Bedankte sich
    653
    Erhielt 4.544 Danksagungen
    in 4.324 Beiträgen

    Standard

    BE - System - Konfiguration - Server - "Fehler berichten"

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  6. #5
    Neu an Board Avatar von Siru
    Registriert seit
    04.04.2013
    Ort
    Eschenbach
    Beiträge
    5
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Böse Nicht gelöst

    Einfach die Fehlermeldung zu ignorieren ist nicht "gelöst", sondern einfach Symptombekämpfung. Unsauber!
    Der Fehler liegt an einem simplen Programmierungsfehler. Ein Fehler, der einem PHP-Programmierer nicht passieren sollte!

    In der Datei:
    [..]/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php, Linie 34, wird ein Array initialisiert mit $xml_items = '';

    Richtig ist
    PHP-Code:
    $xml_items = array(); 
    Simon

  7. #6
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.384
    Bedankte sich
    437
    Erhielt 1.927 Danksagungen
    in 1.828 Beiträgen

    Standard

    Hallo Simon,
    Zitat Zitat von Siru Beitrag anzeigen
    Einfach die Fehlermeldung zu ignorieren ist nicht "gelöst", sondern einfach Symptombekämpfung. Unsauber!
    Fehlermeldungen sind für Developer interessant & auch wichtig.

    Der Fehler liegt an einem simplen Programmierungsfehler. Ein Fehler, der einem PHP-Programmierer nicht passieren sollte!
    Aufgrund von Core Änderungen / Updates / libraries etc., müssen viele Erweiterungen dementsprechend angeglichen, geändert, umgeschrieben und vieles mehr, werden.
    Sei es u.a. PHP Versionen usw. usw. Da können Fehler passieren.

    In der Datei:
    [..]/administrator/components/com_phocadownload/libraries/phocadownload/utils/utils.php, Linie 34, wird ein Array initialisiert mit $xml_items = '';

    Richtig ist
    PHP-Code:
    $xml_items = array(); 
    daher danke für den Hinweis, den ich an Jan weiterleiten werde.

    Deine Information hättest Du auch gerne an Jan schreiben können. Siehe auch hier: http://phoca.cz/support Er und sein Team, ist für jede Hilfe dankbar.

    Liebe Grüße, Christine

  8. #7
    H13
    H13 ist offline
    War schon öfter hier Avatar von H13
    Registriert seit
    16.12.2007
    Beiträge
    115
    Bedankte sich
    3
    Erhielt 66 Danksagungen
    in 38 Beiträgen

    Standard

    Hallo,

    Einfach die Fehlermeldung zu ignorieren ist nicht "gelöst", sondern einfach Symptombekämpfung. Unsauber!
    Der Fehler liegt an einem simplen Programmierungsfehler. Ein Fehler, der einem PHP-Programmierer nicht passieren sollte!
    Hallo, das Program wurde geschrieben, wenn es noch nicht PHP 7.1 gab, so dies ist kein Programmierungsfehler. Es gibt noch keine Version für PHP 7.1,
    nur für ältere PHP Versionen. Warnung ist kein Fehler. Fehler ist z.B. ein Fatal Error.

    Ich mache momentan die Erweiterungen bereit für PHP 7.1. Ich habe über 1.000.000 Zeilen von Kode geschrieben, die ich frei zur Verfügung gestellt habe und es dauert manchmal,
    wenn ich alles auf die neueste Versionen umwandle (es geht nicht nur um PHP oder MySQL, aber auch Joomla!, verschiedene APIs - Google, Facebook, Javascript
    libraries, usw.)

    So dies sind die möglichen Lösungen:

    - nicht ein Programm auf PHP 7.1 installieren, wenn es dafür nicht geeignet ist
    - die Warnungen, die für Developers bestimmt sind, einfach auszuschalten und warten auf neue Version
    - einfach es selbst ändern
    - jemanden mieten um es zu machen
    - oder noch einfacher, 10 Jahre von seinem Leben opfern und für sich selbst eine eigene Komponente schreiben.



    Bitte, hier: http://www.phoca.cz/forum kann man Feedback schreiben, so wenn jemand da schreibt:

    "Bitte, Joomla! 3.x, Phoca Download 3.x, und neueste Version von PHP 7.1 - es sind Warnungen für Developers dargestellt" - dann kann ich als Developer die Informationen
    schneller bekommen und die neue Version für neueste PHP Version vorzubereiten.

    Aber, wie ich es schon geschrieben habe, ich verwalte über mehr als 1.000.000 Zeilen von Kode für die Community in meiner Freizeit, so manchmal nimmt es mehr Zeit.

    Wenn man aber helfen will, gibt es dafür keine Hindernisse.

    Danke, Jan
    Geändert von H13 (10.05.2017 um 15:04 Uhr)

  9. Erhielt Danksagungen von:


  10. #8
    Neu an Board
    Registriert seit
    14.06.2014
    Beiträge
    14
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Danke

    Dank der Anleitung konnte ich es auch lösen.

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein