+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 15 von 15

Thema: update auf php 7 ergibt Error

  1. #11
    Kommt häufiger vorbei Avatar von Svenoldman
    Registriert seit
    09.12.2005
    Ort
    Land Brandenburg
    Alter
    50
    Beiträge
    324
    Bedankte sich
    30
    Erhielt 8 Danksagungen
    in 7 Beiträgen

    Standard

    Was muss ich denn anpassen?
    Da steh ich jetzt auf den Schlauch.

  2. #12
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.276
    Bedankte sich
    194
    Erhielt 1.021 Danksagungen
    in 992 Beiträgen

    Standard

    Du hast möglicherweise die configuration.php überschrieben. Da stehen u.a. die DB-Zugangsdaten drinnen.
    Das wäre dann aber PHP-versionsunabhängig.
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  3. #13
    --- Avatar von anka
    Registriert seit
    01.05.2008
    Ort
    Basel
    Beiträge
    11.491
    Bedankte sich
    449
    Erhielt 4.327 Danksagungen
    in 3.980 Beiträgen

    Standard

    Ich hatte auch mal das gleiche Problem. Wenn ich mich richtig erinnere, dann musste ich für die DB ein neues Passwort setzen und danach die configuration.php entsprechend anpassen. Ich weiss allerdings auch nicht mehr, warum das geholfen hat.
    Geändert von anka (14.04.2018 um 01:19 Uhr)
    Gruss Anka

  4. #14
    Verbringt hier viel Zeit
    Registriert seit
    09.08.2008
    Ort
    /dev/null
    Beiträge
    931
    Bedankte sich
    47
    Erhielt 121 Danksagungen
    in 114 Beiträgen

    Standard

    Läuft das PHP7.x bei dir als FCGI? Bei eigenen Einträgen (max Ram oder Max Executing-Time usw.) funktionieren die htaccess unter Umständen nicht richtig, dafür gibt es dann "user.ini" oder "php.ini", welches du in Hauptverzeichnis packen sollst
    Stasi 2.0,- Dank Merkel und ihrer Lakaien

  5. #15
    Wohnt hier Avatar von Ellwood
    Registriert seit
    03.08.2011
    Ort
    Region Hannover
    Beiträge
    2.699
    Bedankte sich
    136
    Erhielt 627 Danksagungen
    in 608 Beiträgen

    Standard

    Zitat Zitat von anka Beitrag anzeigen
    ... Wenn ich mich richtig erinnere, dann musste ich für die DB ein neues Passwort setzen ...
    Steht auch so in den FAQ:

    Nach der Umstellung der PHP-Version kann ich mich nicht zur Datenbank verbinden?
    Problembeschreibung:

    Nachdem Sie die PHP-Version gewechselt haben, ist eine Datenbank-Verbindung nicht mehr möglich. Eine Neuinstallation von Software schlägt trotz richtigem Passwort fehl.


    Lösung a)

    Sie melden dem Support das aktuelle DB-Passwort und lassen sich das Passwort noch mal neusetzen.
    Lösung b)

    Sie vergeben selbst ein neues Datenbank-Passwort im Confixx-Bereich unter "Einstellungen" oder "Datenbank" und benutzen das neue Passwort.
    Aber vielleicht ist das hier der entscheidene Punkt:

    Wichtig: Ab PHP 7.0 müssen Sie als MySQL-Server 127.0.0.1 und nicht mehr localhost angeben.
    Zitate aus den FAQ von domainexpress.de
    Geändert von Ellwood (15.04.2018 um 08:03 Uhr) Grund: Typo
    Gruß Elwood
    Bin auch hier: http://forum.joomla.de

+ Antworten
Seite 2 von 2 ErsteErste 1 2

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein