+ Antworten
Ergebnis 1 bis 9 von 9

Thema: Administratorbereich nicht mehr aufrufbar

  1. #1
    Neu an Board
    Registriert seit
    11.03.2016
    Beiträge
    11
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Administratorbereich nicht mehr aufrufbar

    Hallo , nach einigen Änderungen meiner Dateiberechtigungen hatte ich plötzlich keinen Zugriff mehr auf den Administratorbereich, ich habe mich dabei an die Joomla Security Seite:
    https://www.joomla-security.de/datei...nisrechte.html gehalten. Wer kann mir sagen, welche Rechte davon verhindern, dass man den Admin Bereich aufrufen kann???
    Habe schon versucht, die Verzeichnisse wieder in die ursprünglichen Rechte zurück zu versetzen, aber das funktioniert momentan irgendwie nicht. Ist das auf der Joomla Security Seite noch aktuell? Weiß das vielleicht jemand?

  2. #2
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.808
    Bedankte sich
    156
    Erhielt 2.259 Danksagungen
    in 2.026 Beiträgen

    Standard

    Mach doch bitte ausführlichere Angaben.

    Welche Verzeichnis- und Dateirechte hattest du zuvor?
    Wie hast du die Rechte geändert? Konsole oder bspw. FileZilla?

    Welche Joomla-Version? Welches Betriebssystem? Hoster? Eigener Server? "Stinknormales" Paket oder irgendwas besonderes?

    Und nein, die Empfehlungen auf der security-Seite sind nicht allgemein empfohlen, ebensowenig wie die dort für Anfänger unzureichend kommentierte htaccess-Datei. Empfohlen ist, Joomla so zu verwenden, wie es ausgeliefert wird, bei einem Hoster, der sein Handwerk versteht.

    Es gibt allerdings Hoster, die andere Datei- und Verzeichnisrechte 0644 und 0755 verwenden, wenn man bspw. joomla per FTP hochlädt, was ja für Installation richtig ist. Wenn dann was nicht funktioniert, passiert mir gelegentlich bei HE oder Green.ch, dann forciere ich 0644 und 0755 per Sammellauf.

    Im besten Fall probiert man so was schrittweise, bspw. mal 1 index.php auf 444 und testen, und ändert nicht per Konsole alles im Sammellauf. Server können unterschiedlich konfiguriert sein, auch bzgl. Dateirechten.
    Geändert von Re:Later (23.04.2019 um 11:58 Uhr)
    Joomlafachmann: https://www.ghsvs.de

  3. #3
    Neu an Board
    Registriert seit
    11.03.2016
    Beiträge
    11
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hmmmm... ok also aktuelle Joomal Version, über Filezilla geändert. Naja eben scheinbar jedenfalls nicht diese... Betriebssystem ist Windows
    - also ich hatte beispielsweise die css-Dateien auf 444 gesetzt, ebenso wie die index.php im Administratorbereich - aber das habe ich mittlerweile wieder rückgängig gemacht...
    trotzdem ist der Administrator Bereich nicht mehr aufrufbar
    Geändert von stupsi (23.04.2019 um 12:55 Uhr)

  4. #4
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.969
    Bedankte sich
    201
    Erhielt 1.271 Danksagungen
    in 1.237 Beiträgen

    Standard

    Für einen vernünftigen Grundschutz benötigst du lediglich einen zusätzlichen Passwortschutz (also eine .htaccess und .htpasswd) im administrator-Verzeichnis. Letztere Datei könnte man auch außerhalb bzw. oberhalb von Joomla platzieren. Es gibt auch Generatoren im Web, die dir diese Dateien erzeugen.

    Alles andere ist meiner Ansicht nach übertrieben und führt tatsächlich häufig zum Blockieren bestimmter Funktionen. Das kann sich bei jedem Update ändern.
    In aller Regel brauchst du auch keine Dateirechte ändern, es sei denn der Hoster macht spezielle Probleme.

    Wie macht sich das bemerkbar, dass du dich nicht ins Backend einloggen kannst (ev. Fehlermeldung)?
    Nutzt du eine .htaccess im Joomla-Root? Die von der genannten Webseite oder die originale .htaccess? Im ersteren Fall diese mal zurück umbennen in z.B. htaccess-deaktiviert.txt
    Hast du weitere Dinge verändert? Vermutlich hat das auch einen ganz anderen Grund.

    Die Beantwortung der Fragen nach dem Hoster bzw. eigenem Server ist wichtig!
    Geändert von JoomlaWunder (23.04.2019 um 15:24 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  5. #5
    Neu an Board
    Registriert seit
    11.03.2016
    Beiträge
    11
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    kann gelöscht werden - ausversehen doppelt gepostet
    Geändert von stupsi (23.04.2019 um 15:45 Uhr)

  6. #6
    Neu an Board
    Registriert seit
    11.03.2016
    Beiträge
    11
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ja, also das mit dem Verzeichnisschutz kenne ich schon.
    Das "/administrator" läßt sich einfach nicht mehr aufrufen. Die Seite lädt dann einfach neu.
    Ich hatte halt auf der Seite einige Spambotangriffe und habe deshalb gedacht, wenn ich die Verzeichnisrechte anpasse, ist es vielleicht sicherer.

    htaccess habe ich auch schon deaktiviert - hmmm - vor ein paar Tagen ging noch alles...

    Also per FTP ist alles aufrufbar und auch noch vorhanden, es sieht auch nicht aus, als wären Dateien verändert worden, daher mein Verdacht mit den Verzeichnisrechten...
    Geändert von stupsi (23.04.2019 um 15:44 Uhr)

  7. #7
    Wohnt hier Avatar von JoomlaWunder
    Registriert seit
    03.03.2010
    Ort
    Nordseeküste
    Beiträge
    4.969
    Bedankte sich
    201
    Erhielt 1.271 Danksagungen
    in 1.237 Beiträgen

    Standard

    1. Meist ist das Kontaktformular oder Ähnliches das Problem, insbesondere die Option "Kopie an Absender". Diese auf jeden Fall deaktivieren.
    2. Nutzt man die Benutzerregistrierung nicht, dann diese deaktivieren!
    3. Joomla und seine Erweiterungen immer aktuell halten.
    4. Zusätzlichen Passwortschutz des Backends einrichten.
    Dann ist die Gefahr von Spam bzw. Hacks sehr gering.

    Hat dich dein Hoster auf das Problem aufmerksam gemacht oder hast du das anhand deiner empfangenen Emails festgestellt?
    Hast du ein Backup? Dann eventuell dieses einspielen. Könnte schneller gehen, als wenn du nun anfängst zu suchen.
    Wahrscheinlich ist es aber nur eine Kleinigkeit, die du ändern musst. Da kann man aus der Ferne aber nur raten?
    Eventuell nur ein einfacher Login-Loop. Nutze am besten mal die Suchfunktion!

    Bleibt noch immer die Frage: Welcher Hoster?
    Geändert von JoomlaWunder (23.04.2019 um 16:20 Uhr)
    Gruß!
    JoomlaWunder
    Kein Support per PN!
    Konnte ich helfen? -> Dann bitte den "Danke"-Button klicken!

  8. Erhielt Danksagungen von:


  9. #8
    Neu an Board
    Registriert seit
    11.03.2016
    Beiträge
    11
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Nein Danke, diese Hinweise kenne ich alle schon und wende sie auch an - ich habe das Problem mit Hilfe meines Webhosters lösen können: Irgendein Plugin ist dafür verantwortlich., Ich weiß wahrscheinlich auch schon, Welches!
    Trotzdem vielen Dank für die Hilfe! Manchmal steht man halt wie der Ochs vorm Scheunentor! Es ging ja auch nicht um einen Hack, sondern und massive Spam Emails - die bekommt man durch diese Maßnahmen eben auch nicht weg.
    Dafür hatte ich halt ein Plugin installiert, als Spambotschutz, aber scheinbar ist dies wohl falsch eingestellt gewesen, vermute ich mal...

  10. #9
    Gehört zum Inventar Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    5.808
    Bedankte sich
    156
    Erhielt 2.259 Danksagungen
    in 2.026 Beiträgen

    Standard

    Nur zur Klarstellung: Mit Betriebssystem meinte ich das, wo die Seite drauf läuft, also nicht dein lokales.
    Joomlafachmann: https://www.ghsvs.de

+ Antworten

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein