+ Antworten
Ergebnis 1 bis 7 von 7

Thema: mehrsprachiges Joomla Frontend nicht erreichbar

  1. #1
    Neu an Board
    Registriert seit
    28.02.2019
    Beiträge
    3
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard mehrsprachiges Joomla Frontend nicht erreichbar

    Hallo,

    ich habe eine mehrsprachige Joomla Seite auf ein Webserver umgezogen. Das Backend ist normal erreichbar, jedoch bekomme ich das Frontend einfach nicht zum laufen, es kommt ein 404 Fehler.

    Webserver:
    nginx: Version 1.14.0
    PHP: Version 7.2
    mariadb: Version 10.1.38

    Joomla
    Version: 3.9.2

    URL Aufbau (xyz.de/lang/)

    Hier noch der Auszug aus der nginx Config:

    Code:
    server {
    
            listen 80;
            listen [::]:80;
    
            root /var/www/html/domain;
            index index.php index.html index.htm;
    
            server_name kup.domain.eu www.kup.domain.eu;
    
            #Create access and error logs in /var/log/nginx
            access_log /var/log/nginx/domain.access_log;
            error_log /var/log/nginx/domain.error_log;
    
            client_max_body_size 100M;
    
    #       location / {
    #               expires 1d;
    #               try_files $uri $uri/ /index.php?q=$request_uri;
    #       }
    
            location = /index\.php {
            }
    
            autoindex off;
    
            location / {
            if ($query_string ~ "base64_encode[^(]*\([^)]*\)"){
                    return 403;
             }
            if ($query_string ~* "(<|%3C)([^s]*s)+cript.*(>|%3E)"){
                    return 403;
             }
            if ($query_string ~ "GLOBALS(=|\[|\%[0-9A-Z]{0,2})"){
                    return 403;
             }
            if ($query_string ~ "_REQUEST(=|\[|\%[0-9A-Z]{0,2})"){
                    return 403;
             }
            if ($http_host !~ "^kup.domain.eu"){
                    rewrite ^(.*)$ http://kup.domain.eu$1 redirect;
             }
            }
    
            location ~ \.php$ {
                    include snippets/fastcgi-php.conf;
            #       # With php-fpm (or other unix sockets):
                    fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    #               fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                    include fastcgi_params;
            #       # With php-cgi (or other tcp sockets):
            #       fastcgi_pass 127.0.0.1:9000;
            }
    }

    Im Error Log bekomme ich folgende Meldungen:

    2019/02/28 12:30:11 [error] 2311#2311: *3 open() "/var/www/html/domain/favicon.ico" failed (2: No such file or directory), client: 192.168.1.44, server: kup.domain.eu, request: "GET /favicon.ico HTTP/1.1", host: "kup.domain.eu"
    2019/02/28 12:30:36 [error] 2634#2634: *4 "/var/www/html/domain/de/index.php" is not found (2: No such file or directory), client: 192.168.1.44, server: kup.domain.eu, request: "GET /de/ HTTP/1.1", host: "kup.domain.eu"
    2019/02/28 12:30:40 [error] 2644#2644: *1 "/var/www/html/domain/de/index.php" is not found (2: No such file or directory), client: 192.168.1.44, server: kup.domain.eu, request: "GET /de/ HTTP/1.1", host: "kup.domain.eu"
    2019/02/28 12:44:15 [error] 2644#2644: *2 open() "/var/www/html/domain/favicon.ico" failed (2: No such file or directory), client: 109.41.193.239, server: kup.domain.eu, request: "GET /favicon.ico HTTP/1.1", host: "kup.domain.eu"
    2019/02/28 12:56:24 [error] 2644#2644: *6 "/var/www/html/domain/de/index.php" is not found (2: No such file or directory), client: 192.168.1.44, server: kup.domain.eu, request: "GET /de/ HTTP/1.1", host: "kup.domain.eu"
    2019/02/28 12:56:24 [error] 2644#2644: *6 open() "/var/www/html/domain/favicon.ico" failed (2: No such file or directory), client: 192.168.1.44, server: kup.domain.eu, request: "GET /favicon.ico HTTP/1.1", host: "kup.domain.eu"
    Hat jemand Rat was ich vielleicht vergessen habe? Danke schonmla für eure Antworten.

  2. #2
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    53
    Beiträge
    17.512
    Bedankte sich
    643
    Erhielt 4.521 Danksagungen
    in 4.305 Beiträgen

    Standard

    Das Ziel des Startseitenmenüeintrags ist auch tatsächlich noch vorhanden?

    Wähle einen anderen Menüeintrag im BE als Startseite aus

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  3. #3
    Neu an Board
    Registriert seit
    28.02.2019
    Beiträge
    3
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ja das ist vorhanden. Die Seite läuft auf einem komplett anderen Test Webspace (jedoch Apache) problemlos (Umzug fand 1zu1 gleich statt).

  4. #4
    Gehört zum Inventar
    Registriert seit
    26.07.2007
    Ort
    RZ / EA / B
    Beiträge
    7.506
    Bedankte sich
    442
    Erhielt 1.762 Danksagungen
    in 1.641 Beiträgen

    Standard

    Evtl ist in der .htaccess etwas verbogen. SEF mal abschalten, wenn aktiviert, und prüfen.
    Gruß, Chris
    Joomla kaputt? Gehackt? Migration mißlungen? Datensalat?
    www.cms-reparatur.de - Soforthilfe & Webentwicklung

  5. #5
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    53
    Beiträge
    17.512
    Bedankte sich
    643
    Erhielt 4.521 Danksagungen
    in 4.305 Beiträgen

    Standard

    Was passiert, wenn Du auf einen anderen Menüeintrag umstellst?

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  6. #6
    Neu an Board
    Registriert seit
    28.02.2019
    Beiträge
    3
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    nginx nutzt keine .htaccess
    Ich habe SEF nun mal deaktiviert und die Webseite wäre erreichbar. Aber natürlich nicht mehr mit Suchmaschinenfreundlichen URLs. Was müsste ich nun machen, damit man suchmaschinenfreundliche URLs nutzen kann?

  7. #7
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.365
    Bedankte sich
    437
    Erhielt 1.924 Danksagungen
    in 1.825 Beiträgen

    Standard

    Hallo,

    weiß nicht, aber vielleicht hilft das da? https://winginx.com/en/htaccess

    Liebe Grüße
    Christine

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein