+ Antworten
Seite 1 von 9 1 2 3 4 5 ... LetzteLetzte
Ergebnis 1 bis 10 von 84

Thema: Joomla 3.5.0 STABLE erschienen

  1. #1
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.768
    Bedankte sich
    130
    Erhielt 1.857 Danksagungen
    in 1.654 Beiträgen

    Standard Joomla 3.5.0 STABLE erschienen

    https://github.com/joomla/joomla-cms/releases/tag/3.5.0


    EDIT: Das Update auf 3.5.0 sollte im Idealfall mit Datenbank-Einstellung MySQLi in der Joomla-Konfiguration ausgeführt werden.
    Die Einstellung Mysql (PDO) sollte nach Möglichkeit vermieden werden, da vermutlich fehlerhaft.


    NOCH MAL: NOTFALL BEdEUTET: NUR, WENN EUER UPDATE AUF NORMALEM WEGE NICHT FUNKTIONIERT. NUR DANN IST FTP-WEG NÖTIG UND TUT AUCH NICHT WEH.
    Nur für Notfälle und bis auf weiteres der einzige Weg, der funktioniert:
    Sollte normales Update via Update-Manager in Joomla fehlschlagen:
    - Update-Paket Joomla_3.5.0-Stable-Update_Package.zip entpacken
    - via FTP über die Joomla-Installation drüberkopieren/drüberbügeln.
    - Im Backend anmelden.
    - Unter Erweiterungen > Datenbank den Reparieren-Button klicken.
    - Vorher(!) angezeigte, rote Fehlermeldungen ignorieren! Da fehlt einfach noch eine Datenbanktabelle.


    Ein Notfall-Update wie früher via Erweiterungen > Installieren funktioniert NICHT MEHR!!!!!!!
    Geändert von Re:Later (26.03.2016 um 06:46 Uhr)

  2. Erhielt Danksagungen von:


  3. #2
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.768
    Bedankte sich
    130
    Erhielt 1.857 Danksagungen
    in 1.654 Beiträgen

    Standard

    2 Dutzend 3.4.7 und 3.4.8 problemlos geupdatet. 3 per FTP-Methode. 4 verschiedene Provider.

    Wartezeit nach Klick auf Aktualisieren und NACHDEM Upload fertig: 1,5 bis 3 Minuten

    Umstellung auf PHP 7 nach Update ebenfalls problemlos (EDIT: fast).
    - Abgesehen von Deprecated-Meldungen von 3rd-Erweiterungen, die man den jeweiligen Entwicklern melden sollte.
    Mit Fehler berichten deaktivieren in der Joomla-Konfiguration wird man Medlungen los.
    Beispiel: "Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP"

    - EDIT: Bei Meldungen der Art (mit weißer Seite)
    "Fatal error: Cannot use Joomla\String\String as String because 'String' is a special class name"
    hilft nur Rückstellen auf niedrigere PHP-Version und auf Bugfix der Erweiterungs-Anbieter warten. (Stichwort String ist jetzt StringHelper in Joomla).


    Die Aktivierung des Stats-Plugins (wird man gefragt nach Update) kann man empfehlen, da Joomlamachern hilft z.B. einzuschätzen, welche Datenbanksysteme verwendet werden.
    Gerade die, die NICHT Mysql verwenden, sollten es aktivieren, da ja immer mal wieder die Diskussion aufkommt, ob Joomla Support für andere Systeme nicht irgendwann einstellen sollte, auch, weil es nicht genügend Tester und Entwickler für diese Systeme gibt (zaunpfahlwinkewinke).
    Das Plugin arbeitet vertrauenswürdig.

    Weiters interessant: Neues und aktiviertes Plugin
    System - Joomla! Update Notification
    das bei Grundeinstellung per Email SuperAdmins mit Einstellung "Systememails erhalten" (bin nicht ganz sicher, ob nur die) über ausstehende Joomla-Updates informiert.
    Etwas schade, dass man nur SuperAdmin-Emails ins konfigurierbare Emailfeld eintragen kann, wenn nicht alle SuperAdmins bekommen sollen.

    Deutsches Sprachpaket wird mir noch nicht angeboten, deshalb einiges neues noch englisch beschriftet.
    Geändert von Re:Later (22.03.2016 um 10:35 Uhr)


  4. #3
    Neu an Board Avatar von badray
    Registriert seit
    05.07.2007
    Ort
    Benz-Town
    Beiträge
    74
    Bedankte sich
    14
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Ausrufezeichen Achtung bei Seiten mit Falang und Update auf Joomla 3.5.0

    Hallo zusammen,

    ich musste gerade feststellen, dass ein Update auf Joomla 3.5.0 bei Seiten mit Unterstützung von Falang zur Mehrsprachigkeit voll in die Hosen geht ;-)

    Falang und auch alle anderen Module sind aktuell, ich vermute es liegt noch an den fehlenden Sprachpaketen.

    Zum Glück hab ich davor ein Backup gemacht und konnte wieder zurück auf die 3.0

    Viele Grüße Ray
    es hat nicht so viel Tag im Jahr, wie der Fuchs am Schwanz hat Haar ^^

  5. #4
    Verbringt hier viel Zeit Avatar von jsc_01
    Registriert seit
    14.10.2012
    Ort
    74321
    Beiträge
    524
    Bedankte sich
    35
    Erhielt 93 Danksagungen
    in 85 Beiträgen

    Standard

    Zwei Testseiten upgedated, J3.4.8 und J3.5.0 rc4 -> J3.5.0, fast problemlos.
    Nach Update weisse Seite im Frontend, Ari-Image Slider deaktiviert und in gleicher Version nachinstalliert, Problem weg.
    Bei installiertem Akeeba Backup wird nach dem Anstoßen des Updates automatisch ein Backup erstellt.
    Gruß Jürgen

  6. #5
    Neu an Board
    Registriert seit
    05.08.2011
    Beiträge
    76
    Bedankte sich
    17
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Update problemlos: Bis darauf, dass ich das Template Protostar verwende und er meine komplette Template.css und das Favicon.ico überschrieben hat.

    Weiß zufällig jemand, ob sich irgendetwas in der template.css geändert hat? Oder kann ich die alte 1:1 wieder reinkopieren?
    Und weiß jemand ob sich sonst noch was an dem Template geändert hat, ausser das die template.css überschrieben wird?

    LG
    Dicken
    Geändert von DickenSerm (22.03.2016 um 08:59 Uhr)

  7. #6
    Wohnt hier Avatar von Ellwood
    Registriert seit
    03.08.2011
    Beiträge
    2.502
    Bedankte sich
    128
    Erhielt 586 Danksagungen
    in 571 Beiträgen

    Standard

    Zitat Zitat von DickenSerm Beitrag anzeigen
    Bis darauf, dass ich das Template Protostar verwende und er meine komplette Template.css und das Favicon.ico überschrieben hat.
    http://forum.joomla.de/index.php/Thr...ine-Template-/
    Bin auch hier: http://forum.joomla.de

  8. #7
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.768
    Bedankte sich
    130
    Erhielt 1.857 Danksagungen
    in 1.654 Beiträgen

    Standard

    Kein Erfolg mit XAMPP, Grundeinstellungen, frischem 3.4.8, PHP 5.6.

    Das Update schlug reproduzierbar aus Zeitgründen fehl, während die Datenbank für 5.0 umbearbeitet wird (utf8 nach utf8mb4).
    Bricht mittendrin ab wegen max_execution_time, die ich in php.ini von 30 aufwärts erhöhen musste (600 = 10Min).

    Das selbe Spiel, wenn man nur Datenbank-Fix anstößt nach fehlgeschlagenem Update. Aber dann per Fix-Button Erfolg, nachdem max_execution_time erhöht.
    Ist also nicht verloren die XAMPP-Joomla-Installation.

    Wunder mich nur, dass online keine Probleme bei Seiten gab, die auch keine höhere max_execution_time haben (prüfe ich aber noch mal).


    Bei installiertem Akeeba Backup wird nach dem Anstoßen des Updates automatisch ein Backup erstellt.
    Wer's nicht mag und so wie ich seine Backups auch in Zukunft lieber selber macht und beschriftet, das Plugin System - Backup on update deaktivieren.
    Das hat akeeba backup in einer der letzten Versionen einfach installiert und aktiviert. Kann auch extrem lästig sein, das Teil ;-)

  9. Erhielt Danksagungen von:


  10. #8
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.768
    Bedankte sich
    130
    Erhielt 1.857 Danksagungen
    in 1.654 Beiträgen

    Standard

    Weiß zufällig jemand, ob sich irgendetwas in der template.css geändert hat? Oder kann ich die alte 1:1 wieder reinkopieren?
    Ersteres: Ja.
    Zweiteres: Vermutlich.

    Kannst aber einfach Protostar löschen, dann deinen alten Protostarordner reinkopieren, dann Ellwoods Link. Danach im Backend im neuen Template-Stil die Einstellungen wieder restaurieren.

    Falls du Module unter Alternatiives Layout einem Protostar-Layout zugeordnet hast, musst die Einstellungen leider auch neu machen.

    Ebenso bei Alternativen Layouts in Menüeinträgen, Kategorien und Beiträgen, falls du das was eingestellt hast.

  11. #9
    Verbringt hier viel Zeit Avatar von faro02
    Registriert seit
    06.03.2006
    Ort
    HRO
    Beiträge
    668
    Bedankte sich
    50
    Erhielt 77 Danksagungen
    in 76 Beiträgen

    Standard

    Zitat Zitat von jsc_01 Beitrag anzeigen
    Zwei Testseiten upgedated, J3.4.8 und J3.5.0 rc4 -> J3.5.0, fast problemlos.
    Nach Update weisse Seite im Frontend, Ari-Image Slider deaktiviert und in gleicher Version nachinstalliert, Problem weg.
    Bei installiertem Akeeba Backup wird nach dem Anstoßen des Updates automatisch ein Backup erstellt.
    Hallo Jürgen,
    wenn dein Akeeba angesprungen ist, dann hast Du das Update nicht per FTP gemacht? Wurde es Dir im Backend angezeigt? Was hast Du dazu eingestellt?

    Danke und Gruß Faro

  12. #10
    Wohnt hier Avatar von Re:Later
    Registriert seit
    21.04.2014
    Ort
    Berlin
    Beiträge
    4.768
    Bedankte sich
    130
    Erhielt 1.857 Danksagungen
    in 1.654 Beiträgen

    Standard

    Achtung bei Seiten mit Falang und Update auf Joomla 3.5.0
    Ich konnte zwar Falang problemlos mit updaten und auch nachinstallieren, allerdings Falang in nicht eingerichteter Form,

    aber die aktuelle Falang-Version 2.2.2 ist GARANTIERT NICHT Joomla-3.5-ready.

    Zerlegt einem fast alle Tabellen im Backend, zeigt keine Steuerelemente an, legt die Werkzeugleiste lahm usw..
    Ist selbst unbedienbar und macht Joomla unbedienbar.

+ Antworten
Seite 1 von 9 1 2 3 4 5 ... LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein