+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Migration nach Ubuntu klappt nicht - Backendeinwahl reagiert nicht

  1. #1
    Neu an Board
    Registriert seit
    18.10.2016
    Beiträge
    7
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Migration nach Ubuntu klappt nicht - Backendeinwahl reagiert nicht

    Hallo,

    kann mir jemand die neuralgischen Punkte sagen, auf die man bei folgender Migration achten muss?

    ich wollte/habe eine online 2.5.6J (Linux dd1714 3.2.0-110-generic #151-Ubuntu) auf meinen Ubuntu-PC kopieren.
    Dazu habe ich die Dateien und die Datenbank kopiert.
    Ich habe bisher nur die configuration.php angepasst.
    Und per
    find /home/...../ -type d -exec chmod 755 {} +
    find /home/...../ -type f -exec chmod 644 {} +
    die Rechte freigegeben.

    Nun gebe ich fürs Backend den Zugang ein, nach LogIn passiert aber nichts: keine Fehlermeldung.
    Wie komme ich da rein?

    Dank für Hilfen,
    Grüße,
    Fes

  2. #2
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.991
    Bedankte sich
    158
    Erhielt 1.823 Danksagungen
    in 1.780 Beiträgen

    Standard

    Hallo,

    willkommen im Forum.

    Beschreibe doch einmal, wie Du die Datenbank kopiert hast. Ds ist mir beim Lesen als Erstes aufgefallen.
    "Normalerweise" erfolgt hier ein Ex-und anschlißender Import mittels phpMyAdmin.

    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  3. #3
    Neu an Board
    Registriert seit
    18.10.2016
    Beiträge
    7
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    über phpMyAdmin exportiert. Das ergab eine file.sql.zip, die ich im anderen phpMyAdmin importierte.
    (die J!-Verzeichnis Dateien habe ich auf dem Server komprimieren lassen, runtergeladen und hier extrahier und dann Rechte geändert)

    Einerseits wird hier bei mir ein Menüteil im Quellcode & nat. auf der Seite nicht gezeigt
    (dem versuche ich grad auf die Spur zu kommen)
    und
    der Zeichensatz für manche Links stimmt nicht,
    z.B. steht im hover-Link "http://localhost/...Dünen", aber wenn ich klicke gibts ein "Not Found ... Dünen".
    Fes

  4. #4
    Gehört zum Inventar
    Registriert seit
    06.03.2013
    Ort
    /dev/random
    Beiträge
    6.245
    Bedankte sich
    138
    Erhielt 2.344 Danksagungen
    in 2.208 Beiträgen

    Standard

    Hört sich an, als ob du die configuration.php mit dem falschen Editor editiert hast.
    Gruß FINWICK
    ↶ Danke Button nutzen, wenn es geholfen hat - Kein Suport via PN

  5. #5
    Neu an Board
    Registriert seit
    18.10.2016
    Beiträge
    7
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von FINWICK Beitrag anzeigen
    Hört sich an, als ob du die configuration.php mit dem falschen Editor editiert hast.
    hier auf dem PC mit dreien:
    bluefish
    mousepad
    leafpad
    nach letzterem hat sie UTF8 und LF.

    Geändert hatte ich eigentlich nur
    public $log_path = '/home/pc/my/pro/logs';
    public $tmp_path = '/home/no1x/my/pro/tmp';

    und den DB-zugang natürlich.

    wie kann man den falsche Zeichen finden?

    Fes

  6. #6
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.991
    Bedankte sich
    158
    Erhielt 1.823 Danksagungen
    in 1.780 Beiträgen

    Standard

    Guten Abend,

    die Datei und m.E. nicht nur die , müssen mit utf8 ohne BOM kodiert sein.

    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  7. #7
    Neu an Board
    Registriert seit
    18.10.2016
    Beiträge
    7
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    >...die Datei und m.E. nicht nur die , müssen mit utf8 ohne BOM kodiert sein....
    wie machst du das?

    arbeitest du mit einem der og. Programmen?
    Wie findet man denn die "schwarzen Peter"? "Die Dateien blinken ja nicht..."
    Und falsche Zeichen erkenne ich in der config-Datei nicht.

    Und ob bluefish seine eine UTF8-Version als mit oder ohne BOM versteht, sagt er auch nicht.
    Mousepad hätte einen Haken bei "Unicode BOM schreiben"
    Und wie soll man das bei zig-Dateien durchchecken?

    Auf Win gib es Notepad++, da gibts zumindest klare Unterscheidungen ... und man konnte einen Schwung Dateien auf einmal abspeichern.

    fes

  8. #8
    Gehört zum Inventar
    Registriert seit
    06.03.2013
    Ort
    /dev/random
    Beiträge
    6.245
    Bedankte sich
    138
    Erhielt 2.344 Danksagungen
    in 2.208 Beiträgen

    Standard

    Auf der Linux-Console - Erstelle eine Datei und mach sie Ausführbar.
    TestFile.sh
    Code:
    #!/bin/bash
    TYPE=$(file -bi $1|sed 's/.*=//')
    if [ "$TYPE" != "utf-8" ] ; then
     echo $1 
    fi
    Dann auf der Console aufrufen
    Code:
    find . -type f -iname \*\.php -exec TestFile.sh {} \;
    Du erhälst dann eine Liste mit php-Dateien die nicht UTF-8 sind ab current Directory.
    Gruß FINWICK
    ↶ Danke Button nutzen, wenn es geholfen hat - Kein Suport via PN

  9. #9
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.991
    Bedankte sich
    158
    Erhielt 1.823 Danksagungen
    in 1.780 Beiträgen

    Standard

    wie machst du das?
    Eigentlich sind die Dateien (damit meine ich z.B. auch die CSS-Dateien) entsprechend codiert.
    Jedoch können ungeeignete Editoren oder eine unzutreffende Codierung ein unerwünschtes Ergebnis erzeugen.

    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  10. #10
    Neu an Board
    Registriert seit
    18.10.2016
    Beiträge
    7
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von FINWICK Beitrag anzeigen
    ...Du erhälst dann eine Liste mit php-Dateien die nicht UTF-8 sind ab current Directory.
    tja: 999.

    toll. ... ich meld mich in einer Woche wieder.
    und jetzt mit oder ohne Blob?

    mein Provider von dem ich die gezippt und hier entpackt habe, hat die Sachen auf Linux Ubuntu laufen...
    Danke,

    mmh - gibts auch so ein script, das die Dateien umcodiert - wohl eher nicht, da sich ja darin auch Zeichen ändern.

    fes

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein