+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Benötige Hilfe beim Community Builder - Login-Modul

  1. #1
    War schon öfter hier Avatar von Berndi
    Registriert seit
    20.02.2013
    Beiträge
    158
    Bedankte sich
    31
    1 Danksagung in 1 Beitrag

    Standard Benötige Hilfe beim Community Builder - Login-Modul

    Hallo Gemeinde,

    hoffentlich kann mir hier jemand helfen.

    Ich benutze Joomla 2.5.28 und den Community Builder 2.0.12

    Jetzt habe ich (seit dem upgrade des CB) das Problem, dass der redirect nach dem Login und dem Logout zu einer seltsamen URL führt.
    Diese sieht folgendermaßen aus:

    sgsn-handball.de/%05%A1%D1%D1%…1%89%85%B1%B0%B9%91%94%BC

    Das Resultat ist:
    404 Not Found
    The requested URL /¡ÑÑÀè¼½ÝÝܹ͝͸µ¡…¹‘‰…±°¹‘”¼ was not found on this server.

    Apache Server at sgsn-handball.de Port 80

    Lade ich die Seite hinterher manuell neu, hat der Login/-out auf jedenfall funktioniert.

    Ich habe bereits mehrere Lösungsansätze auf früheren CB-Versionen versucht
    - redirects manuell eingestellt
    - suchmaschinenfreundliche Links an, bzw. abgeschaltet
    - deinstalliert / reinstalliert

    Hat von Euch noch jemand eine Idee ?

    Gruß,
    Berndi
    -----------------------------------------------------------------------------------
    Merke: Planung ist der Ersatz des Zufalls durch den Irrtum.

  2. #2
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    59
    Beiträge
    18.511
    Bedankte sich
    704
    Erhielt 3.792 Danksagungen
    in 3.556 Beiträgen

    Standard

    Migration auf Joomla 3.4.5 ist notwendig, da 2.5x nicht mehr sicher ist. Ausserdem gibt es auch nuicht mehr wirklich Erweiterungen für diese mittlerweile veraltete Joomlainstallation. Also: Migrieren (Hilfe dazu findest sich oben in der "Joomla FAQ") und danach schauen, ob der Fehler überhaupt nich existent ist.


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  3. #3
    Wohnt hier Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    4.941
    Bedankte sich
    401
    Erhielt 1.737 Danksagungen
    in 1.654 Beiträgen

    Standard

    Hallo,

    dass man auf die J 3.4 upgraden sollte - ja natürlich wär mittlerweile schon sinnvoll. Heißt jedoch nicht, dass die J 2.5.28 unsicher ist

    Mir fällt auf: http://extensions.joomla.org/extensi...munity-builder da steht bei der Version 2.0.12 > Joomla 3
    Habe zwar keine changelogs dazu gesehen (Änderungen zu vorigen Versionen). Aber eben deswegen u.U. eine Rückwärtskompatibilität nicht besteht.
    Sprachdateien (Plugin dazu?) [nur auf die Schnelle geguckt] dürften auch (möglicherweise) ein update haben.

    Also ich würde doch ein Upgrade auf die J 3.4 ins Auge fassen. Und wie Axel schreibt, gibt es dazu viel Literatur ....

    Liebe Grüße, Christine

  4. #4
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    59
    Beiträge
    18.511
    Bedankte sich
    704
    Erhielt 3.792 Danksagungen
    in 3.556 Beiträgen

    Standard

    Zitat Zitat von christine2 Beitrag anzeigen
    Heißt jedoch nicht, dass die J 2.5.28 unsicher ist
    Irgendwann, vor grauer Urzeit bereits und recht nahe an der Ablösung durch die 3.0 wurde ein Sicherheitsloch in J!2.5 nachgewiesen. Das wurde von "privaten" Programmierern, also nicht vom Core-Team" gestopft. Das Problem ist nur, dass ein privater Anwender kaum eine Chance hat, den Fix zu finden. Ich selber müsste auch erst die Katakomben dieses Forums durchwühlen. Und wir beide wissen, dass die Katakomben hier sehr verwinkkelt, sehr groß und schier unübersichtlich sind - und es fraglich erscheint, ob man es je schafft aus ihnen wieder rauszukommen


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  5. #5
    Wohnt hier Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    4.941
    Bedankte sich
    401
    Erhielt 1.737 Danksagungen
    in 1.654 Beiträgen

    Standard

    Hallo Axel,

    von einer Sicherheitslücke in J 2.5.28 ist mir nichts bekannt. Was Du meinst, ist wahrscheinlich das da: http://anything-digital.com/blog/sec...o-install.html

    Wenn ein User mit einer 1.5.26 kommt, dann schiebe ich obiges nach - bevor wegen 2.5 bzw 3.4 die Rede ist.

    Übrigens: Die 3.5 steht auch schon in den Startlöchern (8.12. Stable). Der User könnte dann ja auf diese upgraden.

    Mehr: http://forum.joomla.de/index.php/Thr...la-3-5-BETA-1/

    Liebe Grüße, Christine

  6. #6
    Gehört zum Inventar Avatar von j!-n
    Registriert seit
    26.07.2007
    Ort
    RZ / EA / B
    Beiträge
    7.306
    Bedankte sich
    418
    Erhielt 1.708 Danksagungen
    in 1.590 Beiträgen

    Standard

    Hallo Axel, kannst du bitte belegen, dass die 2.5.28 unsicher ist? Danke.

    Christine *wink*
    Gruß, Chris
    Joomla kaputt? Gehackt? Migration mißlungen? Datensalat?
    www.joomla-notdienst.de - Soforthilfe & Webentwicklung
    Einsteiger- FAQ - bitte lesen!

  7. Erhielt Danksagungen von:


  8. #7
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    59
    Beiträge
    18.511
    Bedankte sich
    704
    Erhielt 3.792 Danksagungen
    in 3.556 Beiträgen

    Standard

    Zitat Zitat von j!-n Beitrag anzeigen
    Hallo Axel, kannst du bitte belegen, dass die 2.5.28 unsicher ist? Danke.
    Hallo Chris,

    ich habe nun keine Lust stundenlang im Forum rumzusuchen. Irgendwann wurde das hier mal gemeldet und damals wurde auch bekannt, dass irgendwelche Entwickler (nicht das Core-Team) einen Patch geschrieben hatten. Aber da das eben nicht mehr ofziell war, hast du entweder gewußt, wer den Patch wo veröffentlich hat oder eben nicht.
    War damals relativ früh nach dem der Support für 2.5 eingestellt wurde.

    Davon ab kann ich die Frage aber auch umdrehen: Kannst du mit Sicherheit sagen, dass 2.5 sicher ist?

    Niemand prüft das mehr ab. Ich halte es für riskant, mit Versionen noch ernsthaft rumzuhantieren, wo keiner so genau weiß, wie der Stand der Dinge ist.


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  9. #8
    Wohnt hier Avatar von WebWorker Berlin
    Registriert seit
    03.02.2013
    Ort
    Berlin
    Beiträge
    2.400
    Bedankte sich
    435
    Erhielt 502 Danksagungen
    in 447 Beiträgen

    Standard

    So lange hier keiner der Offiziellen was in der Art schreibt betrachte ich das als totalen Blödsinn. Bei 1.5 gab es das aber nicht bei 2.5. Verdient Ihr kein Geld mehr mit Joomla oder warum wird hier sowas schon zum 2. Mal behauptet.

  10. #9
    Gehört zum Inventar Avatar von j!-n
    Registriert seit
    26.07.2007
    Ort
    RZ / EA / B
    Beiträge
    7.306
    Bedankte sich
    418
    Erhielt 1.708 Danksagungen
    in 1.590 Beiträgen

    Standard

    Moin Axel, ich lese hier (und auch in anderen Quellen) täglich, da ich mein Wissen gerne auf dem aktuellen Stand halte, und weil es mein Beruf ist. Mir ist nichts darüber bekannt, dass die 2.5.28 unsicher ist. Auch international und in den Diskussionen des Joomla Teams ist nichts darüber zu finden. Und ich denke, David oder Hannes hätten das schon entsprechend publik gemacht, wenn da etwas sein sollte. Ich bin überzeugt davon, dass es noch mindestens soviele 2.5 im Netz gibt, wie 3.x, und auch davon, dass "uns" die Joomla-Oberen nicht im Ungewissen lassen, falls da wirklich etwas sein sollte.

    In einer "Panikmache" sehe ich keinen Vorteil.
    Gruß, Chris
    Joomla kaputt? Gehackt? Migration mißlungen? Datensalat?
    www.joomla-notdienst.de - Soforthilfe & Webentwicklung
    Einsteiger- FAQ - bitte lesen!

  11. Erhielt Danksagungen von:


  12. #10
    Wohnt hier Avatar von WebWorker Berlin
    Registriert seit
    03.02.2013
    Ort
    Berlin
    Beiträge
    2.400
    Bedankte sich
    435
    Erhielt 502 Danksagungen
    in 447 Beiträgen

    Standard

    Genau so ist es

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein