+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: ich auch: Kein Zugang zum Administrationsbereich dieser Website!

  1. #1
    War schon öfter hier
    Registriert seit
    23.02.2010
    Ort
    Daventry, UK
    Beiträge
    121
    Bedankte sich
    75
    Erhielt 8 Danksagung
    in 1 Beitrag

    Standard ich auch: Kein Zugang zum Administrationsbereich dieser Website!

    Hallo,

    nachdem meine Seite vor 2 Wochen gehackt wurde und ich eine Woche damit zugebracht habe, alles wieder neu aufzuspielen, kommt jetzt aus heiterem Himmel und nach ein paar Tagen einwandfreien funktionierens ohne erkennbare Ursache diese Meldung:Kein Zugang zum Administrationsbereich dieser Website!

    Also habe ich hier im Forum gesucht und folgendes bereits ausprobiert:
    Browser Cache geleert
    Cookies werden eh nicht erlaubt, sind also keine zum löschen da
    Passwort in der DB geändert
    Sessions gelöscht
    Version 2.5.7 umbenannt und 2.5.11 aufgespielt und die alte Datenbank eingespielt
    das PWreset- tool ausprobiert
    den Benutzernamen in der config.php eingefügt
    - mit anderen Worten: so ziemlich jeden Lösungsanssatz ausprobiert, der hier genannt wurde.
    Ausnahme: Neuen User angelegt - ich habe keine Ahnung wie das geht, da ich kein FE Login habe und ich alleine als User (Superuser) angelegt bin.

    Das Frontend funktioniert einwandfrei, alle Seiten werden korrekt dargestellt.

    Und jetzt weiss ich nicht mehr, was ich noch tun kann. Weiss von Euch jemand Rat?
    Ich kann doch nicht jede Woche eine komplette Neuinstallation hinlegen...

    Herzlichen Dank im Voraus!
    Flo
    Geändert von Florchen (15.06.2013 um 11:12 Uhr)
    Manche Menschen sind zu gut erzogen, um mit vollem Mund zu reden. Das hindert sie allerdings nicht, es mit leerem Kopf zu tun...

  2. #2
    Gute Seele des Boards Avatar von Orpheus2510
    Registriert seit
    17.10.2006
    Beiträge
    20.807
    Bedankte sich
    287
    Erhielt 4.976 Danksagungen
    in 4.514 Beiträgen

    Standard

    Zitat Zitat von Florchen Beitrag anzeigen
    Version 2.5.7 umbenannt und 2.5.11 aufgespielt und die alte Datenbank eingespielt
    Das dürfte dein Problem sein: die DB passt nicht zur Joomla-Version. Um das zu vermeiden, benennt man die Joomla-Version nicht einfach um, sondern installiert ein Update über den Joomla-Installer, so dass auch die DB upgedatet wird. Versuch mal eine DB-Reparatur - wenn das nicht hilft, spiel das Update vernünftig ein.

  3. #3
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.985
    Bedankte sich
    158
    Erhielt 1.819 Danksagungen
    in 1.776 Beiträgen

    Standard

    Zitat Zitat von Orpheus2510 Beitrag anzeigen
    Versuch mal eine DB-Reparatur - wenn das nicht hilft, spiel das Update vernünftig ein.
    Eine bescheidene Frage sei erlaubt: Wenn ich das richtig verstanden habe, kommt Flo gar nicht mehr ins Backend. Wie soll er da ...?
    Er hat doch wohl "nur" mit phpmyadmin gearbeitet.

    @Flo : Hast Du wirklich alle Punkte von Flottes Liste abgearbeitet (siehe FAQ 2.6). Da ist Dir vermutlich etwas "durchgerutscht".

    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  4. #4
    War schon öfter hier
    Registriert seit
    23.02.2010
    Ort
    Daventry, UK
    Beiträge
    121
    Bedankte sich
    75
    Erhielt 8 Danksagung
    in 1 Beitrag

    Standard

    Zitat Zitat von chr-hl Beitrag anzeigen
    Eine bescheidene Frage sei erlaubt: Wenn ich das richtig verstanden habe, kommt Flo gar nicht mehr ins Backend. Wie soll er da ...?
    Er hat doch wohl "nur" mit phpmyadmin gearbeitet.

    @Flo : Hast Du wirklich alle Punkte von Flottes Liste abgearbeitet (siehe FAQ 2.6). Da ist Dir vermutlich etwas "durchgerutscht".

    Christian
    So ist es, sie kommt erst gar nicht mehr ins Backend.
    Ich hab soviel versucht, dass ich das "durchrutschen" nicht ausschließen kann.

    @Orpheus: Danke, das kann natürlich auch sein, wie ist denn eine DB-Reparatur zu bewerkstelligen?

    Edit:
    Zitat Zitat von Orpheus2510 Beitrag anzeigen
    Das dürfte dein Problem sein: die DB passt nicht zur Joomla-Version. Um das zu vermeiden, benennt man die Joomla-Version nicht einfach um, sondern installiert ein Update über den Joomla-Installer, so dass auch die DB upgedatet wird. Versuch mal eine DB-Reparatur - wenn das nicht hilft, spiel das Update vernünftig ein.
    Boah, ich bin echt schon etwas matschig in der Birne. Natürlich hab ich die 2.5.11 richtig und vollständig aufgespielt. Ich hab nur vorher den Ordner mit der bis dahin aktuellen Installation umbenannt, den Ordner mit der neuen Installation dann wieder wie gehabt benannt. Und in der neuen Version hab ich dann allerdings die bestehende Datenbank verwendet. Manchmal hab ich leider Wortfindungsstörungen, tut mir leid :-(
    Ich dachte, das passt dann schon irgendwie, aber offenbar wohl nicht. Wie mach ich das denn am besten passend?
    Geändert von Florchen (09.06.2013 um 20:20 Uhr)
    Manche Menschen sind zu gut erzogen, um mit vollem Mund zu reden. Das hindert sie allerdings nicht, es mit leerem Kopf zu tun...

  5. #5
    Gute Seele des Boards Avatar von Orpheus2510
    Registriert seit
    17.10.2006
    Beiträge
    20.807
    Bedankte sich
    287
    Erhielt 4.976 Danksagungen
    in 4.514 Beiträgen

    Standard

    Zitat Zitat von Florchen Beitrag anzeigen
    So ist es, sie kommt erst gar nicht mehr ins Backend.
    Ups, das hatte ich aus dem Blick verloren.

    Zitat Zitat von Florchen Beitrag anzeigen
    Ich hab soviel versucht, dass ich das "durchrutschen" nicht ausschließen kann.
    Und dabei wahrscheinlich die Seite total verhunzt. Ich hoffe, du hast nur an einem Backup gearbeitet, so dass du noch einmal mit der Wiederherstellung von vorne beginnen kannst.

    Zitat Zitat von Florchen Beitrag anzeigen
    @Orpheus: Danke, das kann natürlich auch sein, wie ist denn eine DB-Reparatur zu bewerkstelligen?
    Klickweg: Erweiterungen - Erweiterungen - Datenbank - Reparieren. Aber dafür musst du erst einmal wieder ins Backend kommen ...

  6. Erhielt Danksagungen von:


  7. #6
    War schon öfter hier
    Registriert seit
    23.02.2010
    Ort
    Daventry, UK
    Beiträge
    121
    Bedankte sich
    75
    Erhielt 8 Danksagung
    in 1 Beitrag

    Standard

    Zitat Zitat von Orpheus2510 Beitrag anzeigen
    Ups, das hatte ich aus dem Blick verloren.


    Und dabei wahrscheinlich die Seite total verhunzt. Ich hoffe, du hast nur an einem Backup gearbeitet, so dass du noch einmal mit der Wiederherstellung von vorne beginnen kannst.


    Klickweg: Erweiterungen - Erweiterungen - Datenbank - Reparieren. Aber dafür musst du erst einmal wieder ins Backend kommen ...
    Danke schön!
    Und nein, die Seite funktioniert ja "vorne" absolut okay. Also verhunzt ist, jedenfalls was man als Besucher so sieht, nichts. Ich komm halt "nur" nicht mehr hinten rein...
    Manche Menschen sind zu gut erzogen, um mit vollem Mund zu reden. Das hindert sie allerdings nicht, es mit leerem Kopf zu tun...

  8. #7
    Wohnt hier
    Registriert seit
    14.03.2011
    Beiträge
    2.579
    Bedankte sich
    54
    Erhielt 884 Danksagungen
    in 794 Beiträgen

    Standard

    Cookies werden eh nicht erlaubt, sind also keine zum löschen da
    Das ist bei Joomla ein Fehler. Cookies sollten erlaubt sein. Sonst gibt es den berühmten Login-Loop. Hat aber ursächlich nichts mit deinem Problem zu tun. (Glaube ich. Mal mit Cookies probieren kann nicht schaden.)

    da ich kein FE Login habe und ich alleine als User (Superuser) angelegt bin.
    Das verstehe ich nicht.

    Zu Deinem Problem.
    Es gibt nur eine Situation in Joomla, wo dieser Fehler angezeigt wird. Die sich anmeldende ist nicht in der richtigen Benutzergruppe. Also einen Versuch wert:

    Das "ABC" im Folgenden musst du durch den Präfix deiner Datenbank ersetzen, also z.B. durch "jos".

    - Gehe in deine Datenbank per phpMyAdmin. Bei manchen Providern muss man sie erst durch Klick oder Auswahlfeld explizit auswählen. Das ist v.a. wichtig für den Schritt "SQL" unten.

    - Prüfe in der Tabelle ABC_usergroups, ob mit ID 8 die Gruppe "Super Users" existiert. Wenn nicht, abbrechen. Bescheid geben.

    - Gehe in deine Datenbank.

    - Prüfe in der Tabelle ABC_users, ob es noch KEINEN User mit ID 555 gibt. Falls DOCH, merke dir eine ID, die es noch nicht gibt. Eine, die größer als 300 ist.

    - Klicke dann auf Tabulator "SQL".
    - Paste folgenden Code in das Feld.
    - Ändere, falls nötig die 2 vorkommenden "555" in die ID, die du dir oben gemerkt hast (ABC_users).
    - Ändere die 2 vorkommenden "ABC" in deinen Datenbank-Präfix.
    - Klicke "OK" und hoffe...
    - Wenn kein Fehler angezeigt wird, melde dich mit 2x "florchenxyz" an und hoffe wieder...
    - Falls es klappt, vergiss nicht den neuen Super User anzupassen, neues Passwort un v.a. noch mal speichern.

    Code:
    INSERT INTO `ABC_users`
    
    (`id`, `name`, `username`, `email`, `password`, `usertype`, `block`, `sendEmail`,
    `registerDate`, `lastvisitDate`, `activation`, `params`, `lastResetTime`, `resetCount`)
    
    VALUES
    
    (555,
    'florchenxyz', 'florchenxyz', 'florchenxyz@web.de',
    '3e0ed17099d9be78ffc0e7afb561d5ef',
    '', 0, 0, '2013-06-09 23:56:08', '0000-00-00 00:00:00', '', '{"admin_style":"","admin_language":"","language":"","editor":"","helpsite":"","timezone":""}',
    '0000-00-00 00:00:00', 0);
    
    INSERT INTO `ABC_user_usergroup_map`
    
    (`user_id`, `group_id`)
    
    VALUES
    
    (555, 8);
    Geändert von illovo (10.06.2013 um 01:44 Uhr)

  9. Erhielt Danksagungen von:


  10. #8
    War schon öfter hier
    Registriert seit
    23.02.2010
    Ort
    Daventry, UK
    Beiträge
    121
    Bedankte sich
    75
    Erhielt 8 Danksagung
    in 1 Beitrag

    Standard

    Hallo Ilovo,
    zunächst ein dickes Danke für die Anleitung.
    Was soll ich sagen... dat war ein Satz mit X...*seufz*
    Es gab wie gesagt keine anderen User ausser mir. Das ist nur eine "Anguck"-Seite, keine "Mitmach"-Seite. Und mein SuperUser hat die ID 42, also war die 555 kein Thema.
    Ich hab dann, wie du gesagt hast, den Code eingefügt, ABC in das entsprechende Präfix geändert, geklickt, gehofft, und - gewonnen!
    florchenxyz war als User mit ID 555 angelegt.
    Aber beim Einloggen kam dann prompt wieder: Kein Zugang zum Administrationsbereich dieser Website!
    Es ist doch wahrlich zum Verrückt werden...
    Nur, damit ich es richtig verstehe:
    Der Fehler liegt jetzt irgendwo im Ordner administrator? Und wenn ich jetzt die 2.5.11 neu aufspiele - kann ich dann gefahrlos die "alten" Ordner mit Menüs, Inhalten etc. wieder rüberschaufeln? Ich frag nur, weil DIE ja noch Version 2.5.7 sind...
    Oder gibt es noch etwas, das ich ausprobieren kann?
    Ich sage schon mal herzlichen Dank für jeden weiteren Rat!
    Manche Menschen sind zu gut erzogen, um mit vollem Mund zu reden. Das hindert sie allerdings nicht, es mit leerem Kopf zu tun...

  11. #9
    Gehört zum Inventar
    Registriert seit
    16.08.2006
    Beiträge
    8.516
    Bedankte sich
    1.429
    Erhielt 2.078 Danksagungen
    in 1.905 Beiträgen

    Standard

    Zitat Zitat von Florchen Beitrag anzeigen
    s die "alten" Ordner mit Menüs, Inhalten etc. wieder rüberschaufeln?
    Hi,

    lies lieber noch einiges über die Joomla-Grundlagen (Stichworte: Datenbank, Inhalte, ...). Die FAQ oben im Menü hilft Dir weiter.

    hth

    albatros

  12. #10
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.985
    Bedankte sich
    158
    Erhielt 1.819 Danksagungen
    in 1.776 Beiträgen

    Standard

    Hallo,

    nach meinem Verständnis solltest Du eine "saubere" 2.5.7-Version mit Deiner DB zum Laufen bringen.
    Hier gibt es die "Zutaten".
    Dann Kannst Du dich anschließend um die erforderlichen Updates kümmern.

    Und das Ganze lokal mit xampp!
    Der anschließende Umzug auf den Webserver ist das ein Kinderspiel.


    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  13. Erhielt Danksagungen von:


+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein