+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Fehlermeldung: Strict standards: Only variables should be assigned by reference in C:

  1. #1
    Neu an Board
    Registriert seit
    04.01.2013
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard Fehlermeldung: Strict standards: Only variables should be assigned by reference in C:

    Hi und frohes neues Jahr an alle.

    Ich weiss es gibt mehrere threats ueber dieses Problem, keins davon half mir aber weiter.
    Ich such schon seit 2 Tagen nach einer loesung, aber auf allen Foren sprach man von
    php.ini -> display_errors auf Off und
    error_reporting auf E_ALL zu stellen oder
    unter Joomla -> Global Config. -> Server -> Error Reporting = NONE.

    Hab die alle ausprobiert, Server neue gestartet und bekomme immer noch die gleiche Fehlermeldung.
    Ich benutze
    Joomla 2.5.8
    WAMPSERVER 2.2
    add on: Simple File Upload 1.3.5 (das add on dass mir die Probleme bereitet)


    Code:
    SCREAM: Error suppression ignored for
    Strict standards: Only variables should be assigned by reference in C:\WAMP\wamp\www\Joomla\modules\mod_simplefileuploadv1.3\tmpl\default.php on line 15
    Call Stack
    #	Time	Memory	Function	Location
    1	0.0003	156808	{main}( )	..\index.php:0
    2	0.0860	3237168	JSite->dispatch( )	..\index.php:42
    3	0.0925	3449488	JComponentHelper::renderComponent( )	..\application.php:197
    4	0.0967	3473536	JComponentHelper::executeComponent( )	..\helper.php:351
    5	0.0970	3493456	require_once( 'C:\WAMP\wamp\www\Joomla\components\com_content\content.php' )	..\helper.php:383
    6	0.1030	3735168	JController->execute( )	..\content.php:16
    7	0.1030	3735312	ContentController->display( )	..\controller.php:761
    8	0.1125	4231664	JController->display( )	..\controller.php:74
    9	0.1209	4638768	ContentViewArticle->display( )	..\controller.php:722
    10	0.1389	5067480	JDispatcher->trigger( )	..\view.html.php:123
    11	0.1389	5067992	JEvent->update( )	..\dispatcher.php:161
    12	0.1389	5068512	call_user_func_array ( )	..\event.php:71
    13	0.1389	5068536	plgContentLoadmodule->onContentPrepare( )	..\event.php:71
    14	0.1390	5069776	plgContentLoadmodule->_load( )	..\loadmodule.php:61
    15	0.1430	5194336	JDocumentRendererModule->render( )	..\loadmodule.php:105
    16	0.1433	5201680	JModuleHelper::renderModule( )	..\module.php:107
    17	0.1462	5295656	include( 'C:\WAMP\wamp\www\Joomla\modules\mod_simplefileuploadv1.3\mod_simplefileuploadv1.3.php' )	..\helper.php:175
    18	0.1510	5578928	require( 'C:\WAMP\wamp\www\Joomla\modules\mod_simplefileuploadv1.3\tmpl\default.php' )	..\mod_simplefileuploa
    Jemand eine Idee woran das liegen kann oder wie man das beheben kann ?

    Dankbar fuer jeden Vorschlag,
    leftycool
    Geändert von leftycool (06.01.2013 um 16:45 Uhr)

  2. #2
    Wohnt hier
    Registriert seit
    14.03.2011
    Beiträge
    2.580
    Bedankte sich
    54
    Erhielt 885 Danksagungen
    in 795 Beiträgen

    Standard

    error_reporting auf E_ALL zu stellen
    E_ALL zeigt, wie der Name schon sagt, alles.

    E_NONE schaltet alles ab.

    error_reporting = E_ALL & ~E_NOTICE | E_STRICT
    zeigt nur Errors, aber nicht Notice oder Strict-Standard-Meldungen.

  3. #3
    Joomla Guru Avatar von elkuku
    Registriert seit
    14.06.2006
    Ort
    Guayaquil - GMT -5 ~ 40ºC
    Beiträge
    2.183
    Bedankte sich
    92
    Erhielt 667 Danksagungen
    in 515 Beiträgen

    Standard

    Und dann hast Du wohl auch noch die scream extension aktiviert... Das kann Joomla! auch noch nicht ab. Schau mal in der php.ini nach "scream"
    Gruß,
    Nikolai
    Hilf mit: Deutsche Joomla! Dokumentation | Help testing: EasyCreator | Noch Fragen ? Forum.Joomla-Nafu.de | Steigere Dein Joomla! Level

  4. #4
    Neu an Board
    Registriert seit
    04.01.2013
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Hi und danke fuers antworten.
    Hab alles auf E_NONE geschaltet, half trozdem nicht:
    Code:
    ; error_reporting
    ;   Default Value: E_NONE
    ;   Development Value: E_NONE
    ;   Production Value: E_NONE
    Ich verstehe nicht wie das sein kann. Ich sollte jetzt alle Meldungen abgeschaltet haben und trotzdem bekomme ich welche.
    Gibt es eine andere moeglichkeit die wir nicht bedacht haben um die Meldungen abzuschalten oder zu ignorieren ?


    @elkuku
    in der php.ini ist, laut der Suchfunktion, kein "scream" vorhanden.

    Dankbar fuer jeden Vorschlag,
    leftycool

  5. #5
    Wohnt hier
    Registriert seit
    14.03.2011
    Beiträge
    2.580
    Bedankte sich
    54
    Erhielt 885 Danksagungen
    in 795 Beiträgen

    Standard

    Was sagt denn Joomla unter Systeminformationen zu deinen Änderungen. Werden andere Änderungen dort angezeigt. Bspw. php.ini. Je nach Servereinrichtung gibt es eine Masterdatei, evtl. eine überschreibende in deinem Webspace. Zusätzlich können PHP-Einstellungen in den htaccess-Dateien gesetzt sein.
    Außerdem sind in deinem geposteten Code nur Kommentare. Das sind keine Einstellungen. Das Semikolon vor der Zeile ist ein Kommentarzeichen, also nur Beschreibung.
    Heißt du musst eine Zeile so einsetzen, die wirken soll:

    Code:
    error_reporting = E_ALL & ~E_NOTICE | E_STRICT
    Und sie darf in der php.ini kein 2. mal drunter vorkommen. Sonst wird sie wieder überschrieben.

    http://www.bytecamp.net/downloads/1361/php.ini
    Geändert von illovo (05.01.2013 um 19:02 Uhr)

  6. #6
    Neu an Board
    Registriert seit
    04.01.2013
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Zitat Zitat von illovo Beitrag anzeigen
    Was sagt denn Joomla unter Systeminformationen zu deinen Änderungen. Werden andere Änderungen dort angezeigt.
    Ne da steht immer noch Display Errors: On.
    Was die Semikolons angeht, da hattest du recht. Weiter unten in der Datei, gab es die gleichen Einstellungen nochmals und zwar ohne Semikolon.
    Die hab ich jetzt auch bearbeitet und
    error_reporting = E_NONE
    display_errors = Off
    eingestellt. Dachte das wuerde mein Problem beheben, hab mich aber eines besseren belehren lassen.
    error_reporting = E_ALL & ~E_NOTICE | E_STRICT
    half auch nicht weiter.

    Das Problem liegt anscheinend dass jommla die aenderungen in der php.ini Datei nicht bemerkt oder akzeptieren will.
    Muss man die Masterdatei oder die htaccess-Dateien jetzt aendern ?
    Ich kenn mich leider mit diesen Dateien nicht aus bzw. weiss nicht welche die sind und was ich da aendern muss.

  7. #7
    Gehört zum Inventar Avatar von Helrunar
    Registriert seit
    05.03.2006
    Ort
    /home/helrunar/Webdev
    Beiträge
    8.599
    Bedankte sich
    958
    Erhielt 2.182 Danksagungen
    in 1.928 Beiträgen

    Standard

    Hast Du den auch den apachen neu gestartet?

  8. #8
    Neu an Board
    Registriert seit
    04.01.2013
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Ja, hab ich gemacht

  9. #9
    Gehört zum Inventar Avatar von Helrunar
    Registriert seit
    05.03.2006
    Ort
    /home/helrunar/Webdev
    Beiträge
    8.599
    Bedankte sich
    958
    Erhielt 2.182 Danksagungen
    in 1.928 Beiträgen

    Standard

    Setz mal am Anfang (direkt nach dem öffnenden <?php) in der index.php folgendes

    error_reporting(0);

  10. Erhielt Danksagungen von:


  11. #10
    Wohnt hier
    Registriert seit
    14.03.2011
    Beiträge
    2.580
    Bedankte sich
    54
    Erhielt 885 Danksagungen
    in 795 Beiträgen

    Standard

    Werden andere Änderungen dort angezeigt.
    Das meinte ich so. Wenn Du einen der anderen Werte änderst, also nicht error_reporting, ob du diese anderen Änderung in Joomla dann siehst.
    Als Beleg dafür, dass Du in der richtigen php.ini bist.

    Bspw. zum Test mal ein:

    upload_max_filesize=5M

    Vorher nachher vergleichen.

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein