+ Antworten
Seite 2 von 2 ErsteErste 1 2
Ergebnis 11 bis 20 von 20

Thema: Nach Einloggen ist das Backend leer

  1. #11
    Gesperrt
    Registriert seit
    19.07.2007
    Beiträge
    2.317
    Bedankte sich
    416
    Erhielt 411 Danksagungen
    in 362 Beiträgen

    Standard

    Ganz einfach weil es immer Vereine, Freunde etc sind bei dir. Das du das Ganze für Kohle machst geht hier mitlerweile schon per PN durch die Reihen. Warum ist der Link nicht in deiner Signatur ? Ne geheime Firma die keiner kennen soll ?

    Ein Danke nochmal an den Absender.

  2. #12
    Hat hier eine Zweitwohnung Avatar von dette
    Registriert seit
    02.12.2010
    Ort
    Bonn
    Beiträge
    1.352
    Bedankte sich
    713
    Erhielt 43 Danksagungen
    in 42 Beiträgen

    Standard

    Wie bitte? Ich bin dir zwar keine Rechenschaft schuldig und beweisen kann ich es auf dieser Plattform auch nicht, aber ich habe bisher 4 webseiten gemacht. 2 für mich, eine für meine Freundin und nun die für den Verein. Für keine Seite habe ich Geld bekommen.

    Dass ich in Zukunft sehr gerne webseiten für Geld gestalten würde, stimmt, aber erst, wenn ich mehr Ahnung habe. Ich hatte auch eine webseite vorsorglich dafür gebastelt, aber diese ist noch nicht auf einer domain, da ich einfach noch zu wenig Ahnung habe. Ich weiß auch nicht, ob ich es jemals schaffe, so viel Ahnung zu haben wie du und die anderen hier im Forum. Ich bin eben noch ganz am Anfang.

    Ich verstehe ehrlich gesagt nicht, wie es per PN herumgeht, dass ich Geld für meine Webseiten nehme, obwohl es gar nicht stimmt. Wenn es mal soweit ist, werde ich es im Forum offiziell bekannt geben - versprochen.
    Liebe Grüße
    dette

  3. #13
    httpd
    Gast

    Standard

    Zum Problem der weißen Seite:

    Wie du schon in einem Link lesen konntest, ist es häufig auf Fehler zurückzuführen.
    Diese gilt es anzuzeigen um sie auszuwerten. Das geht auch wenn du keinen direkten Zugriff auf Dateien des Servers hast.

    Methode 1 (in deinem Fall ganz am Anfang der index.php im Verzeichnis ../administrator einfügen, direkt nach dem beginneden <?php)
    Code:
    <?php
    error_reporting(E_ALL);
    ini_set('display_errors','On');
    Das Rote steht schon drin


    O D E R

    du legts eine Datei .htaccess im Verzeichnis ../administrator an. Da sollte dann nur das drinstehen:
    Code:
    php_flag display_errors on
    php_value error_reporting -1
    Mit der ersten oder der zweiten Lösung solltest du die Fehler angezeigt bekommen und sie dann ausmerzen können.

  4. Erhielt Danksagungen von:


  5. #14
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.239
    Bedankte sich
    431
    Erhielt 1.865 Danksagungen
    in 1.773 Beiträgen

    Standard

    @ httpd,

    in Ergänzung wollte ich Dich fragen: Könnte es vielleicht helfen i.d. DB nach einer "viewlevels" zu schauen (IDs) wie das dort aussieht?
    Stichwort: SuperUser Berechtigung vielleicht 'ausgesperrt'.

    Gruß, Christine

  6. Erhielt Danksagungen von:


  7. #15
    httpd
    Gast

    Standard

    Zitat Zitat von christine2 Beitrag anzeigen
    ....in Ergänzung wollte ich Dich fragen: Könnte es vielleicht helfen i.d. DB nach einer "viewlevels" zu schauen ....
    Da berichtet wurde zuvor funktionierende Datenbankinhalte eingesetzt zu haben, schließe ich diese Variante zunächst aus. Ich tippe eher in andere Richtung. Aber mal abwarten.

  8. #16
    Hat hier eine Zweitwohnung Avatar von dette
    Registriert seit
    02.12.2010
    Ort
    Bonn
    Beiträge
    1.352
    Bedankte sich
    713
    Erhielt 43 Danksagungen
    in 42 Beiträgen

    Standard

    vielen Dank httpd für deine Hilfe.

    Zitat Zitat von httpd Beitrag anzeigen
    Zum Problem der weißen Seite:

    Wie du schon in einem Link lesen konntest, ist es häufig auf Fehler zurückzuführen.
    Diese gilt es anzuzeigen um sie auszuwerten. Das geht auch wenn du keinen direkten Zugriff auf Dateien des Servers hast.

    Methode 1 (in deinem Fall ganz am Anfang der index.php im Verzeichnis ../administrator einfügen, direkt nach dem beginneden <?php)
    Code:
    <?php
    error_reporting(E_ALL);
    ini_set('display_errors','On');
    Das Rote steht schon drin


    O D E R

    du legts eine Datei .htaccess im Verzeichnis ../administrator an. Da sollte dann nur das drinstehen:
    Code:
    php_flag display_errors on
    php_value error_reporting -1
    Mit der ersten oder der zweiten Lösung solltest du die Fehler angezeigt bekommen und sie dann ausmerzen können.
    Nach Variante 1 bekam ich keine Fehlermeldung, sondern wieder nur die weisse Seite. Oder müsste ich die Fehlermeldung woanders suchen.

    Da ich davon ausgehe, dass die Fehlermeldung auf der weissen Seite steht, habe ich die 2. Variante ausprobiert, aber leider gibt es nun ein weiteres Problem, was den ganzen Tag noch nicht bestand. Wenn ich eine Datei hochladen will, wie jetzt die .htaccess, kommt diese Fehlermeldung.

    Befehl: TYPE A
    Antwort: 200 Type set to A
    Befehl: PASV
    Antwort: 227 Entering Passive Mode (80,237,132,84,204,133).
    Befehl: STOR .htaccess
    Antwort: 550 .htaccess: Permission denied
    Fehler: Kritischer Dateiübertragungsfehler

    Jede andere Datei ist aber auch nicht hochladbar. Bis vorhin konnte ich alles hochladen. O.K. hat jetzt nichts mit dem ersten Problem zu tun, aber ich komme so nicht weiter. Vor allem habe ich jetzt Angst, wenn ich alles lösche und Joomla neu installieren will, dass ich auch die joomla-Dateien nicht hochladen kann.

    Könnte das zweite Problem jetzt etwas mit dem ersten zu tun haben oder ist das einfach nur Zufall?

    Edit:

    danke auch dir Christine für deinen tipp. Ich probiere das nachher mal aus, aber im Moment versuche ich erst mal den Hinweis von httpd zu verfolgen.
    Liebe Grüße
    dette

  9. #17
    httpd
    Gast

    Standard

    Kannst du einmal in deinem FTP-Client die Rechte des Verzeichnisses ../administrator nachsehen und hierher posten?
    Bitte keine Rechte ändern, nur nachsehen wie diese eingestellt sind.

  10. #18
    Hat hier eine Zweitwohnung Avatar von dette
    Registriert seit
    02.12.2010
    Ort
    Bonn
    Beiträge
    1.352
    Bedankte sich
    713
    Erhielt 43 Danksagungen
    in 42 Beiträgen

    Standard

    die Rechte sind 750. Ein supporter von Hosteurope meinte heute Nachmittag, dass es an den Dateiberechtigungen liegt und dann sollte ich von ftp auf wp ändern und eine viertel Stunde warten. Danach wurde es aber nicht besser. Zu der Zeit konnte ich aber noch alle Ordner hochladen. Später sprach ich mit einem Kollegen bei Hosteurope und der meinte, das 750 ausreicht.

    Gerade probierte ich nochmal den ganzen administrator-Ordner hochzuladen und da kam keine Fehlermeldung oder sie rannte so schnell durch, dass ich sie nicht sehen konnte. die .htaccess lässt sich immer noch nicht hochladen und index.php auch nicht. Aber die Dateiberechtigungen habe ich heute mittag nicht geändert. Ich war gar nicht mehr in filezilla. Heute morgen hatte ich joomla installiert und die Seite von xampp nach oben geschoben. Da lief alles noch. Allerdings erschien der 500 Fehler. Daraufhin habe ich das Passwort neu gesetzt und und ich kam ins backend bis Mittag. Ich habe ein paar Stunden darin gearbeitet und dann bei erneuten einloggen kam die weisse Seite. Also keine Dateiberechtigungsänderungen, außer im backend. Ich kann ja mal in der Datenbank schauen, was Christine geschrieben hat- wegen ausgesperrt.

    Edit:

    Es ist geschafft. Christine hatte Recht. Ich habe mich ausgesperrt. Ich weiß zwar nich wie, aber irgendwie muss es passiert sein, als ich für drei User noch einen besonderen Zugriff angelegt habe. Ich bin ja SuperUser und habe alle haken drinnen und die anderen eben drei andere Haken. Nun habe ich in der Datenbank statt 3,4,5 noch die 1 und 2 dazu genommen und nun komme ich ins Backend.

    TAusen Dank dir Christine und natürlich auch dir Httpd
    Geändert von dette (18.06.2012 um 19:53 Uhr)
    Liebe Grüße
    dette

  11. #19
    httpd
    Gast

    Standard

    Die Aussperrung halte ich derzeit für nicht gegeben, aber natürlich kannst du nachsehen.
    Kennst du diesen Text, kannst ihn verstehen und entsprechend agieren? -> http://faq.hosteurope.de/view.php?mo...ontent_id=6800

  12. Erhielt Danksagungen von:


  13. #20
    Hat hier eine Zweitwohnung Avatar von dette
    Registriert seit
    02.12.2010
    Ort
    Bonn
    Beiträge
    1.352
    Bedankte sich
    713
    Erhielt 43 Danksagungen
    in 42 Beiträgen

    Standard

    ja nach dem www****n Problem hatte ich heute nachmittag schon geschaut, weil ich das kenne. Das hätte es natürlich gut sein können. Aber nun bin ja zum Glück im Backend. Ich habe noch nichts probiert, weil ich erst mal schnell hier im Forum antworten wollte, um euch unnötig Zeit zu rauben. ich hoffe nun von ganzem Herzen, dass nun alles in Ordnung ist.

    Edit:

    So bin jetzt alles durch und es scheint alles zu funktionieren. Ich dachte eigentlich, ich könne abschließen erklären, was der Grund für das ganze Schlamassel war, aber ich weiß es nicht. Ich hatte mittags eine weitere zugewiesene Gruppe erstellt für die drei anderen Nutzer. Da der SuperUser ja sowieso auf alles Zugriff hat, habe ich da keinen Haken reingesetzt. Ich dachte vorhin, dass dies mein Fehler war. Aber nachdem ich nun in der datenbank unter viewlevels die Zahlen 1 und 2 zugefügt habe, hat sich das im Backend nicht geändert. Ansonsten wüsste ich nichts, was ein Grund gewesen sein könnte, dass ich mich ausgesperrt habe.

    Falls jemanden spontan einfällt, was der Grund gewesen sein könnte, dann würde das wahrscheinlich auch anderen für die zukunft weiterhelfen.
    Geändert von dette (18.06.2012 um 20:26 Uhr)
    Liebe Grüße
    dette

+ Antworten
Seite 2 von 2 ErsteErste 1 2

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein