+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Fehler bei Beiträge einreichen im Frontend

  1. #1
    Neu an Board Avatar von wendland1965
    Registriert seit
    09.10.2011
    Ort
    24899 Wohlde
    Beiträge
    11
    Bedankte sich
    2
    Erhielt 34 Danksagungen
    in 4 Beiträgen

    Standard Fehler bei Beiträge einreichen im Frontend

    Moin moin an die Foren-Gemeinde.

    Ich habe folgendes Problem, das ich mir nicht erklären kann:

    Möchte ich (oder einer meiner Portal-User) einen Beitrag über das Frontend einreichen, erscheint die Fehlermeldung:

    "Keine Berechtigung zum Anlegen neuer Datensätze"

    Ich habe Joomla 1.7.1 installiert, Der Menüpunkt mit der Zugriffsebene "Registriert" und die Rechtevergabe ist korrekt angelegt.

    Der Fehler betrifft alle Benutzergruppen - auch mich als Super-User - und nur das Einreichen von Artikeln. Das Einreichen von Links und Veranstaltungen über JEvent funktioniert entsprechend der Rechtevergabe.

    Hat jemand eine Idee, wo die Ursache liegen kann und wie ich dies behebe?

    Ich danke schon einmal im Voraus.

  2. Erhielt Danksagungen von:

    jmz

  3. #2
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    60
    Beiträge
    19.296
    Bedankte sich
    746
    Erhielt 3.933 Danksagungen
    in 3.693 Beiträgen

    Standard

    Duz brauchst mindestens Autorenrechte, um Beiträge einreichen zu können.


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  4. #3
    Neu an Board Avatar von wendland1965
    Registriert seit
    09.10.2011
    Ort
    24899 Wohlde
    Beiträge
    11
    Bedankte sich
    2
    Erhielt 34 Danksagungen
    in 4 Beiträgen

    Standard

    Moin Axel,

    danke für Deine Rückmeldung, aber das ist mir schon klar und alles ist so eingestellt - Alle Benutzer als Autor oder höher; Autoren haben Rechte "Erstellen" "Eigene Beiträge bearbeiten" und auf der Seite anmelden aktiviert. Dies sowohl in den globalen Einstellungen als auch bei den Beiträgen (da das Problem wie gesagt ja "nur" die Artikel betrifft, habe ich hier zuerst geschaut). Alles richtig eingestellt.

    Zugriffsebene für den Menüpunkt "Beitrag einreichen" ist auf registriert gesetzt und in der Benutzerverwaltung sind dieser Zugriffsebenen die Gruppen Autoren und höher zugewiesen.

    Von den ACL-Einstellungen sollte eigentlich alles ok sein. Oder gibt es noch einen gravierenden Unterschied zu den Einstellungen in 1.6 ? Ich hatte vorher Joomla 1-6 laufen und habe vorige Woche auf 1.7 umgestellt. Um auf Nummer sicher zu gehen, habe ich 1.7 komplett neu installiert und die Datenbank importiert.

    Meiner Meinung nach kann es eigentlich auch nichts mit den Rechteeinstellungen zu tun haben, da Weblinks und Veranstaltungen (mit den gleichen Rechtevergaben) einwandfrei funktionieren. Auch das Bearbeiten bestehender Artikel geht über das Frontend.

    Hast Du noch eine Idee, wo sich da der Fehler eingeschlichen haben könnte? Ich hänge mal Screenshots der Fehlermeldung und Rechteeinstellunen an.
    Angehängte Grafiken

  5. #4
    Neu an Board Avatar von wendland1965
    Registriert seit
    09.10.2011
    Ort
    24899 Wohlde
    Beiträge
    11
    Bedankte sich
    2
    Erhielt 34 Danksagungen
    in 4 Beiträgen

    Standard

    Hallo Leute, der "Sündenbock" war die Content Builder Komponente, wie ich nach fast zwei schlaflosen Nächten festgestellt habe. Da hatte ich früher mal schon kurz eine Ahnung, habe ihn aber leider nur aktiviert statt deinstalliert.

    Joomla neu installiert, gleicher Fehler. Bis ich jede Tabelle der DB separat importiert hatte. So habe ich jetzt eine Neuinstallation, alles läuft wieder - hätte ich aber einfacher haben können.

    Hat jemand von Euch eine nachvollziehbare Erklärung für diese Problematik? Ich hab im Moment keine. Oder ähnliche Erfahrungen. Nutzt jemand Joomla 1.7 mit dem Content Builder?

    Ich finds eigentlich schade, weil ich mich von der Bedienung her gerade mit ihm anfreunden wollte.

    Falls von Euch noch keiner diese Konstellation hatte, kann ich ja mal mit dem Support Kontakt aufnehmen und wenn es ein Ergebnis bringt, hier posten.

    Bis dahin Grüße aus dem Norden
    Olaf Wendland

  6. Erhielt Danksagungen von:


  7. #5
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    60
    Beiträge
    19.296
    Bedankte sich
    746
    Erhielt 3.933 Danksagungen
    in 3.693 Beiträgen

    Standard

    Ich habe zufälligerweise den Content Builder gestern Abend bei mir installiert und wolte mich auch gerade mit ihm anfreunden. Und hatte dann plötzlich den gleichen Effekt, wie du ihn beschrieben hast. Offenbar ist der noch nicht ausgereift. Wenn ich mich schwach erinnere, steht auch eine entsprechende Mitteiklung beim Download der Kumponente. Also werde ich das auch wieder deinstallieren und eine der anderen Möglichkeiten ausprobieren. Das einzigste, was du noch machen kannst an dieser Stelle, ist, den Entwickler zu kontaktieren. Da ich kein Englsch kann, überlasse ich das mal dir


    Axel
    Schulungen, Webentwicklung: time4mambo
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    Kein Support per PM!

  8. #6
    Neu an Board Avatar von wendland1965
    Registriert seit
    09.10.2011
    Ort
    24899 Wohlde
    Beiträge
    11
    Bedankte sich
    2
    Erhielt 34 Danksagungen
    in 4 Beiträgen

    Standard

    Hallo Axel,

    geteiltes Leid ist halbes Leid ;o)

    Ich habe über die Website des Entwicklers mit Broken English versucht das Problem zu schildern - mal sehen, was ich da für eine Resonanz bekomme. Ich halte Dich hier auf dem Laufenden.

    Was fällt Dir denn als erstes für eine Alternative zum Content Builder ein? Mir ging es in erster Linie darum, dass sich Vereine und Unternehmen in unserem Portal Stapelholm.info eintragen sollten und diese dann direkt in die Datenbank fließen und im Portal erscheinen sollten.

    Ich habe mich bereits angefangen mit mehreren CCK auseinanderzusetzen, aber so richtig bin ich da noch nicht auf den richtigen Nenner gekommen. Für die Beiträge selbst wollte ich eigentlich die Joomla-Struktur behalten.

    Viele Grüße aus dem Norden
    Olaf

  9. #7
    Neu an Board Avatar von wendland1965
    Registriert seit
    09.10.2011
    Ort
    24899 Wohlde
    Beiträge
    11
    Bedankte sich
    2
    Erhielt 34 Danksagungen
    in 4 Beiträgen

    Daumen hoch Lösung gefunden

    Hallo Axel und alle anderen Interessierten,

    es hat mir keine Ruhe gelassen und ich habe zu dem genannten Problem die Lösung gefunden. Da bei der Installation des ContentBuilders eine Reihe Plugins installiert werden, kam mir jetzt nach langem mal die Idee, diese nach und nach durchzugehen.

    Und siehe da: Im Plugin "ContentBuilder System" gibt es in den Parametern rechts die Option "Disable Joomla built-in article submission" . Diese ist nach der Installation mit "Yes" aktiviert und muss auf "NO" gestellt werden.

    Damit funktioniert das Einreichen von Beiträgen durch die User wie gewohnt.

    Viele Grüße aus dem Norden
    und allen einen schönen Sonntag

    Olaf Wendland
    Geändert von wendland1965 (15.10.2011 um 23:16 Uhr)

  10. Erhielt Danksagungen von:


  11. #8
    Neu an Board
    Registriert seit
    16.02.2008
    Alter
    40
    Beiträge
    51
    Bedankte sich
    33
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo,

    ich habe wahrscheinlich nach der Installation vom Content Builder das Problem das die Beiträge von den Usern außer Super User nicht mehr im Frontend erscheinen, kann mir jemand sagen wie ich den Content Builder ganz weg bekomme von meinem Server? Deinstalliert habe ich den schon!

  12. #9
    Gute Seele des Boards Avatar von Indigo66
    Registriert seit
    30.10.2007
    Ort
    127.0.0.1/htdocs/eu/de/muc/home.html
    Alter
    51
    Beiträge
    18.709
    Bedankte sich
    582
    Erhielt 5.610 Danksagungen
    in 5.409 Beiträgen

    Standard

    Durchsuche die DM in der Tabelle extensions ob es da noch Überreste gibt und auch vie FTP in den Verzeichnissen components modules und plugins.

  13. Erhielt Danksagungen von:


  14. #10
    Neu an Board
    Registriert seit
    16.02.2008
    Alter
    40
    Beiträge
    51
    Bedankte sich
    33
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Einfach die Ordner mit Content Builder löschen?

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein