+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 30

Thema: Kein Zugang zum Administrationsbereich dieser Website!

  1. #1
    Neu an Board
    Registriert seit
    07.06.2011
    Beiträge
    3
    Bedankte sich
    2
    1 Danksagung in 1 Beitrag

    Standard Kein Zugang zum Administrationsbereich dieser Website!

    Liebe Joomla-Experten,

    ich bin Anfänger. Ich habe keine Programmierkenntnisse. Bitte helft mir.

    Folgendes Problem:

    Plötzlich (<- das bedeutet, es hat bisher funktioniert und es gibt keine ersehbare Ursache wie aktuelle Änderungen, etc.) kann ich mich im Backend meines Auftritts nicht mehr anmelden.

    Es kommt die Meldung: "Kein Zugang zum Administrationsbereich dieser Website!"

    Passwort und Nutzer sind 100% korrekt, ebenso wie die Einstufung als Administrator. Wäre das Passwort vertippt oder falsch käme die Meldung:
    "Benutzername und Passwort falsch oder das Benutzerkonto existiert noch nicht!"

    Das habe ich bereits erfolglos versucht:

    - Browser-Cache gelöscht
    - über phpMyAdmin in die Liste jos_users das Passwort auf 21232f297a57a5a743894a0e4a801fc3 geändert
    - bei usertype "Super Administrator" reingeschrieben

    Zwar ist mein altes Passwort jetzt geändert, aber selbst mit dieser Grundeinstellung kommt immer noch die Meldung
    "Kein Zugang zum Administrationsbereich dieser Website!"

    Es sind bereits über 30 Manuskriptseiten in dem Auftritt mit Bildern hinterlegt. Ich würde die Joomla-Installation nur sehr ungern komplett platt machen.

    Was ich nicht verstehe: Wie kann es dazu überhaupt kommen, ich habe an den Nutzereinstellungen beim letzten LogIn gar nichts verändert. Wie könnte ich so etwas denn in Zukunft verhindern?

    Wie bekomme ich jetzt Zugang zum Backend als Administrator?

    Zwar habe ich hier drin gesucht, aber nichts passendes gefunden. Sollte ich einen Thread übersehen haben, bitte ich um Nachsicht.

    Ich bin Euch für Eure Antworten und Hilfestellungen wirklich sehr dankbar.

    Viele Grüße
    Beginnerz

    Übrigens: Ich nutze Joomla 1.6
    Geändert von beginnerz (07.06.2011 um 16:02 Uhr)

  2. #2
    Kommt häufiger vorbei Avatar von Ethlaegil
    Registriert seit
    15.12.2008
    Ort
    Oldenburg
    Alter
    44
    Beiträge
    495
    Bedankte sich
    5
    Erhielt 122 Danksagungen
    in 116 Beiträgen

    Standard

    poste mal einen link zur seite. vielleicht auch mal die Cookies löschen.

  3. Erhielt Danksagungen von:


  4. #3
    Neu an Board
    Registriert seit
    07.06.2011
    Beiträge
    3
    Bedankte sich
    2
    1 Danksagung in 1 Beitrag

    Standard an Ethlaegil

    hallo,

    vielen Dank für die Antwort. Cookies sind gelöscht. Einen Link in diesem Kontext darf ich nicht posten, weil es ein Kundenprojekt ist.

    Welche weiteren Informationen könnten zur Lösung helfen? Index.php oder config-Dateien? Beide sind mit unicode formatiert, die BOM-Problematik kann ich ausschließen.

    Ich kann auch genaue Einstellungen der jos_Tabellen beschreiben in der sql-Datenbank.

    Bitte weiterhin freundlichst um Eure Unterstützung.

    Woran kann der Fehler liegen?

    Vielen Dank.

    Beste Grüße
    Beginnerz

  5. #4
    Hat hier eine Zweitwohnung Avatar von Pest
    Registriert seit
    23.09.2004
    Alter
    43
    Beiträge
    1.164
    Bedankte sich
    80
    Erhielt 176 Danksagungen
    in 103 Beiträgen

    Standard

    Einen Gruß an die Kollegen hier. Bevor wir uns jetzt alle die Finger blutig schreiben, dass Thema wurde auch bei uns eingestellt. Nur zur Info und Abstimmung was bereits unternommen wurde.

    http://www.joomla-downloads.de/forum...eser-webs.html

    Gruß Jan
    Joomla Downloads - Aktuelle News, Downloads und Templates. Alle Pakete unter offenen Lizenzen wie GNU / GPL.
    Antizicke - Wirf einen Blick in die wunderbare Welt der Frauenprobleme.

  6. Erhielt Danksagungen von:


  7. #5
    Neu an Board
    Registriert seit
    07.06.2011
    Beiträge
    3
    Bedankte sich
    2
    1 Danksagung in 1 Beitrag

    Standard Das ist die lösung!!!

    Deltapapa, ein User aus dem http://www.joomla-downloads.de/forum/ hatte die Lösung! Du bist der Held, ein König, der Checker. Das wars. Du hast mir die Lösung präsentiert! DANKESCHÖN

    Nochmal für alle:

    - Mein Fehler: Ich habe meinem Super User mehrere Benutzergruppen zugeteilt (aus Versehen? Keine Ahnung...)
    - Das Problem: Ich konnte mich mit meinem richtigen Admin-Zugang weder im Front- noch im Backend anmelden
    - Das Passwort über die SQL-Datenbank zurücksetzen hat nichts gebracht
    - Die Lösung von Deltapapa:

    1. die configuration.php runterladen
    2. unten in die letzte Zeile eine weitere Zeile einfügen:

    (...)
    public $feed_email = 'author';
    public $cookie_domain = '';
    public $cookie_path = '';
    public $root_user='BENUTZERNAME';
    }

    3. Wie gewohnt über www.MEINEWEBSITE.de/administrator einloggen
    4. Es erscheint eine Warnmeldung, dass man im Emergency-Mode eingeloggt ist und das ein Sicherheitsproblem sein kann
    5. Den Super User wiederherstellen (bei mir, wie gesagt, waren dem Super User alle Benutzergruppen zugeteilt, ich habe wieder nur die Benutzergruppe "Super User" zugeteilt
    6. Ausloggen
    7. Die letzte Zeile aus der configuration.php wieder löschen und die Datei austauschen per FTP
    8. Glücklich wieder neu einloggen, wie gewohnt

    DANKE AN ALLE, so eine Community sollte es für alles geben...

    Liebe Grüße
    Beginnerz

    ein Link dazu: http://www.compassdesigns.net/joomla...min-permission

  8. Erhielt Danksagungen von:


  9. #6
    Neu an Board
    Registriert seit
    07.11.2008
    Beiträge
    6
    Bedankte sich
    0
    1 Danksagung in 1 Beitrag

    Standard

    Zitat Zitat von beginnerz Beitrag anzeigen

    1. die configuration.php runterladen
    2. unten in die letzte Zeile eine weitere Zeile einfügen:

    (...)
    public $feed_email = 'author';
    public $cookie_domain = '';
    public $cookie_path = '';
    public $root_user='BENUTZERNAME';
    }

    3. Wie gewohnt über www.MEINEWEBSITE.de/administrator einloggen
    4. Es erscheint eine Warnmeldung, dass man im Emergency-Mode eingeloggt ist und das ein Sicherheitsproblem sein kann
    5. Den Super User wiederherstellen (bei mir, wie gesagt, waren dem Super User alle Benutzergruppen zugeteilt, ich habe wieder nur die Benutzergruppe "Super User" zugeteilt
    6. Ausloggen
    7. Die letzte Zeile aus der configuration.php wieder löschen und die Datei austauschen per FTP
    8. Glücklich wieder neu einloggen, wie gewohnt
    ..oder alternativ in MySQL die 'jos_user_usergroup_map' bearbeiten.
    Der Eintrag 'user_id' (die vom Admin in 'jos_users' natürlich) sollte die 'group_id' 8 (die vom Superbenutzer in 'jos_usergroups') beinhalten.

    besser geht immer!
    Geändert von jazzvox (06.07.2011 um 02:00 Uhr)

  10. Erhielt Danksagungen von:


  11. #7
    Neu an Board
    Registriert seit
    20.08.2011
    Beiträge
    13
    Bedankte sich
    8
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Gleiches Problem - keine Lösung

    Hallo zusammen,
    bei mir ist das gleiche Problem über Nacht aufgetreten.
    Den Lösungsansatz wie unten von Jan beschrieben kann ich durchführen, bin dann auch im Admin Bereich.
    Der Super User hat alle notwendigen Eintragungen (nur eine Gruppe, usw.)
    Wenn ich dann wieder ohne die geänderte configuration.php einlogge kommt wieder die Verweigerung Kein Zugang zum Administrationsbereich dieser Website!

    Gibt es noch irgend eine Schraube an der ich drehen kann?

    Ergänzung:
    in der jos_users steht der betroffenen User als "Super Benutzer" drin.
    Spielt der Eintrag hier eine Rolle ob "Super Benutzer" oder "Super User" oder "Super Administrator"?


    Danke für eure Hilfe
    (Joomla 1.6)
    Geändert von BartSimpson (27.08.2011 um 13:24 Uhr)
    Danke und Gruß

    Peter

  12. #8
    Neu an Board Avatar von ekelzarth
    Registriert seit
    06.09.2006
    Ort
    38364 Schöningen
    Alter
    59
    Beiträge
    99
    Bedankte sich
    37
    Erhielt 3 Danksagungen
    in 3 Beiträgen

    Standard

    Hallo Beginnerz,

    das habe ich versucht. Ging nicht.
    Stattdessen bekam ich folgende Meldung als ich "Benutzer" im Backend angeklickt habe:
    Table 'DB998551.cwgt7_user_notes' doesn't exist SQL=SELECT n.user_id, COUNT(n.id) As note_count FROM cwgt7_user_notes AS n WHERE n.user_id IN (42,43) AND n.state >= 0 GROUP BY n.user_id

    Ich habe zwar eine Ahnung, was das bedeuten könnte, aber kein Wissen.
    Watt nu?

    Jetzt hab ich es mal mit mySQL versucht. Bei einer Abfrage nach dem User kommt:
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '`usertype` SELECT * FROM `cwgt7_users` WHERE 1 LIMIT 0, 60' at line 1

    Das macht mich nun auch nicht gerade schlauer . . .

    Grüße

    Ekelzarth
    Geändert von ekelzarth (30.01.2012 um 13:04 Uhr)

  13. #9
    Kommt häufiger vorbei Avatar von Ethlaegil
    Registriert seit
    15.12.2008
    Ort
    Oldenburg
    Alter
    44
    Beiträge
    495
    Bedankte sich
    5
    Erhielt 122 Danksagungen
    in 116 Beiträgen

    Standard

    falls du nur wenige User in der Datenbank hast, wäre vielleicht folgende brutale Lösung erfolgreich.

    Installier doch irgendwo ein frisches Joomla und exportier mit phpmyadmin alle user Tabellen, bearbeite die sql Datei und ersetze die Präfixe mit deinem obigen (cwgt7_) und importiere sie in die bestehende Seite. Die restlichen User legst du dann neu an. Beim exportieren DROP TABLE mit anhaken.

  14. #10
    Verbringt hier viel Zeit Avatar von niandra
    Registriert seit
    17.01.2006
    Ort
    im schönen Wendland
    Beiträge
    532
    Bedankte sich
    46
    Erhielt 101 Danksagungen
    in 98 Beiträgen

    Standard

    mir hat joompassreset da schon sehr gute dienste geleistet.

    war zwar unter joomla 1.7, aber einfach probieren, ob es mit deiner version auch klappt.

    grüße,
    nia
    Fundgrube für Joomla-Erweiterungen: die JED
    Warum Updates? KLICK | Webseite gehackt? KLICK

+ Antworten
Seite 1 von 3 1 2 3 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein