+ Antworten
Ergebnis 1 bis 10 von 10

Thema: Installation auf Web Server

  1. #1
    Neu an Board
    Registriert seit
    24.02.2010
    Beiträge
    28
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Installation auf Web Server

    Hallo
    Bis jetzt habe ich Websites auf die herkömliche Weise erstellt (statisch mit Homesite)
    Jetzt habe ich eine Website mit Joomla erstellt, sie auf den Server geladen, die Datenbank angelegt. Dann die Datenbank importiert.

    Beim Aufrufen der Webseite kam die Meldung:
    This page is used to test the proper operation of the Apache HTTP server after it has been installed. If you can read this page, it means that the web server installed at this site is working properly, but has not yet been configured.

    If you are the website administrator:
    You may now add content to the directory /var/www/html/. Note that until you do so, people visiting your website will see this page, and not your content. To prevent this page from ever being used, follow the instructions in the file /etc/httpd/conf.d/welcome.conf.

    Ich weiss aber nicht, was das heisst. Wo ist dieses Directory? Ich habe im Web gesurft, da kam was wegen PHP Safe Mode?
    Kann mir jemand helfen?
    Vielen Dank
    Chantal

  2. #2
    Moderator Avatar von Lacki
    Registriert seit
    27.04.2006
    Ort
    Direkt um die Ecke
    Beiträge
    8.811
    Bedankte sich
    345
    Erhielt 3.789 Danksagungen
    in 2.999 Beiträgen

    Standard

    Hallo und willkommen im Forum.

    Die besagte Meldung will Dir "nur" mitteilen, dass der Apache Webserver korrekt läuft und Du anfangen kannst, Deine Inhalte auf den Server zu packen. In dem Fall in das Verzeichnis /var/www/html/ dorthin gehört die index.php und der Rest der Joomla Dateien und Verzeichnisse. U. U. musst du die zusätzlich vorhandene index.htm oder html in dem Verzeichnis umbenennen oder löschen, damit die index.php aufgerufen wird. BTW, worum handelt es sich denn hier, um einen eigenen Server, um Webspace bei einem Hoster oder um einen lokalen Webserver wie z. B. xammp?

    EDIT: Man sollte richtig lesen, hochgeladen hast Du es ja schon. Also nur index.htm oder index.html im genannten Verzeichnis löschen, nicht in den Unterverzeichnissen von Joomla.

  3. #3
    Neu an Board
    Registriert seit
    24.02.2010
    Beiträge
    28
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Installation auf Webserver

    Hallo
    Also ich habe folgendes gemacht:
    - auf meinem localhost ein Seite mit Joomla kreiert, hat auch gut geklappt.
    - beim Webhoster (unaxus.com) eine Datenbank angelegt (Staub_joomla).
    . per FTP im Verzeichnis httpdocs ein Unterverzeichnis (Staub_joomla) erstellt und da drin die Files von joomla vom localhost rueberkopiert.
    - auf localhost ueber phpmyadmin die Datenbank auf die Festplatte exportiert.
    - im Webhoster über phpyadmin Datenbank in Datenbank Staub_joomla importiert. Hat auch geklappt, entsprechende Meldung kam.
    - im FTP die Datei configuration.php auf Festplatte kopiert und ergänzt mit Datenbankname (Staub_joomla), username, Passwort, Servername (localhost, spielt da die Gross und Kleinschreibung eine Rolle? Habe es mit beidem versucht.
    - configuration.php wieder per ftp rüberkopiert.

    Alles nach Anleitung des Buches "Joomla 1.5 " von Galileo Computing.

    Ich habe im Unterverzeichnis httpdocs ein Verzeichnis Staub_joomla, da drin sind alle plugins etc, weiter CHANGELOG.php, configuration, php, configuration.php-dist, COPYRIGHT.php, CREDITS.php, htaccess.txt, index.php, index2.php, INSTALL.ph., LICENCE.php, LICENSES.php, robots.php.
    Sonst befindet sich nirgends eine index.html oder index.php.

    Und dennoch klappt es nicht und es kommt obengenannte Meldung.

    Ich habe die Datenbank beim Webhoster gelöscht, neu angelegt, mit neuem Namen, etwa 3 mal.

    Was ist immer noch nciht richtig?

    Danke fuer die Hilfe.
    Chantal

  4. #4
    Verbringt hier viel Zeit Avatar von rocx
    Registriert seit
    30.09.2006
    Ort
    Niedersachsen
    Alter
    35
    Beiträge
    851
    Bedankte sich
    38
    Erhielt 300 Danksagungen
    in 286 Beiträgen

    Standard

    Servus...wenn ich das richtig verstehe
    Ich habe im Unterverzeichnis httpdocs ein Verzeichnis Staub_joomla
    liegen deine Dateien nicht einzeln im Ordner /html/ auf deinem Webserver sondern in Unterordnern richtig ??
    Falls das so ist hast du 2 Möglichkeiten:
    (1) alle Dateien direkt in den /html/ Ordner (root) des Webservers laden bzw. verschieben
    (2) deine Domain direkt auf das Joomla Unterverzeichnis pointen lassen
    Um auszuprobieren ob mein Gedanke richtig ist, könntest du in deinem Browser mal
    [url]www.-deinedomain-.de/httpdocs/Staub_joomla eingeben und schauen ob du etwas angezeigt bekommst.

    Gruß,
    Rocx
    Abgeschlossene Threads bitte als "Gelöst" markieren !
    Falls Dir meine Antwort geholfen hat, klick doch bitte auf "Danke"
    Zum Zeitpunkt des Postens war ich all meiner 5 Sinne(Stumpfsinn, Schwachsinn, Wahnsinn, Irrsinn und Unsinn) mächtig.

  5. #5
    Neu an Board
    Registriert seit
    24.02.2010
    Beiträge
    28
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Das hatte ich auch versucht, kam eine Fehlermeldung.
    Jetzt habe ich aber folgendes eingegeben:
    www.domain.ch/Staub_joomla und die Joomla Seite erschien.

    Wenn ich das also richtig verstehe, muss ich die Joomla Seiten zuoberst reinkopieren.
    Dort sind Ordner wie cgi-bin, conf, subdomains, httpdocs, httpsdocs.
    Jetzt dachte ich, ich mache hier zusätzlich den Ordner Staub_joomla - dann kam permission denied.
    Also kopiere ich das ganze joomla einfach so rein?
    Danke
    Chantal

  6. #6
    Wohnt hier Avatar von addi
    Registriert seit
    29.11.2005
    Ort
    Berlin
    Beiträge
    2.113
    Bedankte sich
    20
    Erhielt 433 Danksagungen
    in 418 Beiträgen

    Standard

    Nein, nicht ganz.

    In httpdocs wäre eine Möglichkeit.

    Die andere Möglichkeit wäre, du gibst in deinem Server-Interface deines Providers bei der Domain-Einstellung den Ordner an, in dem dein Joomla im Moment liegt, also z.B. Staub_joomla.

    Groß- und Kleinschreibung spielt immer eine Rolle im Web - muss beachtet werden!
    Die Welt dreht sich auch ohne Joomla weiter. Nur langsamer.

    Kein Support per PM. Keine Antwort auf Fragen, die mit der Thread-Frage nichts zu tun haben.

  7. #7
    Neu an Board
    Registriert seit
    24.02.2010
    Beiträge
    28
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Da komm ich nicht ganz mit.
    Wo muss ich das angeben?

    Der Webhoster bietet die Moeglichkeit, Webapplikationen zu installieren, darunter ist auch joomla.
    Das liess ich also machen, daraufhin haben die einen Ordner erstellt im Verzeichnis von htppdocs, der hiess dann joomla.
    Als ich dann aber die Datenbank von meinem Rechner in den Webhoster rueberkopierte, kamen Fehlermeldungen, es befanden sich naemlich schon Dateien in der Datenbank. Und wahrscheinlich hat das Ueberspielen nicht richtig geklappt.
    Deshalb loeschte ich die Webapplikation und die von ihnen angelegte Datenbank.

    Ich legte eine neue Datenbank an (Staub_joomla) und erstellte wie sie im Verzeichnis httpdocs einen Ordner mit dem Namen der Datenbank.

    Ich habe doch alles so gemacht wie sie, wieso klappt es dann nicht?

    Hier ist die Homepage
    http://www.borboletta.ch/Staub_joomla/

    Chantal

  8. #8
    Hat hier eine Zweitwohnung Avatar von X-Bit
    Registriert seit
    08.06.2007
    Beiträge
    1.416
    Bedankte sich
    69
    Erhielt 306 Danksagungen
    in 271 Beiträgen

    Standard

    Hallo!

    Ohne dir nahe treten zu wollen, hast du das HIER schon mal gelesen?

    Du sprichst von einer "Datenbank" welche du in den "Ordner" kopierst... Eine Datenbank lässt sich nicht kopieren, sondern muss in eine andere DATENBANK migriert werden. Daten kann man kopieren und bei Joomla muss dann die configuration.php angeglichen werden. Dies geschieht entweder bei einer Neuinstallation oder aber, wenn man zum Beispiel lokal arbeitet, nach einem Transfer manuell.

    Ich hoffe, du liest dich bei dem obigen Link ein wenig ein und verstehst dann besser mit Joomla um zu gehen.

    Ach ja noch was am Rande... dein Beitrag liest sich wie das Mail an deinen Hoster.
    Problem gelöst?! Mark it! | FAQ gelesen? | Level-Up auch DU zählst!

  9. #9
    Moderator Avatar von Lacki
    Registriert seit
    27.04.2006
    Ort
    Direkt um die Ecke
    Beiträge
    8.811
    Bedankte sich
    345
    Erhielt 3.789 Danksagungen
    in 2.999 Beiträgen

    Standard

    Oder, um es anders zu sagen, auch wenn die Datenbank staub_joomla heißt, kann das Verzeichnis von Joomla ganz anders heißen. Und in dem Fall brauchst Du nur alle Dateien und Ordner auf Deinen PC runterladen, und dann anschließend einen Ordner höher (Also ohne das Staub_joomla) wieder hochladen. Dann noch die configuration.php per Joomlapath (Dort Anleitung beachten, nachher unbedingt löschen) an die neuen Ordner anpassen, fertig. Dann lautet der Aufruf nicht mehr http://www.borboletta.ch/Staub_joomla/ sondern http://www.borboletta.ch/ Eigentlich doch logisch, oder?

  10. #10
    Neu an Board
    Registriert seit
    24.02.2010
    Beiträge
    28
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ja jetzt hat es endlich geklappt.
    Vielen Dank fuer die Hilfe.
    Chantal

+ Antworten

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein