+ Antworten
Seite 1 von 7 1 2 3 4 5 ... LetzteLetzte
Ergebnis 1 bis 10 von 70

Thema: Installation von Joomla 1.5.10 auf All-Inkl

  1. #1
    Neu an Board
    Registriert seit
    19.01.2006
    Beiträge
    39
    Bedankte sich
    3
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard Installation von Joomla 1.5.10 auf All-Inkl

    Moin,
    hab mich jetzt schon Stunden hier durchs Forum gelesen, bin aber etwas durcheinander, was die richtige Installation von Joomla 1.5.10 auf den Anbieter All-Inkl.com angeht.

    1.) Ich hab von Joomlaos das Paket 1.5.10 Deutsch Core heruntergeladen und auf meine Festplatte entpackt
    2.) Ich hab beim KAS eine neue Datenbank angelegt
    3.) Habe per Filezilla die entpackten Dateien von Installationspaket (Joomla) per FTP auf den Webspace hochgeladen
    4.) Homepage aufgerufen und dort hat automatisch die Installation begonnen.
    Soweit so gut.

    Jetzt meine Fragen:
    Das erste was mir aufgefallen ist war, das die "configuration.php" NICHT beschreibbar ist!!!
    Mir ist dabei aufgefallen, das die Datei im / garnicht vorhanden ist, sondern nur die "configuration.php-dist" da ist.

    Darauf habe ich hier im Forum gesehen, das man im KAS die Besitzerrechte ändern soll.
    Jetzt meine Frage:
    Auf was soll ich die Besitzerrechte im KAS ändern? Auf mein w00xxxxxx oder auf PHP-User?
    Soll ich das dann VOR der Installation machen oder wenn sie durchgelaufen ist?
    Wenn die configuration.php nicht beschreibbar ist, bekomm ich ja einen Text, den ich dann in eine Textdatei einfüge und per Hand(FTP) auf den Webspace hochlade.
    Das scheint dann auch zu funktionieren, scheint mir aber dann nicht ganz so krüsch zu sein.

    Dann ist mir noch aufgefallen, das ich NOCH PHP 4.4.9 und MySQL 4.1.22 habe.
    All-Inkl habe ich schon angeschrieben, das sie mich auf PHP 5.x und auf einer neuere Version von MySQL heute Nacht umstellen wollen.

    Gibt es sonst noch etwas bei der Installation bei All-Inkl zu beachten???
    Danke schonmal für eure Antworten.

    Gruß

  2. #2
    War schon öfter hier
    Registriert seit
    30.10.2005
    Beiträge
    237
    Bedankte sich
    35
    Erhielt 13 Danksagungen
    in 12 Beiträgen

    Standard

    nein. alles ohne probleme
    vg
    thomas

    http://www.photoblog-index.com

  3. #3
    War schon öfter hier
    Registriert seit
    03.08.2008
    Alter
    70
    Beiträge
    245
    Bedankte sich
    59
    Erhielt 30 Danksagungen
    in 27 Beiträgen

    Standard

    all inkl hat doch einen joomla installer. Kannst auswählen ob mit oder ohne Beispieldateien. Datenbaknk angeben und nach 1 Minite ist alles fertig. Kannst du im Kas unter tools finden.

    Rainer

  4. Erhielt Danksagungen von:


  5. #4
    Neu an Board
    Registriert seit
    19.01.2006
    Beiträge
    39
    Bedankte sich
    3
    Erhielt 2 Danksagungen
    in 2 Beiträgen

    Standard

    Genau das hatte ich auch gemacht.
    Doch ich hatte fast bei jeder Komponente Probleme die zu installieren.
    Es kamen Datenbankfehler, das er irgendwelche Tabellen nicht anlegen konnte oder Verzeichnisse nicht anlegen konnte etc.
    Konnte das damit zusammen hängen, das PHP & MySQL Version 4.x waren???
    EDIT:Ich habe die Vermutung, das Joomla irgendwie keine Rechte hat, selbstständig neue Dateien/Verzeichnisse zu erstellen.

  6. #5
    Gute Seele des Boards Avatar von keraM
    Registriert seit
    12.03.2006
    Beiträge
    13.189
    Bedankte sich
    202
    Erhielt 3.283 Danksagungen
    in 2.998 Beiträgen

    Standard

    Bei all-inkl hast Du in der Standardkonfiguration das wwwrun-Problem. Läßt sich dort aber ganz leicht beheben.
    * gehe auf all-inkl.com -> Top-Menü "Wichtig zu wissen" -> Anleitungen -> Skripte/Sonstiges -> .htaccess-Generator Direktlink
    * Dort ganz unten: PHP5 als CGI aktivieren, Magic Quotes off, Register Globals off, externe Includierungen unterbinden ja.
    * Die Ausgabe in eine .htaccess kopieren und in den Webroot packen.

    Bei einer Neuinstallation von Joomla:
    * Joomla in ein eigenes Verzeichnis kopieren und im KAS die Domain auf das Verzeichnis legen.
    * Wenn Du jetzt die Installation startest, wird alles gut. FTP- und PHP-User können jetzt gleichberechtigt auf die Dateien zugreifen. Ein Setzen der Rechte auf 777 ist nicht nötig, es reicht 755 für Ordner und 644 für Dateien (wird automatisch so vergeben).
    * die htaccess.txt, welche Joomla mitbringt, kann später für SEO Zwecke problemlos in .htaccess umbenannt werden

    Bei einer vorhandenen Installation im Webroot:
    * wenn bereits eine .htaccess im Webroot existiert, dann muss der vom Generator erzeugte Code an den Anfang dieser .htaccess kopiert werden.
    * die Anweisung "RewriteEngine On" steht nun zweimal in der Datei, weshalb die zweite Anweisung (im Joomla Teil) gelöscht/auskommentiert werden kann.
    * selbstverständlich kannst Du auch das existierene Joomla in ein eigenes Verzeichnis verschieben, die Domain im KAS auf dieses Verzeichnis legen, in der configuration.php die Pfade anpassen und dann zwei getrennt .htaccess Dateien anlegen, wie es bei der Neuinstallation beschrieben ist.
    Geändert von keraM (03.07.2013 um 20:01 Uhr) Grund: für Joomla 3: Magic Quotes off
    Ich leiste hier keinen Support mehr.


  7. #6
    War schon öfter hier
    Registriert seit
    03.08.2008
    Alter
    70
    Beiträge
    245
    Bedankte sich
    59
    Erhielt 30 Danksagungen
    in 27 Beiträgen

    Standard

    Verstrehe ich nicht.
    Ich habe bis jetzt immer nur den Installer laufen lassen und noch nie ein Problem gehabt. Joomla rennt ohne Probleme bei all inkl.

    Rainer

  8. #7
    War schon öfter hier
    Registriert seit
    30.10.2005
    Beiträge
    237
    Bedankte sich
    35
    Erhielt 13 Danksagungen
    in 12 Beiträgen

    Standard

    wie bereits oben erwähnt. der installer ist bei mir ohne probleme durchgelaufen.
    musste nichts vorher anpassen.
    eine datenbank im allinkl manager musst ich anlegen und nach der installation das installationsverzeichnis umbenennen.
    vg
    thomas

  9. #8
    War schon öfter hier
    Registriert seit
    03.08.2008
    Alter
    70
    Beiträge
    245
    Bedankte sich
    59
    Erhielt 30 Danksagungen
    in 27 Beiträgen

    Standard

    Datenbank kann man aber auch automatisch bei der Instalation erstellen lassen.

  10. #9
    Gute Seele des Boards Avatar von keraM
    Registriert seit
    12.03.2006
    Beiträge
    13.189
    Bedankte sich
    202
    Erhielt 3.283 Danksagungen
    in 2.998 Beiträgen

    Standard

    Der Installer steht erst ab Webpaket "Privat Plus" zur Verfügung. Auf "Privat" fehlt er, dort muß man also per FTP hochladen und installieren.
    Außerdem muß man ja nicht immer neu installieren, man kann ja auch erstmal lokal entwickeln und dann online stellen. Auch bei Update braucht man FTP-Zugang.
    In diesen Fällen ist es schon günstig, wenn man PHP als CGI laufen hat.
    Ich leiste hier keinen Support mehr.

  11. #10
    Gehört zum Inventar Avatar von cybergurk
    Registriert seit
    06.07.2005
    Ort
    Berlin
    Beiträge
    8.807
    Bedankte sich
    197
    Erhielt 2.729 Danksagungen
    in 2.089 Beiträgen

    Standard

    Zitat Zitat von RainerM Beitrag anzeigen
    Datenbank kann man aber auch automatisch bei der Instalation erstellen lassen.
    Hallo,
    NEIN, also, überlegt mal was ihr hier schreibt, ich bin auch bei allinkl... schaut dieses Tut und ihr habt keine probs.
    http://www.filmanleitungen.de/news/1...tallieren.html

    ansonsten das wwwrun problem wegbekommen mit einem .htaccess eintrag GANZ UNTEN einfügen

    AddHandler php-fastcgi .php .php4 .php3

    man kann auch VOR der eigentliche Installation diese htaccess erstellen
    Gruß Achim
    www.cybergurke.de | MyFaceSite.com - Freunde neu entdecken -

  12. Erhielt Danksagungen von:


+ Antworten
Seite 1 von 7 1 2 3 4 5 ... LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein