+ Antworten
Ergebnis 1 bis 10 von 10

Thema: Menüeinträge doppelt vorhanden

  1. #1
    Neu an Board
    Registriert seit
    20.03.2010
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Menüeinträge doppelt vorhanden

    Hallo,

    ich möchte vorrausschicken, dass ich noch nicht sehr lange mit Joomla arbeite.

    Ich brauche 2 Menüs, die beinahe gleich sind, nur einzelne Menüeinträge sollen je nach "Aufenthaltsort" innerhalb der Homepage ausgetauscht werden.
    Dazu habe ich das Menü (modul mainmenu) kopiert, anscheinend aber bei der Namensvergabe einen Fehler gemacht (bei der Vergabe des neuen Menütitels bzw. unter "neues Menü erstellt").
    Anschliessend habe ich alle neuen Module bzw. Menüs gelöscht, außerdem Cache, Papierkorb, alles was mir so einfiel...
    Trotzdem habe ich nun irgendwo noch ein Relikt übrig:
    Wenn ich nun generell für einzelne Module (egal welche) festlegen möchte, wo sie auftauchen und wo nicht, erscheint die von mir gelöschte Menüstruktur immer noch unter Erweiterungen-Module-...-Menüzuweisung-Menüauswahl.

    Wie bekomme ich dieses Relikt weg?
    Danke im Voraus für jede Hilfe!

    Gruß,
    Michael
    Geändert von gutti (05.04.2010 um 09:46 Uhr)

  2. #2
    Kommt häufiger vorbei
    Registriert seit
    08.06.2009
    Beiträge
    283
    Bedankte sich
    0
    Erhielt 73 Danksagungen
    in 73 Beiträgen

    Standard

    wenn du ein neuew Modul Menü erstellst mußt du noch auf der rechten Seite
    menü-name mal schauen was ausgewählt bzw. was du einstellst...

    Die Menüs mit Namen hast du ja schon unter Menüs erstellst

  3. #3
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    61
    Beiträge
    19.636
    Bedankte sich
    763
    Erhielt 4.010 Danksagungen
    in 3.767 Beiträgen

    Standard

    Hier ein Video, wie man neues Menüs anlegt. Gleiche Menüpunkte werden mit einem "Alias" erzeugt, wenn du auf Neu klickst.

    Das Menü löschen geht dann genauso. Also nicht das Modul, sondern das Menü
    http://www.time4joomla.de/artikel-co...e-anlegen.html


    Axel
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    CCK SEBLOD-Das Handbuch als kostenloses Onlinebook

  4. #4
    Neu an Board
    Registriert seit
    20.03.2010
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hallo und danke erstmal. Habe mich offensichtlich nicht eindeutig ausgedrückt

    Menus sind da und auch ok so.
    Allerdings habe ich bei diesem Punkt:

    Zitat Zitat von gutti Beitrag anzeigen
    Trotzdem habe ich nun irgendwo noch ein Relikt übrig:
    Wenn ich nun generell für einzelne Module (egal welche) festlegen möchte, wo sie auftauchen und wo nicht, erscheint die von mir gelöschte Menüstruktur immer noch unter Erweiterungen-Module-...-Menüzuweisung-Menüauswahl.

    Wie bekomme ich dieses Relikt weg?
    l
    nun quasi dreifachen Eintrag (einmal das Originalmenu, einmal das kopierte (soweit ok, wird ja angepasst), einmal das wieder gelöschte, fehlerhafte).

    Und diesen Eintrag (bzw. die Menüpunkte des kompletten Menüs) bekomme ich nicht wieder los. Menü ist gelöscht, modul ist gelöscht, Einträge tzrotzdem da in dieser Liste... Ich schätze ein Relikt in der Datenbank übrig, o.ä. ...

    Gruß,
    Michael

  5. #5
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    61
    Beiträge
    19.636
    Bedankte sich
    763
    Erhielt 4.010 Danksagungen
    in 3.767 Beiträgen

    Standard

    Schau mal im Papierkorb nach...


    Axel
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    CCK SEBLOD-Das Handbuch als kostenloses Onlinebook

  6. #6
    Neu an Board
    Registriert seit
    20.03.2010
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hi,

    steht im Ausgangspost, dass Papierkorb, Cache etc. alles gelöscht wurde...

    Gruß,
    Michael

  7. #7
    Gute Seele des Boards Avatar von time4mambo
    Registriert seit
    11.12.2006
    Ort
    76646 Bruchsal
    Alter
    61
    Beiträge
    19.636
    Bedankte sich
    763
    Erhielt 4.010 Danksagungen
    in 3.767 Beiträgen

    Standard

    Zitat Zitat von gutti Beitrag anzeigen
    erscheint die von mir gelöschte Menüstruktur immer noch unter Erweiterungen-Module-...-Menüzuweisung-Menüauswahl.
    Also: wenn es da noch erscheint, dann lösche doch einfach mal das Modul.


    Axel
    Joomla- und Office-Tutorials: time4joomla
    Deutschsprachige SEBLOD-Community
    CCK SEBLOD-Das Handbuch als kostenloses Onlinebook

  8. #8
    Neu an Board
    Registriert seit
    20.03.2010
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hi,

    die Struktur erscheint ja bei jedem Modul!
    Das fehlerhafte Modul war ja bereits gelöscht! Das ist ja mein Problem, dass irgendwie alles gelöscht ist, die Struktur aber bei anderen Modulen immer noch erscheint!

    Wenn sich das jemand anschauen möchte, kann ich gerne temporären Zugang zum backend gewähren!

    Gruß,
    Michael

  9. #9
    Neu an Board
    Registriert seit
    20.03.2010
    Beiträge
    5
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    So,
    nun habe ich das Problem selbst lösen können :-)

    Ursache war das Kopieren des Menüs (wie befürchtet):
    Wenn ich ein komplett neues Menü anlege, ist es bei "eindeutiger Name" nicht erlaubt, Leerzeichen zu verwenden. Beim Kopieren wird das aber anscheinen nicht abgefragt, er legt es trotzdem an mit diesem fehlerhaften Namen.
    Beim löschen kommt er dann offensichtlich ins Stolpern...

    Lösung: Ich habe das Ursprungs-Menu XY (mit 13 Einträgen) nun nochmal mit fehlerhaften Namen (also mit Leerzeichen) kopiert. Voila, das kopierte Menu Copy-XY exisiert mit 26 (!) Einträgen, er hat also seine Relikte irgendwo mitgeschleppt. Nun auf einen korrekten Namen ohne Leerzeichen geändert und erst dann gelöscht. Nun ist alles wieder paletti :-)

    Danke für die Lösungsversuche!

    Gruß,
    Michael

  10. #10
    mio
    mio ist offline
    Neu an Board
    Registriert seit
    18.05.2007
    Beiträge
    26
    Bedankte sich
    5
    Erhielt 2 Danksagung
    in 1 Beitrag

    Standard

    hier noch eine ergänzung zur lösung!
    ich hatte heute das selbe problem: bereits gelöschte menüs waren noch immer im auswahlfenster für die menüzuweisung von modulen sichtbar. zudem kam es im frontend auch zu fehlern in der menüdarstellung etc. ursache ist wohl der oben genannte leerzeichen-bug beim kopieren von menüs (der in aktuellen joomla-updates aber gefixt wurde, da leerzeichen im menünamen/menütyp nun automatisch durch unterstriche ersetzt werden).
    die lösung: in der sql-datenbank müssen unter jos_menu die verwaisten menüeinträge manuell gelöscht werden! dannach ist alles wieder wie es sein sollte...

+ Antworten

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein