+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: E-Mail-Benachrichtigung bei Benutzer-Registrierung

  1. #1
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Frage E-Mail-Benachrichtigung bei Benutzer-Registrierung

    aktuelle Einstellungen:

    System:: Benutzer
    Benutzerregistrierung erlauben: Ja
    Gruppe für neue Benutzer: registriert
    Aktivierung neuer Konten: Ja
    Einstellungen im Frontend: Anzeigen

    Server::Mailing
    Mailer: PHP Mail-Funktion
    Absender (Adresse): fsromanistik-ld@gmx.de
    Absendername: FSR-Homepage
    Sendmail-Pfad: /usr/sbin/sendmail
    SMTP-Auth: Nein
    SMTP-Sicherheit:
    SMTP-Port:
    SMTP-Benutzer:
    SMTP-Passwort:
    SMTP-Host:


    Wenn ich nun versuche, ein neues Mitglied zu registrieren, empfange ich unter meiner Admin-Adresse zwar eine Email:
    Hallo Admin,

    Ein neuer Benutzer hat sich auf "Homepage" registriert.
    Diese E-Mail enthält die Details:

    Name - Max Mustermann
    E-Mail - mail@xxxxxxx.de
    Benutzername - Max

    Bitte nicht auf diese Nachricht antworten, da sie automatisch generiert wurde und nur zur Information dient.


    ... Aber der registrierte Benutzer enthält keine eMail. So kann er auch sein Konto nicht selber freischalten. Die registrier-Seite wechselt sofort auf die Startseite um und zeigt nicht an, ob die Registrierung erfolgreich war oder fehlerhaft. Es erscheint keine Seite, wo steht, dass man nun eine Mail bekommt mit einem Bestätigungslink/Code...
    Könnt Ihr mir helfen die Fehler auszuschließen ? und zu beheben ? *g*
    Geändert von axo (05.10.2011 um 13:24 Uhr)

  2. #2
    PHP
    PHP ist offline
    War schon öfter hier
    Registriert seit
    30.01.2011
    Beiträge
    109
    Bedankte sich
    4
    Erhielt 18 Danksagungen
    in 17 Beiträgen

    Standard

    Worüber verschickst du den deine Email? Sendmail, PHP, Smtp?
    Mit freundlichen Grüßen
    PHP

    Mein Blog über CMS, Linux, PHP und mehr unter http://www.noob-blog.tk

  3. Erhielt Danksagungen von:

    axo

  4. #3
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Zitat Zitat von axo Beitrag anzeigen


    Server::Mailing
    Mailer: PHP Mail-Funktion
    ^^ habs aber auch schon über sendmail versucht.

  5. #4
    Neu an Board
    Registriert seit
    14.03.2009
    Beiträge
    53
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    hey axo, hab da ein ähnliches problem - es lassen sich keine user registrieren, bzw. es wird ein account im backend angelegt, aber keine emails verschickt.

    Bei der registrierung kommen folgende 2 fehlermeldungen:

    Mail-Funktion konnte nicht initialisiert werden!

    Registrierung fehlgeschlagen: Beim Verschicken der Registrierungs-E-Mail ist ein Fehler aufgetreten! Der Admistrator der Seite wurde hierüber informiert.

    Gibts da schon Lösungsvorschläge?

    MfG

  6. #5
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Nee, hier gabs noch 0 Lösungsvorschläge... wie du erkennen kannst.
    Bei mir spuckt er ja noch nicht Mal ne Fehlermeldung aus.

    Von daher kann ich dir leider wenig helfen, da ich mich selber auch erst seit ca. 4 Wochen mit joomla 1.5 auseinandersetze :-(

  7. #6
    PHP
    PHP ist offline
    War schon öfter hier
    Registriert seit
    30.01.2011
    Beiträge
    109
    Bedankte sich
    4
    Erhielt 18 Danksagungen
    in 17 Beiträgen

    Standard

    Hallo,

    wenn Ihr Email unter Windows mit einer XAMPP Installation verschicken wollt, dann könnt Ihr den Mercury Mail Server einrichten. Ein Turturial findet Ihr hier. Dort habe ich gute Erfahrungen mit einer Googlemailadresse gemacht. Solltet Ihr XAMPP unter Linux (=also Lampp) benutzen, dann geht es (zumindestens bei mir) sofort. Auch dort verwende Ich eine Googlemail Adresse.

    Wichtig: Auch unter Windows habe ich es mit exakt der selben SMTP Konfiguration versucht - es geht nicht.

    Wenn es sich um eine Webseite bei einem Hoster handeln, und SMTP keine abhilfe schaffen sollte, dann gebt bitte euren Hoster an.

    Gruß PHP
    Mit freundlichen Grüßen
    PHP

    Mein Blog über CMS, Linux, PHP und mehr unter http://www.noob-blog.tk

  8. #7
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    meine installation läuft direkt aufm server und nicht aufm rechner unter xampp ;-)

    Und mein Hoster ist eine Universität ;-)

  9. #8
    PHP
    PHP ist offline
    War schon öfter hier
    Registriert seit
    30.01.2011
    Beiträge
    109
    Bedankte sich
    4
    Erhielt 18 Danksagungen
    in 17 Beiträgen

    Standard

    Hast du den schon mal reines SMTP versucht?
    Mit freundlichen Grüßen
    PHP

    Mein Blog über CMS, Linux, PHP und mehr unter http://www.noob-blog.tk

  10. #9
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    flüchtig.
    mit ner gmx-mail-adresse

    hab mail.gmx.net als host eingegeben...
    hat aber nicht funktionniert.

  11. #10
    axo
    axo ist offline
    Neu an Board
    Registriert seit
    20.09.2011
    Ort
    Saarbrücken
    Beiträge
    27
    Bedankte sich
    11
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    also, hier neue Erkenntnisse:

    Mit der Einstellung "sendmail"

    Registriert sich ein user: bekommt der Admin2 eine email-Benachrichtigung über den neu angelegten Benutzer. Admin 1 bekommt keine mail, obwohl er auch Systemnachrichten empfangen soll...

    Schreibt der Admin über joomlaBackEnd eine Massenmail: bekommt diese nur der Admin2, nicht jedoch andere Admins oder User...

    Mit der Einstellung "smtp"

    funktionniert gar kein Mail-Versand



    Am Server kann es ja dann nicht liegen ???
    Wenns chließlich der Admin2 benachrichtigt wird.....

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein