+ Antworten
Ergebnis 1 bis 9 von 9

Thema: Lokale installation: could not connect to MySQL

  1. #1
    Neu an Board
    Registriert seit
    01.01.2011
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Daumen hoch Lokale installation: could not connect to MySQL

    Hallo,
    ich möchte joomla lokal installieren.
    Habe xampp installiert.
    Habe eine Da€tenbank erzeugt.
    Habe die Installationsschritte 1 bis 3 geschafft
    Dann kommt die Fehlermeldung:
    Unable to connect to the database:Could not connect to MySQL

    Habe xampp komplett deinstalliet und alle nochmal gemacht:
    Genau der gleicher Fehler.

    Kann mir jemand weiterhelfen?
    Danke

    Stefan
    Geändert von delta920 (01.01.2011 um 10:38 Uhr)

  2. #2
    Gehört zum Inventar Avatar von Helrunar
    Registriert seit
    05.03.2006
    Ort
    /home/helrunar/Webdev
    Beiträge
    8.599
    Bedankte sich
    958
    Erhielt 2.182 Danksagungen
    in 1.928 Beiträgen

    Standard

    Was für Daten gibts Du denn für die Datenbankverbindung ein? Normalerweise reicht der Datenbankname Deiner angelegten Datenbank und root als Benutzername. In der Grundinstallation von xampp wird kein Passwort benötigt.

  3. #3
    Gehört zum Inventar
    Registriert seit
    17.09.2008
    Ort
    München
    Beiträge
    7.803
    Bedankte sich
    758
    Erhielt 2.532 Danksagungen
    in 2.199 Beiträgen

    Standard

    Was hast du denn bei den Zugangsdaten eingetragen?
    Server "localhost" Benutzer "root" Datenbankname wie angelegt.

    und: ist mysql gestartet - schau in den xampp-controller, ob das läuft

    OT: grüß dich Helrunar

  4. #4
    Neu an Board
    Registriert seit
    01.01.2011
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Im Xampp controlPaneel ist ApPache und MzSql auf "running"
    localhost und root habe ich wie vorgeschlagen eingetragen.

    Die Datenbank habe ich test2 genannt und voher installiert.
    Sie wird auch unter http://localhost/phpmyadmin/ links angezeigt.

  5. #5
    Gehört zum Inventar Avatar von Helrunar
    Registriert seit
    05.03.2006
    Ort
    /home/helrunar/Webdev
    Beiträge
    8.599
    Bedankte sich
    958
    Erhielt 2.182 Danksagungen
    in 1.928 Beiträgen

    Standard

    Hallo Lady,

    wünsch Dir ein gutes neues Jahr

  6. Erhielt Danksagungen von:


  7. #6
    Gehört zum Inventar
    Registriert seit
    17.09.2008
    Ort
    München
    Beiträge
    7.803
    Bedankte sich
    758
    Erhielt 2.532 Danksagungen
    in 2.199 Beiträgen

    Standard

    Hast du im xampp ein passwort für root definiert? Das müsstest du dann natürlich eintragen.
    Auch eine Möglichkeit:
    Versuch die Installation nochmal von vorn und zwar mit den Datenbanknamen test3.
    Erzeuge die Datenbank vorher nicht, das macht Joomla auf dem lokalen server selber.

  8. #7
    Neu an Board
    Registriert seit
    01.01.2011
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Zitat Zitat von oldlady Beitrag anzeigen
    Hast du im xampp ein passwort für root definiert?
    Nicht dass ich wuesste. Wie kann ich das pruefen?


    Zitat Zitat von oldlady Beitrag anzeigen
    Erzeuge die Datenbank vorher nicht, das macht Joomla auf dem lokalen server selber.
    Der Fehler bleibt der gleiche.

    Und auch ein gutes Jahr an die schnell helfenden Fruehaufsteher!

  9. #8
    Gehört zum Inventar
    Registriert seit
    17.09.2008
    Ort
    München
    Beiträge
    7.803
    Bedankte sich
    758
    Erhielt 2.532 Danksagungen
    in 2.199 Beiträgen

    Standard

    Seltsam .. und du hast auch bei Datenbanktyp "mysql" stehen lassen, das wird ja standardmäßig vorgegeben.
    Also da fällt mir im Moment auch nichts mehr ein, musst du wohl warten bis jemand von den anderen aufwacht.
    Ich schick dir noch eine Datei mit, vielleicht kannst du dem was entnehmen.
    Geändert von firstlady (01.01.2011 um 10:40 Uhr)

  10. Erhielt Danksagungen von:


  11. #9
    Neu an Board
    Registriert seit
    01.01.2011
    Beiträge
    11
    Bedankte sich
    5
    1 Danksagung in 1 Beitrag

    Standard

    Super, das wasrs.
    Augrund Deiner Anleitung habe ich nun endlich kapiert, dass ich lokal gar kein Passowort eingeben darf! Hat Helunar am anfang ja auch geschrieben, aber der Groschen fiel da bei mir noch nicht.

    So faengt das Jahr ja gut an - sass schon einen ganzen Abend an diesem Problem.
    Alle anderen koennen also weiteschlafen.

+ Antworten

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein