+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Webseite umgezogen, Domäne neu, Weiterlinkung

  1. #1
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Webseite umgezogen, Domäne neu, Weiterlinkung

    Tach allerseits!

    Meine alte Domäne gibt es nicht mehr, ich bin mit meiner Webseite umgezogen und nun habe ich das Problem, dass ich mich nicht mehr anmelden kann auf der Seite. Die leitet immer noch zu der alten Domäne obwohl ich eine neue Datenbank erstellt habe und diese auch in der configuration.php eintrug. Doch anstatt mich ins Adminbereich oder auf die Seite zu linken, wird die neue Domäne überschrieben und auf die alte weitergeleitet.

    Zudem steht dann folgendes auf der Seite:
    Code:
    Database Error: Unable to connect to the database:Could not connect to MySQL
    Das erste Problem ist - wieso leitet es noch auf die alte Domäne um? In der Configuration.php habe ich alles auf die neue mysql DB umgestellt (5.6)
    Geändert von Putin (10.07.2016 um 12:55 Uhr)

  2. #2
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Hab versucht die Sicherung der alten Datenbank in die neue zu importieren. Die folgende Fehlermeldung habe ich dabei bekommen.

    dfsdf.jpg

  3. #3
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.390
    Bedankte sich
    438
    Erhielt 1.930 Danksagungen
    in 1.831 Beiträgen

    Standard

    Hallo Putin,

    die alte DB hat ja sicher einen anderen Präfix (vielleicht) bzw. auch anderen Datenbanknamen usw.
    Screenshot kann man nicht lesen.
    Die configuration.php hattest Du ja schon mal angeglichen. Stimmen die logs/tmp Pfade?

    Liebe Grüße, Christine

  4. #4
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ich glaube diese Seite hier komprimiert irgendwie die Bilder. Auf jeden Fall habe ich es in höherer Qualität hochgeladen.

    So sieht der Anfang der configuration.php aus:
    Code:
    <?php
    class JConfig {
    	var $offline = '0';
    	var $editor = 'tinymce';
    	var $list_limit = '20';
    	var $helpurl = 'http://hilfe.jgerman.de';
    	var $debug = '0';
    	var $debug_lang = '0';
    	var $sef = '1';
    	var $sef_rewrite = '0';
    	var $sef_suffix = '0';
    	var $feed_limit = '10';
    	var $feed_email = 'site';
    	var $secret = 'XXXXXXXXXXXXXXXXXX';
    	var $gzip = '1';
    	var $error_reporting = '-1';
    	var $xmlrpc_server = '0';
    	var $log_path = '/opt/users/www/domain.one/logs';
    	var $tmp_path = '/opt/users/www/domain.one/tmp';
    	var $live_site = '';
    	var $force_ssl = '0';
    	var $offset = '1';
    	var $caching = '0';
    	var $cachetime = '15';
    	var $cache_handler = 'file';
    	var $memcache_settings = array();
    	var $ftp_enable = '0';
    	var $ftp_host = '127.0.0.1';
    	var $ftp_port = '21';
    	var $ftp_user = 'admin';
    	var $ftp_pass = 'XXXXXXXXXXXXXXXXXXXXXXX';
    	var $ftp_root = '';
    	var $dbtype = 'mysql';
    	var $host = 'localhost';
    	var $user = 'qXXXXXX';
    	var $db = 'qXXXXXXX';
    	var $dbprefix = 'prefix_';
    	var $mailer = 'mail';
    Meine Domäne liegt bei one.com und hat die tld "one".

    Ich habe das Bild woanders geladen
    Geändert von Putin (10.07.2016 um 18:15 Uhr)

  5. #5
    Gehört zum Inventar Avatar von christine2
    Registriert seit
    08.10.2010
    Beiträge
    5.390
    Bedankte sich
    438
    Erhielt 1.930 Danksagungen
    in 1.831 Beiträgen

    Standard

    Hab erst nachher gesehen, dass Du im J 1.5er Forum bist.

    Die configuration.php sieht auch so aus.
    Welche Joomla Version hast Du eigentlich?
    PHP Version?
    Wieso gibt es ftp user/passwort?
    Bei Datenbank $host steht: localhost
    Eigentlich sollte: mysqli verwendet werden (statt mysql) Spreche da aber J 3.5 an.

    Sorry, aber da weiß ich jetzt nicht weiter.

  6. #6
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Ich habe folgende Configuration:

    Joomla 1.5.26 + PHP 5.6 (vorher auf 5.4)

    Ich weiß nicht mehr wieso das pw gesetzt ist. Ist das relevant? Mit "localhost" lief das früher immer so.

  7. #7
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Kann mir denn wirklich Niemand helfen?

  8. #8
    Gute Seele des Boards Avatar von NinjaTurtle
    Registriert seit
    24.11.2012
    Ort
    Willich
    Alter
    53
    Beiträge
    17.665
    Bedankte sich
    658
    Erhielt 4.561 Danksagungen
    in 4.339 Beiträgen

    Standard

    Zitat Zitat von Putin Beitrag anzeigen
    Kann mir denn wirklich Niemand helfen?
    Das pushen von Beiträgen ist in diesem Forum nicht gestattet.

    Du als Putin verfügst doch über genügend Ressourcen. Statt Spionage und Propaganda können Deine Leute mal etwas vernünftiges machen.

    Mach die Seite mit J3.5.1 oder ab morgen J3.6 neu und kopier die Daten einfach. Diesen alten Schrott kannst Du eh nicht mehr gebrauchen. Vor allem wenn man wenig Ahnung von der Materie hat.

    Neue Webseite mit Joomla - Relaunch einer Joomla-Seite - Umzug?
    Erstellung, Betreuung, Backups, Updates und Hosting - Monatliche Zahlweise!
    WebMonkeyDesign


  9. #9
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Offenbar bin ich nicht der Einzige der zuwenig Ahnung hat...

    Ich brauche diese Version von jommla weil drauf module laufen, die für meinen Geheimdienst vor Jahren entwickelt wurden. Diese sind nicht mit 3.x kompatibel. Noch nicht.

    Zudem ist es offenbar ein sql Problem und es liegt nicht an joomla.
    Geändert von Putin (11.07.2016 um 14:31 Uhr)

  10. #10
    Neu an Board
    Registriert seit
    10.07.2016
    Beiträge
    9
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    So, ich habe die Lösung gefunden. Ich musste noch eine weitere SQL Tabelle erstellen - erst dann ging der import Problemlos. Also die Datenbank ist jetzt auf dem neuen Host.

    Dennoch habe ich weiterhin das Problem, dass bei der Eingabe der neuen Domäne ich zu der alten weitergeleitet werden und dann den Error 404 zurückbekomme - existiert nicht.

    Was kann es denn sein, was mich zu der alten Domäne weiterleitet? Bei der Einrichtung des neuen Hosts habe ich keine Verweise auf die alte Domäne gesetzt. Also muss es an der Datenbank oder Joomla liegen.

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein