+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: JFolder::create: Das Verzeichnis kann nicht erstellt werden!

  1. #1
    Neu an Board
    Registriert seit
    21.07.2009
    Beiträge
    75
    Bedankte sich
    9
    1 Danksagung in 1 Beitrag

    Frage JFolder::create: Das Verzeichnis kann nicht erstellt werden!

    Hallo,

    ich weiß das dieses Thema hier schon mehrfach vorkommt. Ich habe auch verschiedene Lösungen ausprobiert, aber keine hat geholfen.

    Ich bekomme immer noch folgende Fehlermeldung, wenn ich eine Komponente installieren möchte:

    JFolder::create: Das Verzeichnis kann nicht erstellt werden!
    Warnung! - Die Datei kann nicht verschoben werden!

    Diese Versuche schlugen fehl:
    http://www.joomlaportal.de/installat....html?langid=2
    http://www.joomlaportal.de/installat...dir-paths.html
    http://www.joomlaportal.de/joomla-1-...n-plugins.html
    usw.

    Datenbankversion: 5.0.91-log
    Datenbankzeichensatz: utf8_general_ci
    PHP-Version: 5.2.17
    Webserver: Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8r
    PHP-Anbindung zum Webserver: cgi-fcgi
    Joomla!-Version: Joomla! 1.5.14 Stable [ Wojmamni Ama Naiki ] 30-July-2009 23:00 GMT

    Hat vielleicht jemand einen anderen Lösungsvorschlag?


    EDIT:
    Ich habe mir nochmal die Schreibrechte angeschaut.

    Könnte vielleicht der Fehler daran liegen, dass folgende Verzeichnisse Schreibgeschützt sind?

    Log-Verzeichnis ($log_path) /mnt/web3/12/84/52103484/htdocs/joomla/logs/ Schreibgeschützt
    Temp-Verzeichnis ($tmp_path) /mnt/web3/12/84/52103484/htdocs/joomla/tmp/ Schreibgeschützt

    Wenn ja, wie hebe ich den Schreibschutz auf?
    Geändert von schnattchen00 (30.11.2011 um 18:27 Uhr)

  2. #2
    Moderator
    Registriert seit
    27.04.2006
    Beiträge
    8.812
    Bedankte sich
    344
    Erhielt 3.828 Danksagungen
    in 2.999 Beiträgen

    Standard

    FAQ Abschnitt 3.6:
    Unter Umständen passen aber auch die Pfade in der configuration.php nicht, dazu am besten eines der in Abschnitt 2.4 genannten Tools zur Anpassung der Konfiguration verwenden.
    z. B. https://www.fc-hosting.de/joomla/joomla-tools.php dort joom-config

    Dringend Joomla und alle Erweiterungen aktualisieren. Momentan ist Deine Joomla Installation akut gefährdet, damit auch Deine Webseitenbesucher. Dringend informieren über die gängigen Sicherheitsvorkehrungen, Schritt a) alles aktuell halten (momentan Joomla 1.5.25). Siehe dazu in die FAQ.

  3. #3
    Neu an Board
    Registriert seit
    21.07.2009
    Beiträge
    75
    Bedankte sich
    9
    1 Danksagung in 1 Beitrag

    Standard

    Vielen Dank für deine Antwort. Ich werde ein Update für Joomla + Komponenten durchführen.

    In dem Punkt 2.4 in den FAQ's ist das Backup-Programm Akeeba beschrieben. Genau dieses Programm wollte ich installieren und bekam die Fehlermeldung.
    Ich kann also kein Backup mit diesem Programm durchführen.

    Werde wohl die Dateien alle manuell herunterladen.

  4. #4
    War schon öfter hier Avatar von fischiimnetz1
    Registriert seit
    08.05.2007
    Ort
    Colditz
    Beiträge
    173
    Bedankte sich
    97
    Erhielt 5 Danksagungen
    in 2 Beiträgen

    Standard Kann nichts mehr installieren?

    Hallo

    Habe einen Serverumzug durchgeführt. Die Seite läuft Prima bloß es lässt sich nichts installieren. Es kommt immer diese Fehlermeldung:
    HTML-Code:
    JFolder::create: Das Verzeichnis kann nicht erstellt werden!
    Warnung! - Die Datei kann nicht verschoben werden!
    Habe die neuste Version 1.5.25 drauf und folgende PHP -Datei erstellt

    PHP-Code:
    <?php
    echo getcwd();
    ?>
    Diese dann aufgerufen: http://kleintierpraxis-hanicke.de/path.php

    Und den Path:
    Code:
    /home/web76/public_html
    in die configuration.php eingefügt. Doch der Fehler kommt immer noch.
    Hier der Code:
    PHP-Code:
    <?php
    class JConfig {
        var 
    $offline '0';
        var 
    $editor 'tinymce';
        var 
    $list_limit '20';
        var 
    $helpurl 'http://help.joomla.org';
        var 
    $debug '0';
        var 
    $debug_lang '0';
        var 
    $sef '1';
        var 
    $sef_rewrite '1';
        var 
    $sef_suffix '1';
        var 
    $feed_limit '10';
        var 
    $feed_email 'author';
        var 
    $secret 'bBDsBDs2oYdBCjF0';
        var 
    $gzip '0';
        var 
    $error_reporting '-1';
        var 
    $xmlrpc_server '0';
        var 
    $log_path '/home/web76/public_html/logs';
        var 
    $tmp_path '/home/web76/public_html/tmp';
        var 
    $live_site '';
        var 
    $force_ssl '0';
        var 
    $offset '0';
        var 
    $caching '0';
        var 
    $cachetime '15';
        var 
    $cache_handler 'file';
        var 
    $memcache_settings = array();
        var 
    $ftp_enable '0';
        var 
    $ftp_host '127.0.0.1';
        var 
    $ftp_port '21';
        var 
    $ftp_user '';
        var 
    $ftp_pass '';
        var 
    $ftp_root '';
        var 
    $dbtype 'mysql';
        var 
    $host 'localhost';
        var 
    $user 'web76_......';
        var 
    $db 'web76_bank1';
        var 
    $dbprefix 'jos_';
        var 
    $mailer 'mail';
        var 
    $mailfrom 'info@kleintierpraxis-hanicke.de';
        var 
    $fromname 'Kleintierpraxis Hanicke';
        var 
    $sendmail '/usr/sbin/sendmail';
        var 
    $smtpauth '0';
        var 
    $smtpsecure 'none';
        var 
    $smtpport '25';
        var 
    $smtpuser '';
        var 
    $smtppass '';
        var 
    $smtphost 'localhost';
        var 
    $MetaAuthor '1';
        var 
    $MetaTitle '1';
        var 
    $lifetime '15';
        var 
    $session_handler 'database';
        var 
    $password '..............';
        var 
    $sitename 'Kleintierpraxis Hanicke';
        var 
    $MetaDesc 'Kleintierpraxi Hanicke - Ihr Tierarzt in Colditz';
        var 
    $MetaKeys 'Hanicke,Tierarzt,Kleinierpraxis,Oeffnungszeiten,Thumirnicht,Colditz';
        var 
    $offline_message 'Diese Website ist zurzeit im Wartungsmodus. Bitte sp�ter wiederkommen.';
    }
    ?>
    Hat einer einen Tipp was der Fehler sein kann? Danke schon mal im Vorraus
    Joomla ist schon geil doch leider komme ich manchmal nicht weiter und benötige deshalb ab und zu eure Hilfe. Ich danke für eure Unterstützung.
    MFG fischiimnetz1
    Klick hier

  5. #5
    Gehört zum Inventar Avatar von chr-hl
    Registriert seit
    28.07.2009
    Ort
    Lübeck
    Beiträge
    5.991
    Bedankte sich
    158
    Erhielt 1.823 Danksagungen
    in 1.780 Beiträgen

    Standard

    Hallo,

    Pkt. 3.6 der FAQs hast du schon geprüft?

    Habe die neuste Version 1.5.25 drauf
    Naja, es es gibt 2.5.1

    Christian
    1. Ohne Link >>> Kein Wink!!!
    2. Konnte ich Dir helfen - dann freut ein Klick auf "Bedanke Dich"
    JUG Lübeck + develop.linsner-luebeck.de

  6. Erhielt Danksagungen von:


  7. #6
    War schon öfter hier Avatar von fischiimnetz1
    Registriert seit
    08.05.2007
    Ort
    Colditz
    Beiträge
    173
    Bedankte sich
    97
    Erhielt 5 Danksagungen
    in 2 Beiträgen

    Standard

    Danke für Deine Antwort.
    Habe das Problem gefunden. In der configuration.php stimmte alles, doch im Adminbereich unter Konfiguration stand bei dem Punkt System und Server der falsche Pfad drin.
    Joomla ist schon geil doch leider komme ich manchmal nicht weiter und benötige deshalb ab und zu eure Hilfe. Ich danke für eure Unterstützung.
    MFG fischiimnetz1
    Klick hier

  8. Erhielt Danksagungen von:


  9. #7
    Neu an Board
    Registriert seit
    12.01.2012
    Ort
    Berlin
    Beiträge
    1
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    DANKE! fischiimnetz1! Ich hatte das gleiche Problem!

  10. #8
    Neu an Board Avatar von shakkar
    Registriert seit
    14.02.2005
    Beiträge
    1
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Danke!!! Das war auch mein Fehler. Die Entwicklungsumgebung war ursprünglich in einer anderen Subdomain. Dementsprehend stand dieser Pfad noch im Admin in der Konfiguration.
    Das hätte ich ohne euch nie gefunden! :-)

  11. #9
    Neu an Board Avatar von shesmile
    Registriert seit
    08.11.2008
    Beiträge
    25
    Bedankte sich
    14
    1 Danksagung in 1 Beitrag

    Standard

    Vielen Dank! Hatte auch das gleiche Problem. Der Pfad der logs und tmp Ordner war falsch.

  12. #10
    War schon öfter hier Avatar von posttraumatisch
    Registriert seit
    22.07.2008
    Ort
    ganz in der Nähe
    Beiträge
    131
    Bedankte sich
    37
    Erhielt 5 Danksagungen
    in 5 Beiträgen

    Standard

    Wenn man bei Strato hostet gibt es die Möglichkeit im Backend einen Schreibschutz einzustellen. Dann kommt die Fehlermeldung ebenso.
    Bin ich eben nur durch Zufall drauf gekommen, meine Pfade haben gestimmt alle anderen Lösungswege scheiterten auch, ich war nahe dran einen neuen thread zu eröffnen... .

    schreibschutz.jpg
    Geändert von posttraumatisch (16.05.2013 um 16:33 Uhr)
    lg Mario

    Vertan sprach der Hahn und stieg von der Ente...

+ Antworten
Seite 1 von 2 1 2 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein