+ Antworten
Ergebnis 1 bis 8 von 8

Thema: Joomla auf qnap NAS

  1. #1
    Neu an Board
    Registriert seit
    01.01.2010
    Beiträge
    2
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard Joomla auf qnap NAS

    Hallo Zusammen,
    bin ein newboddy auf den Gebiet von Joomla und habe jetzt folgendes Problem, ich habe einen Qnap 119 NAS auf dem ich Joomla installiert habe, bis dahin kein Problem.. die Seite ist auch lokal erreichbar unter http:// NAS-ip/joomla komme ich auf die Startseite, habe jetzt auf dyndns eine weiterleitung eingegeben, nur wenn ich jetzt http://meine seite.dyndns.org/joomla eingebe kommt immer " The requested URL /joomla/ was not found on this server " an was kann das liegen

  2. #2
    Kommt häufiger vorbei
    Registriert seit
    07.12.2008
    Ort
    Wien (AUT)
    Alter
    28
    Beiträge
    418
    Bedankte sich
    8
    Erhielt 93 Danksagungen
    in 93 Beiträgen

    Standard

    warum willst du hiter die dyndns noch "/joomla" dranhängen? die sollte doch normal auf die richtige ip weitergeschalten werden, bzw warum brauchst du dyndns?

    lg

  3. #3
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.816
    Bedankte sich
    93
    Erhielt 1.621 Danksagungen
    in 1.292 Beiträgen

    Standard

    Die Adresse http://meine seite.dyndns.org/joomla wäre prinzipiell schon richtig. Du musst nur dafür sorgen, das Dein lokaler Apache-Webserver die auch auflösen kann.
    Es muss ein entsprechend konfigurierter Virtuell-Host-Eintrag existieren.

    Beachte auch:
    Wenn Du die Seite auf diese Weise so öffentlich erreichar machst, musst Du unbedingt dafür sorgen, das Deine gesammte Software (PHP, MYSQL, Apache usw.) sicher für öffentlichen Zugriff konfiguriert ist.
    Genau das ist sie aber meistens in lokalen Umgebungen ganz und gar nicht der Fall. Meistens gibt es dort KEINELEI sicherheitsrelevante Einstellungen. Das bedeuted letztlich, das Dein Rechner offen wie ein Scheunentor für jederman halbwegs gewitzen Besucher ausnutzbar wird...
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  4. #4
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.816
    Bedankte sich
    93
    Erhielt 1.621 Danksagungen
    in 1.292 Beiträgen

    Standard

    Ich habe gerade mal nach dieser Hardware recherchiert und bin hier fündig geworden, wo dann auch beschrieben wird, wie man Joomla installiert.
    Schlimm genug, das hier mit solchen vorinstallierten und wie nicht anders erwartet vollkommen veraltetene Softwarepaketen (hier 1.5.9) gearbeitet wird und Joomla mal wieder als Werbemittel mißbraucht wird. Viel graviender ist die Tatsache das man an den ScreenShots schon erkennen kann wie wenig geeignet diese Umgebung für öffentlichen Zugriff ist. So benutzt man den MySQL-root-User für Joomla. Also genauso wie bei diesen typischen xampp-Installationen. Absolut fatal !!!
    Ist ist davon auszugehen, das MYSQLund PHP leinerlei Restriktions hat und quasi alles erlaubt (ist ja auch am einfachsten bezüglich der Kompatibilität), aber absolut tödlich für öffentlichen Zugriff. Die Aktivierung des FTP-Layer läßt zudem das wwwrun-Problem vermuten...

    Also:
    Falls möglich, konfiguriere erst einmal alle Dienste sicher für den öffentlichen Zugriff. Hier sind tiefgreifende Administrator-Kenntnisse erforderlich, denn Du musst einen root-Server einrichten (nichts anderes hast Du da ja). Erst danach so einen Server für den öffentlichen Zugriff zulassen. Vermutlich läuft sogar Telnet...
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  5. Erhielt Danksagungen von:


  6. #5
    Neu an Board
    Registriert seit
    01.01.2010
    Beiträge
    2
    Bedankte sich
    1
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    also wie es bei mir aussieht heist es erstmal kräftig die Bücher wälzen.... hatte mir das ganze etwas leichter vorgestellt mit einer Joomla Site.
    Ich hatte aber wenigstens die neueste Version von Joomla installiert und nicht die mirgelieferte.Wenn ich recht verstehe muss ich erst die Reche in htacces richtif setzten bin ich da richtig.

  7. #6
    Moderator Avatar von flotte
    Registriert seit
    20.03.2005
    Ort
    Neustadt
    Beiträge
    5.816
    Bedankte sich
    93
    Erhielt 1.621 Danksagungen
    in 1.292 Beiträgen

    Standard

    Zitat Zitat von vitelotomato Beitrag anzeigen
    .... hatte mir das ganze etwas leichter vorgestellt mit einer Joomla Site...
    Wo ist denn das Problme? Passendes Webspacepaket buchen, Joomla installieren - fertig.
    Warum willst Du es auch einer lokalen Maschine betreiben? Schon wegen der Netzanbindung (Upload-Stream!) macht das normalerweise überhaupt gar keinen Sinn.
    Gruß! Uwe

    fc-hosting.de

    . . . . . . . . . . . .Gehackt? Was tun? | Themenpakete | Tools

  8. #7
    Neu an Board
    Registriert seit
    27.08.2013
    Beiträge
    1
    Bedankte sich
    0
    Erhielt 0 Danksagungen
    in 0 Beiträgen

    Standard

    Naja.. 2 Jahre her das Problem.. was solls: hier ist die Lösung

    Zugriff Adminbereich über Lokales Netz 192.168.xxx.xxx/Joomla/Adminstrator/index.php (is klar)

    Aber !!

    Zugriff über Internet mit DYNDNS: http://deine.dndns.de/Administrator/index.php (tada Ohne "Joomla")

    @ flotte
    So benutzt man den MySQL-root-User für Joomla. [...] das MYSQLund PHP leinerlei Restriktions hat und quasi alles erlaubt (ist ja auch am einfachsten bezüglich der Kompatibilität), aber absolut tödlich für öffentlichen Zugriff. Die Aktivierung des FTP-Layer läßt zudem das wwwrun-Problem vermuten...
    ..nein, stimmt alles nicht..

    + Das Problem mit dem Buchen eines Webspacepakets kannst dir selber beantworten

    ..Sei doch nicht so negativ. Bei dem ganzen rumgemotze hast du ganz vergessen vitelotomato zu helfen und ein paar nützliche Tipps zu geben..

    Viele Grüße

  9. #8
    Gute Seele des Boards
    Registriert seit
    12.03.2006
    Beiträge
    13.193
    Bedankte sich
    202
    Erhielt 3.284 Danksagungen
    in 2.999 Beiträgen

    Standard

    Fein.
    Dann stelle doch bitte hier die Anleitung ein, wie Du diese Mängel beseitigt hast. Welche QNAP hast Du und welche Firmwareversion läuft dort?

+ Antworten

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein